mit FTP Server -> kein Directory Listing wegen Hardware Router!

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • mit FTP Server -> kein Directory Listing wegen Hardware Router!

    Hi Leute!

    Ich habe ein Riesenproblem mit meinem Router und ein paar FTP Servern! Kann problemlos auf den FTP einloggen nur das Directory Listing klappt nicht - er bricht dann nach einer Zeit mit einem Timeout Signal auch ab! Sobald ich Den Router weghänge und direkt ins Netz gehe, funzt alles perfekt!! Router ist übrigens Netgear RT-314! Ein Kumpel hat mir gesagt ich müsse Port 20 zusätzlich freigeben, hat aber nix gebracht!

    Hat vielleicht jemand eine Idee was da schieflaufen kann bzw. auch eine Lösung?

    Besten Dank

    The Immortal

    P.S.: Passive Mode ist es nicht, geht sowohl mit als auch ohne nicht!
  • So ist das Problem exakt erklärt: Ah, the elusive FTP… such a bundle of problems when used without the default port of 21 in Active FTP mode! FTP has two modes, the traditional mode is called Active FTP and the newer mode is Passive FTP. Most web browsers default to passive mode and most FTP programs use Active by default.

    In Active mode if the remote FTP server wants to send a file (or a get a directory listing) it tries to open up a connection to the CL machine. This runs smoothly if connected to the FTP server on the default port of 21 (thanks to the ip_masq_ftp module). If you connected to a non-standard port (say 2000) on the otherhand, the FTP transfer or directory listing will stall & fail!

    There is a way around this however.. it's called Passive FTP and it's a blessing for NAT router users!! If your FTP client and server supports it (most do) then this mode will allow data connections from Coyote to the server, even for incoming data! If your client supports it then you should set passive mode as the default.


    Bräuchte jetzt nur noch eine Lösung!! :D :D

    Besten Dank
    The Immortal
  • Also ich weiss nicht genau was man da machen kann, aber du musst irgendwas mit portforwarding machen. *gg* Hoffe wenigstens ein bisschen was geholfen zu haben, ach ja und in dem router muss die DNS richtig eingetragen sein,
  • hmm, ich habe hier auch einen hardware router und bei mir funzt der ftp server nur mit passive mode.

    dazu habe ich das angesprochene port forwarding gemacht! einmal den port, den man braucht, um auf deinen ftp zu connecten, also z.b. 20 oder 2000; je nachdem was du eingestellt hast. und dann gibts du beim ftp server proggie noch den bereich der passive mode ports an. die müssen auch beim router eingestellet werden dass "geforwarded" (schreckliches wort) wird! :D

    ich hoffe mal, du kommst damit ein stück weiter!

    gruß
    jumper
  • -[edited]-
    problem wurde schon geklärt sry... ich wollt mein beitrag löschen nachdem es mir aufgefallen ist doch es geht leider net [nur mods vorbehalten]

    greetz dA_LoRd