Eigener FTP Server!! Problem mit Router!! HILFE!!

  • geschlossen
  • Frage

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Eigener FTP Server!! Problem mit Router!! HILFE!!

    moin!!

    also hier muss ich ja wohl hilfe bekommen ;)

    also wollte aus spaß mal mit nem ftpserver prog einen ftp einrichten..

    als programm benutze ich G6-FTP-Server...

    sitze allerdings hinter einem router.. also hat mein pc (den ich als ftp nutzen will) nur eine netzwerk ip.. (192.168.....)

    also kann ich z.b. von einem freund aus nicht auf den ftp zugreifen..

    früher hatte ich das schon öffters ausprobiert.. da hatte ich noch keinen router und hing direkt am dsl anschluss..

    wie kann ich das jetzt einrichten dass der router das weiterleitet zu der bestimmten ip vom server??

    muss doch sicher funktionieren!!!

    bitte um hilfe..

    dickes danke!!!!!

    und hier is noch nen kleines prob =)

    freesoft-board.to/f58/habe-ein…r-146230.html#post1075955
  • Das sollte eingentlich kein Problem sein.
    Die einzige Vorraussetzung, die dein Router erfüllen muss, ist, dass er Portforwarding beherrscht (also, dass er bestimmte Ports an eine lokale IP weiterleiten kann ).
    Wenn das dein Router kann, dann kannst du das im Konfigurationmenü einfach einstellen.
    Für FTP sind das die Ports 20 und 21.
    Welchen Router hast du denn genau ?
  • Thunderkill schrieb:

    also ich hab einen D-Link DI-604


    Den hab ich auch ^^
    Du musst auf 192.168.0.1 -> dann advanced -> dann Virtual Server
    Dann :
    Hacken bei enabled
    name egal zb. "ftp"
    Private IP die IP deines PCs
    Protocol Type TCP oder UDP
    Private Port und Public Port das gleiche das ist der port den du in deinem programm eingestellt hast
    schedule : always

    Dann apply klicken

    Der FTP server funktuniert nur wenn dein PC an ist
    suche crew plz PM me habe sources all over the world und haxx0r win und *nix (pma)
  • du musst schauen ob du den passive-modus im ftp verwendest oder nicht, denn danach richten sich die Ports, die du im router freischalten musst!
    eigentlich ist es so, das du entweder den port 21 ODER den Port 20 (+weitere, für die Verbindungen bei etwa 50000) freigeben musst!
    [SIZE="4"]
    Sei Realist, versuch das Unmögliche!
    [/SIZE]