load movie problem

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • load movie problem

    hi!


    also ich habe einen button auf den ich den AS

    on (release)
    loadMovieNum ("galerie.swf", 1);
    }

    aber wenn ich auf den button klicke kommt nix!
    kann mir mal einer sagen wo da der fehler liegen könnte?


    danke
  • hi!

    du hast 2 swf´s ?

    probiers mal mit dem folgendem as auf dem button:

    PHP-Quellcode

    1. on (release)
    2. {
    3. LoadMovie ("galerie.swf", 1);
    4. }


    dann sollte es klappen!

    ps: wichtig ist auch der x, y bereich wo du deine galerie lädst .. nicht, dass die außerhalb liegt .. oder so..

    darauf musst du auch achten ;)
  • danke

    ja ich hab 2 swf´s da die galerie swf größer wird will ich es eben mit load movie laden weils dann nicht so lange ladet.

    werd deinen vorschlag mal probieren!!!


    ~~~~~~~

    supa hat geklappt!!

    ich hätte da aber noch 2 fragen:
    1, wie gebe ich das mit x und y so an das es genau in meinen hauptfilm passt? macht man das mit einer if bedingung?

    2, die anderen buttons habe ich mit dem AS
    on (release) {
    _root.gotoAndPlay(15);
    }
    aber das bild 15 hat auch den namen home
    aber mit _root.gotoandplay("home"); geht es nicht.und ich weiß nicht warum.wo könnte da der fehler liegen?

    danke
  • hi!

    also das mit der x, y ausrichtung machst du am besten so:

    zuerst baust du dein hauptfilm.swf .. machst da alles fein mit navi usw.

    dann eine neue ebene, bastelst dir da grob nen content, der in die galerie.swf soll .. und makierst und kopierst das in die zwischenablage.
    dann STRG + N -> STRG + V .. voilà das passt dann schon ;)

    und das mit dem namen eines frames ansprechen hatte ich auch schon mal .. bei mir hatte ich nur irgendeinen doofen semantischen fehler also fehlerhafte namensgebung .. kontrollier noch mal, obs daran liegen könnte .. wenn nicht .. :confused: ;) :D
  • danke werd das mal checken!
    falls das mit den instanznamen nicht geht lasse ich die bildnummer!

    ~~~~~~
    was is noch bemerkt habt ist wenn ich jetzt zb zuerst auf den button home klicke kommt der inhalt.aber wenn ich dann auf den button der galerie klicke überlagert sich das.muss ich da einfach ein unloadmovie oder so drüber tun oder wie kann ich das lösen?
  • in wiefern überlagert sich das denn??

    du kannst
    1. mit LoadMovie("galerie2.swf", 1)
    den nächsten mc "überschreiben" / "überladen" oder
    2. mit unloadmovie das ding wieder entladen ..