sendmail unter RedHat -> Mail an unbekannte Nutzer

  • Problem

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • sendmail unter RedHat -> Mail an unbekannte Nutzer

    Hallo alle zusammen! :)

    Ich hab da mal ein kleines Problem :eek: :read:

    Nach einem Neustart des Systems werden Mails an lokal unbekannte Nutzer (auf diesem System also nahezu alle) nicht mehr an den im Netz vorhandenen "echten" Mailer (der die Nutzer kennt) weitergeleitet.

    Ich habe nun per sendmail.mc und m4 den "echten" Mailer wieder als SMART_HOST auf dem Rechner eingetragen.

    (Eintrag in der sendmail.mc:
    define(`SMART_HOST´,`mailserver.meine.domäne.de´)

    Nach Aufruf von m4 ergibt ein cat sendmail.cf|grep mailserver auch folgendes:
    DSmailserver.meine.domäne.de
    Das m4 scheint also funktioniert zu haben)

    Danach habe ich natürlich brav sendmail neugestartet (einmal mittels "service sendmail restart" und als das nichts gebracht hat, mittels Reboot).

    Trotzdem probiert er immer, die Mails lokal zuzustellen.

    Der DNS funktioniert, also kann es an der Auflösung von [email protected] nicht liegen.


    Wenn ich einfach per mail -s "Test" [email protected] probiere mir eine Mail zu schicken, hängt der Prozess und tut (augenscheinlich?) nichts.

    Probiere ich testweise sendmail -v [email protected]<Testdaten bekomme ich folgendes zu sehen:

    [email protected].. Connecting to [127.0.0.1] via relay...
    220 meine.domäne.de ESMTP Sendmail 8.12.8/8.12.8; Tue, 21 Mar 2006 15:43:34 +0100
    >>> EHLO meine.domäne.de
    250-meine.domäne.de Hello server1 [127.0.0.1], pleased to meet you
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    250-8BITMIME
    250-SIZE
    250-DSN
    250-ETRN
    250-DELIVERBY
    250 HELP
    >>> MAIL From:<[email protected]> SIZE=33
    250 2.1.0 <[email protected]>... Sender ok
    >>> RCPT To:<[email protected]>
    >>> DATA
    550 5.1.1 <[email protected]>... User unknown
    503 5.0.0 Need RCPT (recipient)
    >>> RSET
    250 2.0.0 Reset state
    >>> RSET
    250 2.0.0 Reset state
    root... Using cached ESMTP connection to [127.0.0.1] via relay...
    >>> MAIL From:<> SIZE=1057
    250 2.1.0 <>... Sender ok
    >>> RCPT To:<[email protected]>
    >>> DATA
    250 2.1.5 <[email protected]>... Recipient ok
    354 Enter mail, end with "." on a line by itself
    >>> .
    250 2.0.0 k2LEhY7W003199 Message accepted for delivery
    root... Sent (k2LEhY7W003199 Message accepted for delivery)
    Closing connection to [127.0.0.1]
    >>> QUIT
    221 2.0.0 meine.domäne.de closing connection


    Hier noch ein paar Fakten die evtl. wichtig sind?

    Distribution
    Red Hat Linux release 9 (Shrike)

    uname -sirmo
    Linux 2.4.20-8 i686 i386 GNU/Linux

    rpm -qif $(which sendmail)
    Name: sendmail
    Version: 8.12.8
    Release: 4
    Vendor: Red Hat, Inc.
    Relocations: (not relocateable)
    Build Date: Die 25 Feb 2003 01:16:00 CET


    Das Aufsetzen des Systems ist schon recht lange her und ich kann mich nicht erinnern, damals großartig etwas am sendmail ein- oder umgestellt zu haben.
    Nur nach dem Neustart jetzt ging es einfach nicht mehr.

    Hoffe ihr könnt mir helfen :hy:
    So groß kann der Fehler ja eigentlich nicht sein, da ja - wie gesagt - vor dem Neustart alles noch ging :(

    Falls ihr noch mehr Infos bzgl. des Systems braucht, einfach melden.

    Danke & Gruß,
    Commander Keen
    Ich habe das Wort "Europa" immer im Munde derjenigen Politiker
    gefunden, die von anderen Mächten etwas verlangten, was sie im
    eigenen Namen nicht zu fordern wagten. [SIZE="1"](Nov. 1876)[/SIZE]
    [SIZE="1"]Otto von Bismarck[/SIZE]
  • Sieht ja eignetlich alles gut aus.

    Für mich sieht auch die Ausgabe für sendmail (beim Testmail) nach einer Erfolgsmeldung aus. Das Mail kommt allerdings nicht an?

    Hast du denn Zugriff auf den Mail-Server? Evtl. ist da ja was umkonfiguriert worden, da es ja so plötzlich nicht mehr lief.

    Das syslog sagt auch nix?

    Wegen dem "mail"-Befehl:
    Der hängt nicht, der Wartet nur auf einen Punkt (".") auf einer einzelnen Zeile gefolgt von einer Leerzeile um das Mail abzuschicken ;)


    -purx
    [SIZE=1]"There's no right, there's no wrong, there's only popular opinion." Jeffrey Goines (Brad Pitt) in Twelve Monkeys[/SIZE]

    [SIZE=1]$ killall chico[/SIZE]
  • Danke schonmal für deine Antwort!

    Mist. Der Punkt... manchmal vergisst man die einfachsten Dinge :depp: :read:
    Das werd ich nochmal testen müssen :)

    Allerdings wird das wohl nichts ändern, denn es kommen auch Mails aus Skripten nicht an, die vorher einwandfrei funktionierten.

    Ich habe auch Zugriff auf den Hauptmailserver, auf dem ist aber - laut Rücksprache mit Kollegen - nichts verändert worden. (Kann man davon ausgehen, dass das so stimmt.)

    Komisch natürlich vorallem auch, dass alles nach einem simplen Reboot nicht mehr funktioniert hat.

    Inwiefern im "syslog"? Wenn du mir sagen kannst, wo genau ich Mailing-relevante Daten finden kann schau ich gerne mal nach :)
    (Ich bin noch ein ziemlicher Linux-N00b ;) ).

    Ich glaub ich hatte schon unter /var/log oder /var/maillog (weiß nicht mehr genau) nachgeschaut. Konnte allerdings nichts entdecken was mir weitergeholfen hätte... :(

    Vielleicht hast du oder jemand anders noch eine Idee?

    Gruß,
    Commander Keen

    P.S.: Ist ein Rechner auf Arbeit, drum kann ich jetzt hier leider nichts testen.
    Ich habe das Wort "Europa" immer im Munde derjenigen Politiker
    gefunden, die von anderen Mächten etwas verlangten, was sie im
    eigenen Namen nicht zu fordern wagten. [SIZE="1"](Nov. 1876)[/SIZE]
    [SIZE="1"]Otto von Bismarck[/SIZE]
  • Auf meinem Rechner hab ich für jedes Log-Level ein eigenes File:

    /var/log/mail.log
    /var/log/mail.err
    /var/log/mail.info
    /var/log/mail.warn

    Vielleicht helfen dir ja die Files, sonst unbedingt mal das logging einschalten.

    Jeder nicht funktionierende Aufruf ist dann registriert und das Problem kann weiter eingegrenzt werden...
    [SIZE=1]"There's no right, there's no wrong, there's only popular opinion." Jeffrey Goines (Brad Pitt) in Twelve Monkeys[/SIZE]

    [SIZE=1]$ killall chico[/SIZE]