VNC per SSH installieren...

  • Suse

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • VNC per SSH installieren...

    Hi @ all...

    Ich habe mir einen vServer gemietet. Darauf läuft SuSE Linux 9.3! Da ich eingendlich ein Windoofler bin und mich eigentlich nur ein wenig mit Linux auskenne möchte ich dadrauf RealVNC installieren.

    Soweit sogut... mit WGet per SSH-Console die .rpm raufgeladen und dann mit

    rpm -Uvh realvnc...rpm

    das ganze installiert... aber nun gehts los ?!?!? jetzt weiß ich net weiter... eigentlich müsste man ja nur eingeben:

    vncserver

    und er sollte eigentlich starten... dabei kommt folgendes Problem in der .log :

    Quellcode

    1. Xvnc Free Edition 4.1.1 - built Mar 11 2005 16:09:48
    2. Copyright (C) 2002-2005 RealVNC Ltd.
    3. See http://www.realvnc.com for information on VNC.
    4. Underlying X server release 40201000, The XFree86 Project, Inc
    5. Wed Mar 22 20:12:53 2006
    6. vncext: VNC extension running!
    7. vncext: Listening for VNC connections on port 5901
    8. vncext: Listening for HTTP connections on port 5801
    9. vncext: created VNC server for screen 0
    10. error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
    11. Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from l ist!
    12. Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
    13. Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from list!
    14. Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from li st!
    15. Could not init font path element /usr/X11R6/lib/X11/fonts/75dpi/, removing from list!
    16. Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!
    17. Fatal server error:
    18. could not open default font 'fixed'
    19. /root/.vnc/xstartup: line 4: xsetroot: command not found
    20. /root/.vnc/xstartup: line 6: xterm: command not found
    21. /root/.vnc/xstartup: line 7: twm: command not found
    22. vncconfig: unable to open display "####:1"
    Alles anzeigen


    Ich hab einfach kein Plan was ich machen soll... bin schon am verzweifeln... pls help me...

    MFG
  • Da ich gerade kein Linux-System vor der Nase habe, kann ich dir nur aus dem Kopf helfen.

    VNC hat mehrere Konfigurationsdateien. In denen stehen beispielsweise Pfade drin, die - je nach Installation des Betriebssystem - angepasst werden müssen.

    Such mal nach der Datei vncconfig
    Sie kann entweder im .vnc Ordner im Homedirektory stehen oder unter /etc

    Prüfe, ob alle eingetragenen Pfade mit deinem System übereinstimmen und ob alle Dateien da liegen, wo sie gesucht werden.

    Zweitens solltest du die Dateien in .vnc überprüfen. Da können ebenfalls Sachen drin stehen, die auf deinem System angepasst werden müssen.

    Und Drittens: um VNC zu starten, muss bereits ein gestartetes aktives X-Windows vorhanden sein. Die Environment-Variable DISPLAY muss auf dieses X-Windows zeigen. Das macht der X-Server beim Start automatisch. Allerdings ist diese Variable nur in Sessions sichtbar, die auch über den X-Server gestartet wurden! Nicht über ssh-Sessions.

    Du musst also vor dem Starten des VNC-Servers ggf. dein X-Windows starten und die DISPLAY-Variable von Hand darauf setzten. Typisch ist

    Quellcode

    1. export DISPLAY='name_des_eigenen_rechners:0'

    Der Doppelpunkt und die Null am Ende müssen fast immer so stehen.

    Grüße
    Michael
  • THX FOR Help schonmal... hatte das aber schon geschaft...
    Hab folgendes gemacht:
    1. XFree86 RPM installiert
    2. RealVNC RPM installiert
    3. Mit SSH und YaST2 in der Console den VNC Server konfiguriert

    Aber soweit sogut ;) ... funzt zwar alles ABER nun hab ich ein neues Problem :D... ich habe nur eine graue oberfläche mit nem 45° Fadenkreuz...

    Nun hab ich echt n Problem... was hat denn das zu bedeuten ???

    mfg rave