Warum steht bei mir manchnal buffer underrun

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Warum steht bei mir manchnal buffer underrun

    Hi ich habe einen Plextor 40-fach brenner und manchmal bekomme ich die meldung buffer underrun was das bedeutet weiß ich, wieso kommt das aber manchmal 19 mal bei einem brennvorgang vor ?
    Liegt es daran das ich zu wenig arbeitsspeicher habe?
    Also ich habe einen Athlon 1 ghz, mit 128 mb arbeitsspeicher mit win XP.
    Alle programme sind zu dem zeitpunkt closed.
    Und wieso brauche ich beim brennenn von cd´s so um die 4 min. müßte doch eigentlich schneller sein oder ?

    Gruß

    Chris
    Fahre niemals schneller als dein Schutzengel fliegen kann !!!
    Zum Glück schafft mein Engel locker 300 km/h
  • Buffer-Underrun

    Beim Schreiben einer CD müssen die Daten kontinuierlich geschrieben werden, d.h. es darf keine Pause im Datenstrom geben. Bei z. B. 2-facher Brenngeschwindigkeit heißt dies, dass die Daten mit 352 KB / Sekunde geschrieben werden.
    Da natürlich der Rechner keinen konstanten Datenstrom liefern kann (da er die Daten blockweise überträgt), besitzen die CD-Recorder einen Bufferspeicher, in dem die vom Rechner gesendeten Daten zwischengespeichert und dann mit der richtigen Rate zum Schreiblaser gesendet werden.
    Der Bufferspeicher beträgt je nach Rekorder 512 KB - 4 MB (Siehe: Device-Eigenschaften / Recorder-Eigenschaften).

    Schaft der Rechner es nicht, während des Schreibvorgangs den Buffer immer wieder aufzufüllen (d.h. wird der Buffer komplett geleert), hat der Schreiblaser keine Daten mehr, der Schreibvorgang muss also abgebrochen werden. Diesen Zustand nennt man "Buffer Underrun".
    Leider ist ein "Wiederaufsetzen" das Schreiblasers normalerweise nicht möglich (es sei denn, der Recorder beherrscht "Burn-Proof"), die CD kann also nach einem Buffer-Underrun nicht weiter beschrieben werden, sie ist defekt. (Die bereits beschriebenen Teile können in dem Recorder abgespielt werden)

    Auch Burn-Proof schafft es nicht, wieder EXAKT an der Stelle aufzusetzen, wo der Schreibvorgang abgebrochen wurde. Burn-Proof schafft es aber, so "nah" wieder "aufzusetzen", dass es nachher für den CD-Player nur wie ein kleiner Kratzer auf der CD "aussieht", d.h. die Fehlerkorrektur des CD-Players wird aktiv und korrigiert diesen kleinen "fehlerhaften" Bereich auf der CD.
  • Durch die heutigen ATAPI-Brenner kann es auch zu Buffer-Underuns kommen wenn Brenner und Platte z.B. an einem Strang hängen, da immer nur eines der zwei Geräte zur selben Zeit bedient werden kann. Der Effekt tritt vermehrt bei hohen Brenngeschwindigkeiten auf. Sollte man ein Board haben, das sogar beide ATAPI Stränge mit nur einem Controller bedient ist der Effekt derselbe, wie oben beschrieben. Abhilfe schafft also nur: Brenner und Platte auf der das Image oder die temp-Dateien angelegt werden müssen an zwei verschiedenen Strängen hängen oder bei Billigboards mit nur einem Controller einen SCSI-Brenner verwenden.

    Greetz :hy:
  • Mein Board hat 4 IDE-Ports und der Brenner hängt ganz alleine an einem. Also kann es da schonmal zu keinen Konflikten kommen, desweiteren besitzt der Brenner einem Cache von 2 oder 4 MB da bin ich mir nun nicht sicher und beim Brennen läuft normalerweise kein Prog., daher dürfte es ja eigentlich keinen Buffer-Underrun geben. Es könnte mir ja auch egal sein, da Plextor ja einen Burn-Proof drin hat. Nur es wundert mich dann trotzdem, dass der Bufferunderun passiert. Man sieht dann beim brennen auch wie die Speicher, bei Nero, von 100 % auf null runter geht und dann wieder hoch und je nachdem wie oft dies geschieht tritt dann eben der Bufferunderun auf. Nur die Ursache kenne ich nicht, wie gesagt es läuft nur das reine Brennprogramm sonst nichts und es tritt zwar nicht immer auf aber so 30 %.
    Deshalb meine Vermutung wegen dem Arbeitsspeicher, desweiteren dauert es für einen 40 fach Brenner meines Erachtens zu lange für 700er Rohlinge 4 -5 min zu brennen. Er müßte ja rein theorethisch reine Brenndauer ohne Lead in/out 2 min brauchen. Jetzt noch Lead in/out 1 min dann kommt man ja auf 3 und nicht auf 4 oder 5.
    Eigentlich macht es mir ja nichts aus nur mich würde interessieren wie es dazu kommt.
    Fahre niemals schneller als dein Schutzengel fliegen kann !!!
    Zum Glück schafft mein Engel locker 300 km/h
  • Hast Du schon einmal nachgesehen, ob Windoof Deine Platte(n) denn auch im DMA-Modus bedient? Im Prozessorlastigen PIO-Modus könnte Dir auch der Brenner zu langsam versorgt werden. Zum Thema Arbeitsspeicher: 256 MB sollten es unter XP möglichst schon sein, um andauerndes Swapen von Windows zu vermeiden (auch diese Festplattenzugriffe stören beim Brennen).

    Greetz :hy:
  • Jetzt mußt du mir nur noch sagen wie ich den DMA-Modus einstellen kann :D

    Mit Problem mit dem Arbeitsspeicher ist bald aus der Welt, Vom Weihnachtsgeld hole ich mir erstmal eine neue CPU, ein Mainboard, eine Grafikkarte und DDR-Ram. :D
    Fahre niemals schneller als dein Schutzengel fliegen kann !!!
    Zum Glück schafft mein Engel locker 300 km/h
  • Das liegt nciht daran...deinstalliere einfach die Boardtreiber... war auf jeden Fall bei mir so und es hat geholfen... :)
  • ja genau...ich muss aber dazu sagen, dass ich ein Epox Board hab...