Linux-Suse 10 problem nach installation

  • Problem

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Linux-Suse 10 problem nach installation

    hallo,

    hab mir heute mal vorgenommen linux auszuprobieren,

    die installation verlief ohne probleme,

    als ich dann linux starten wollte ---> schwarzer bildschirm, keine reaktion

    dann bin bei der startauswahl auf linux (und dahinter irgendwas in klammern, weiss nichmer was) gegangen, und hab dann dort die ganzen updates ect, installiert und konfiguriert.

    jedoch immernoch das gleiche problem.

    wenn ich wieder auf das linux (mit dem dahinter geschriebenen wort in klammern gehe^^)

    dann kommt login

    benutzername und PW erfolgreich eingegeben...

    Linux@"benutzername" have fun oder so...

    was muss ich jetzt machen um das in gang zu bekommen?

    bei der installation habe ich gesehen das meine graka erkannt wurde und mit 800* 600 laufen sollte

    was muss ich denn machen um nicht nur black and bluescreen zu bekommen^^


    danke schonmal
  • es könnte daran liegen, dass entweder deine grfaikkarte nicht, bzw. nicht richtig unterstützt wird (besonders bei neuen).

    Aber eins kann ich dir sagen Linux läuft bei dir schon, denn genau das "Ding" mit

    Linux@"benutzername" bist eigentlich du in Linux, d.h das system läuft aber ohne grafischen oberfläche ;)

    Ok.

    also es kann natürlich auch daran liegen, dass das system nicht automatisch auf die grafische oberfläche umschaltet, man kann es auch manuell tun:

    1. melde dich als root an:

    #su

    dann gib das rootpasswort ein und enter

    danach

    #init 3

    das soll dich auf die grfaische oberfläche umschalten

    edit: alle befehle ohne "#" einzugeben

    wenn es nicht klappt, versuche die xorg.conf datei zu reconfigurieren, vielleicht tratt es ein fehller bei der configuration auf, zum reconfigurieren melde dich wiederum als root an

    dann gib folgendes ein:

    #dpkg-reconfigure xserver-xorg

    die genauere beschreibung der reconfiguration findest du hier

    edit:vergiess nicht, dass du SUSE hast und nicht UBUNTU, d.h alle befehle, die mit sudo beginnen sollst du ohne sudo eingeben, aber melde dich vorher als root an.

    Und noch eins, wenn du auf linux umsteigen willst, dann sollst du viel viel und noch mehr lesen. Hier eine wunderschöne seite für SUSE LINUX USER, besonders für die einsteiger gedacht, da kannst beliebige fragen stellen; im WIKI BREICH sind da auch viele Howto's; sollst einfach sufu nutzen.

    ok ich hoffe ich konnte dir halbwegs helfen :)


    mfg Allonewalk
  • Du kannst auch mal versuchen am Bootbildschim die Option
    vga=normal

    einzugeben und damit in den Runlevel3 zu booten.

    Danach würde ich versuchen mit
    sax2 -a

    eine Standartkonfiguration für den X-Server zu erstellen. Anschließend mit
    sax2

    die Einstellungen prüfen die erstellt wurden. Als letzten Schritt dann noch den VESA Treiber laden durch die Eingabe
    sax2 -r m 0=vesa

    Danach wieder in den Grafikmodus (Runlevel 5) wechseln. Das hat zumindest bei einem Bekannten zu Erfolg geführt und hilft vielleicht auch hier.

    Denk auch dran das wenn du eine Grafikkarte von ATI oder Nvidia hast die notwendigen Grafiktreiber von der Herstellerseite zu laden und zu installieren. Diese werden ab der Version 10.2 nicht mehr mitgeliefert wodurch solche Dinge wie 3D Unterstützung fehlen.
  • hallo,

    ich hab das alles so gemacht wie du gesagt hast, und bei dem erstellen und überprüfen von der standartkonfiguration hab ich sogar mal eine grafische oberfläche gesehen^^ (frage ob ich die einstellungen akzeptiere), bin aber dann gleich wieder in den blackscreen modus zurückgeworfen worden.

    dann hab ich diesen VESA treiber geladen und es stand dort NVIDIA, also vermute ich mal er erkennt meine graka.

    dann bin ich (glaub ich) wieder in den runlevel 5 gewechselt.
    das ist doch der ganz normale start von linux oder?
    oder wie komm ich in den runlevel 5?

    ja, und wieder das gleiche problem --> alles black! (ausser 2-3 blaue pixel oben:confused: )

    danke

    L3x
  • Ich hab schon fast das Gefühl das dein Monitor falsch angesteuert wird. Grund könnte der fehlende original Nvidia Treiber sein der ja nicht mehr enthalten ist auf der Suse DVD. Das beste ist das du den passenden aktuellen Nividia Treiber runterlädst und installierst. Auf der Suse Seite gibt es glaube ich eine Anleitung wie man das machen mußt.

    Im Runlevel 3 Modus kannst du auch mal prüfen ob alle xorg-Server Pakete installiert sind. Zur Not nachinstallieren wenn welche fehlen sollten bzw. nochmal neu installieren. Dazu einfach "yast" eintippen nachdem du dich als Admin angemeldet hast und die Pakete suchen lassen.
    Soweit ich weiß gab es auch wenige Wochen nach Veröffentlichung der aktuellen Suse Version auch ein Update der xorg-Pakete. Daher vielleicht auch gleich ein Online Update machen wenn du schon mal in Yast drin bist.