.htaccess problem ohne login

  • Allgemein

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • .htaccess problem ohne login

    Hallo Leute,
    ich möchte für nen shop den admin bereich sperren bzw sichern mit einem passwort!
    ich habe die .htaccess datei über das programm ispconfig geschrieben und sollte eigentlich sofort funktionieren! nun starte ich es im explorer und ich komme trotzdem noch in adminbereich!
    ich verstehe es nicht! liegt es am server?
    liegt es an mir?
    bitte um rat!

    MfG
    Olek
  • also der Server muss natürlich .htaccess können. Ich bin bei Strato, da gehts. Nimm doch einfach mal einen Generator. Google mal nach .htacces Generator. Da gibst du einfach den absoluten Pfad (gaaanz wichtig) an und den benutzernamen und passwort und es werden die Datein angezeigt und was du damit machen musst.

    So habe ich es gemacht und nach ein paar dämlichen Fehlern von mir gings dann auch.

    edit: Hier mal was bei mir in der .htaccess steht:

    AuthUserFile /home/strato/www/ka/www.xyz.de/htdocs/Intern/.htpasswd
    AuthGroupFile /dev/null
    AuthName Intern
    AuthType Basic
    <Limit GET>
    require valid-user
    </Limit>

    Gruß
    Tina
    --- Das Leben ist zu kurz für ein langes Gesicht ---
  • der xxxx funktioniert immernoch net!
    bei mir siehts so aus!

    AuthType Basic
    AuthName "Members Only"
    AuthUserFile /var/www/web15/web/test/.htpasswd
    <limit GET PUT POST>
    require valid-user
    </limit>


    Olek

    Auf nen anderem Server läuft es!
    Wie kann ich es auf meinem server umstellen?
  • Also bei meinen Bemühungen der Fehlersuche habe ich folgende Aussagen erhalten:

    Wenn der Sprung auf die geschützte Seite gänzlich ohne Anzeige der Passwortabfrage geht, dann liegt die .htaccess im falschen Ordner.
    Geht die Passwortabfrage auf, aber das Passwort wird nicht akzeptiert, dann ist der absolute Pfad falsch.

    Da du ja "ungehindert" auf die Members only kommst, liegt wohl .htaccess im falschen Verzeichnis.

    lg
    Tina
    --- Das Leben ist zu kurz für ein langes Gesicht ---
  • also ich bin der meinung das ich alles richtig habe!
    immerhin funktioniert es auf einem anderm server!
    bin der meinung das es am server liegt!
    Kennst du dich mich ispconfig aus?
    wo und wie kann man es einstellen?
    mein admin kann ich grad nicht erreichen!