Mouseover effekt funktioniert nicht richtig

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hallo liebe FSBler,ich will mir grad ne neue homepage machen und dabei bei der navigationsleiste nen mouse over effekt einbringen.Eigentlich geht es aber irgendwie hab ich nen schwarzen rand um mein wort rum.Schauts euch einach mal an

    Hier

    oben nochmal ein button wie er eigentlich sein sollte ,also nur statt home steht halt about aber schriftfarbe usw is die selbe.

    Hier mal mein

    Quellcode

    1. <img src="http://neuner9.ne.funpic.de/homepage/buttons/home.png" alt="Home" border="0" style="filter:alpha(opacity=1000);
    2. " onMouseover="high(this)" onMouseout="low(this)" width="89" height="46">
    3. <script language="JavaScript" type="text/JavaScript">
    4. function high(which2) {
    5. theobject=which2
    6. highlighting=setInterval("highlightit(theobject)",50)
    7. }
    8. function low(which2) {
    9. clearInterval(highlighting)
    10. if (which2.style.MozOpacity)
    11. which2.style.MozOpacity=0.3
    12. else if (which2.filters)
    13. which2.filters.alpha.opacity=30
    14. }
    15. function highlightit(cur2) {
    16. if (cur2.style.MozOpacity<1)
    17. cur2.style.MozOpacity=parseFloat(cur2.style.MozOpacity)+0.1
    18. else if (cur2.filters&&cur2.filters.alpha.opacity<100)
    19. cur2.filters.alpha.opacity+=10
    20. else if (window.highlighting)
    21. clearInterval(highlighting)
    22. }
    23. </script>
    Alles anzeigen



    Ich hoffe ihr könnt mir helfen.Wenn es falsches Forum ist bitte verschieben.

    Greetz

    *push*
    kann mir niemand helfen?
  • Ähm ich weiß nicht, was das Problem ist.
    Wenn ich über die Home-Schaltfläche fahre, wird Home deutlicher, der Mouseovereffekt funktioniert.
    Einen schwarzen Rand seh ich nicht.
    EDIT: Ist nur im IE so, im Firefox wird das richtig angezeigt.
    Kp, wieso das so ist. Fehler im IE?

    Gruß Moritz