IntelliJ IDEA 7 -> erkennt kein Java

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • IntelliJ IDEA 7 -> erkennt kein Java

    Hi,
    ich bin frischer Besitzer des Programms IntelliJ IEDA 7 und wollte auch gleich loslegen mit dem JAVA Programmieren...
    Ich habe als Test, das "Hello World!"-Programm nach einem Video von der jetbrains Homepage realisiert (klick)
    Jedoch steht bei mir unter String[] "Cannot resolve symbol 'String'..." Und "System" scheint dem Programm auch unbekannt :\

    Ich habe die aktuelle Java Version und diese auch eingestellt

    Jedoch wird kein Java-Wort, außer die vordefinierten erkannt. Wenn ich hello kompiliere erscheint zwar, dass es erfolgreich kompiliert wurde, aber kein Programm/Ergebnis, wie im Video zusehen :(

    Was kann ich tun?


    Danke schonmal und Gruß
    Broken Sword

    P.S.
    Habe nun schon ein paar Java spezifische Foren aufgesucht, aber keine Antwort bekommen...
  • Was verstehst du unter einem Java-Wort außer den vordefinierten?

    Ansonsten auf den ersten Blick siehts ja auch richtig konfiguriert aus.
    Würde vielleicht nicht umbedingt in den Ordner die Projekte compilieren lassen, aber das ist Geschmackssachen.

    Ein Sample Code wäre vielleicht nicht schlecht mit Fehlermeldung ;)
  • Hi, eigentlich wurden deine Fragen in meinem Post schon beantwortet :P

    Wie zum Beispiel "String". das sollte ein Java-Editor doch kennen, genauso wie "System"... aber bei mir wird nichts angezeigt. Fehlermeldung steht im Post => "Cannot resolve symbol 'String'..." ;)

    Bsp. (Wie im angegebenen Link halt :\)

    Quellcode

    1. package hello;
    2. /**
    3. * Created by IntelliJ IDEA 7
    4. * User: Broken
    5. * Date: 26.11.2007
    6. * Time: 18:54:48
    7. *
    8. * Package: hello
    9. */
    10. public class hello {
    11. public static void main(string[] args) {
    12. system.out.println("Hello World!");
    13. }
    14. }
    Alles anzeigen


    Gruß
    Broken Sword
  • Broken Sword schrieb:

    Hi, eigentlich wurden deine Fragen in meinem Post schon beantwortet :P

    Wie zum Beispiel "String". das sollte ein Java-Editor doch kennen, genauso wie "System"... aber bei mir wird nichts angezeigt. Fehlermeldung steht im Post => "Cannot resolve symbol 'String'..." ;)

    Bsp. (Wie im angegebenen Link halt :\)

    Quellcode

    1. package hello;
    2. /**
    3. * Created by IntelliJ IDEA 7
    4. * User: Broken
    5. * Date: 26.11.2007
    6. * Time: 18:54:48
    7. *
    8. * Package: hello
    9. */
    10. public class hello {
    11. public static void main(string[] args) {
    12. system.out.println("Hello World!");
    13. }
    14. }
    Alles anzeigen
    Gruß
    Broken Sword


    du musst bei

    PHP-Quellcode

    1. system.out.println("Hello World!");
    das wort system mit einem Großbuchstaben beginnen, also :

    PHP-Quellcode

    1. System.out.println("Hello World!");
    das gleiche mit String auch.

    MFG
  • Okay ich hab den starken verdacht, das liegt an einem sehr einfachen Fehler.
    Java ist nun mal ziehmlich case-sensitiv
    String schreibt man immer gross
    und System auch ^^
    Ich werds jetzt gleich nochmal durchtesten, aber imho wars das schon :)

    *edit*
    LoL, okay hat sich wohl erledigt ^^
    Ist aber nur komisch, das dir sonst niemand hat helfen können, in den anderen Java Foren.
    Tja, was das posten von dem eigenem Code oft alles helfen kann :D
    Achja und in dem Video steht auch alles in gross *g*
  • Hmm.. das wärs ja, wenn das der Fehler wäre ^^
    Dann hätte ich mir selber in den Hintern getreten... Aber zum Glück bleibt alles wie gehabt.

    DOCH...auf einmal erscheinen beim Kompilieren vier Fehlermeldungen :)

    Quellcode

    1. connot access java.lang.Object
    2. class file for java.lang.Object not found
    3. cannot find symbol class String
    4. package System does not exist
    5. connot access java.lang.String
    6. class file for java.lang.String not found


    Gruß
    Broken Sword
  • package hello; // <-- das rauslöschen!

    /**
    * Created by IntelliJ IDEA 7
    * User: Broken
    * Date: 26.11.2007
    * Time: 18:54:48
    *
    * Package: hello
    */
    public class hello {
    public static void main(string[] args) {
    system.out.println("Hello World!");
    }
    }


    Oben in der ersten Zeile meine ich. Das einfach rauslöschen...
  • Ja, aus dem Code geht ja hervor
    "package hello;"
    Hast du denn wirklich auch eins erstellt?
    Wenn nicht, muss das natürlich einfach rausgelöscht werden.

    Und ansonsten wäre es nicht schlecht wenn du nochmal ne screen von den Projekt Settings machen könntest, aber diesesmal, dann auf Platform Settings/JDKs gehst, damit man da mal nachsehen kann was bei dir eingestellt ist.

    Wobei, daran wirds wohl auch net liegen.
    Denke mal das es wirklich an dem fehlendem package liegt.
    Aber sowas müsste doch eigentlich alles zur Runtime schon angezeigt werden.
    Zumindest ist das in Eclipse so und jetzt sollte ja eigentlich dieses IDEA so toll sein.
    Gleich mal testen *g*
  • Achso (sag das doch :P)...
    Aber leider keine Veränderungen sichtbar :\

    Gruß
    Broken Sword

    edit

    stelzi schrieb:

    Ja, aus dem Code geht ja hervor
    "package hello;"
    Hast du denn wirklich auch eins erstellt?
    Wenn nicht, muss das natürlich einfach rausgelöscht werden.

    Hat das Ding (wie im Video) automatisch gemacht.


    stelzi schrieb:


    Und ansonsten wäre es nicht schlecht wenn du nochmal ne screen von den Projekt Settings machen könntest, aber diesesmal, dann auf Platform Settings/JDKs gehst, damit man da mal nachsehen kann was bei dir eingestellt ist.


    Ja, das ist auch ein Punkt der mich stutzich gemacht hat. Dort steht halt der Homepath (C:\Programme\java\jre1.6.0_03) aber bei classpath und den anderen Optionen ist nichts zu finden. Dachte mir aber, dass das so soll :\

    Gruß
    Broken Sword
  • Okay dann liegt hier der Hund begraben, anscheinend ist beim installen / configurieren mist gebaut worden.
    Sollte nämlich so aussehen:


    Versuch nochmal unter General unter Projekt JDK, das JDK neu zu adden.
    Also new, und dann den root folder vom JDK angeben.