PoiWarner3 auf modifizierten Medion-Gerät(PNA) mit MN6 läuft nicht!

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hallo Leute,
    jetzt sind die Fachmänner gefragt! :löl:
    Habe ein Medion PNA 240T (MD 95518), den ich mit einer Anleitung aus einem anderen Forum erfolgreich modifiziert habe.
    Dass heisst, es war vorher MobileNavigator5 installiert und nach Änderung einiger Dateien in der vorhandenen MNAVDCE.CAB, habe ich nun erfolgreich diesen PNA mit MN6.1 zum laufen gebracht. Das ganze war nötig, weil diese Medion-Geräte die 3-Buttons "Einstellungen", "Navigation" und "MP3-Player" haben. Wenn man nun auf "Navigation" klickt, wird auch MN6 gestartet!
    Nun will ich den PoiWarner 3 darauf zum laufen bringen.

    Nach erfolgreicher Installation mit der setup_arm.exe, also einer Installationsroutine für "Andere PNA´s" hier aus dem forum, habe ich den PoiWarner3 auch erfolgreich registrieren können, Einstellungen machen können und sogar die POI´s einpflegen können. Doch wenn ich dann "Überwachung starten" drücke, kommt der Hinweis:
    "Der in der Registry hinterlegte Pfad zum Mobilenavigator 6 ist nicht gültig!". Daraufhin hat man ein rotes Viereck unten links.
    In anderen Threads habe ich dann erfahren, dass man mit MobileRegistryEditor.exe die Registry des PNA´s ändern kann, was ich dann auch erfolgreich gemacht habe, sprich ich habe dann in der Registry des PNA folgendes reingeschrieben, damit alle Pfade stimmen:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Apps\navigating.de POI-Warner MN6 Editon]
    "CabFile"="\Storage Card\navigating.de POI-Warner MN6 Editon.CAB"
    "CmdFile"="\Windows\AppMgr\navigating.de POI-Warner MN6 Editon.DAT"
    "InstallDir"="\Storage Card\POI-Warner MN6 Editon"
    "Instl"=dword:00000001
    "InstlDir"="\Storage Card\POI-Warner MN6 Editon"
    "InstlDirCnt"=dword:00000001
    "IsvFile"="\Windows\AppMgr\navigating.de POI-Warner MN6 Editon.DLL"

    Nach dieser Änderung und einem Softreset läuft der PoiWarner 3 erfolgreich, der grüne Viereck ist da, es kann in den PoiWarner gewechselt werden und auch die Poi´s werden während der Navigation angezeigt! HURRA! :hot:

    NUN DAS DICKE PROBLEM: Das ganze geht bis zum nächsten Hardreset(Knopf ON/OFF hinten am Gerät) gut, denn nach einem Hardreset startet der PoiWarner nicht mehr mit dem MN6 zusammen, das Viereck ist weg und es lässt sich nicht mehr starten, bis man erneut installiert und wieder die Registry korregiert. Auf der SD-Karte ist nur die besagte modifizierte MNAVDCE.CAB, autorunce.exe, die Europakarte 2008 und der "POI-Warner MN6 Editon"-Ordner!
    Ich könnte zwar nach erfolgreicher Änderung die Registry über MobileRegistryEditor.exe diese Registryeinträge als *.reg wegspeichern, weiss aber nicht, wohin ich Sie in den PNA speichern soll, damit diese automatisch nach Hardreset geladen wird. :confused:

    Hat jemand ne Idee?
    Für Nachfragen, Ideen, Unterstützungen oder natürlich Lösungen bin ich Mega-Dankbar!


    Verzweifele schon und benötige Dringend Hilfe!
    THANXS!

    ------------------------------------------------
    EDIT:

    Hi Leute,
    hat keiner eine Idee???
    Wie kann man im WinCE des PNA etwas in den Autostart legen,
    damit es bei einem Hardreset gestartet bzw ausgeführt wird???

    Bitte um Hiiiilfeeee! Verzweifele schon richtig!
    Bin für jeden Tip und für jede Idee dankbar!

    Grüsse aus Düsseldorf!

    ------------------------------------------------
    yuhu:
    Übe dich bitte ein wenig in Gedult.
    Doppelposts sowie Pushen sind bei uns verboten !
  • Hallo Leute,
    ich habe von einem Kollegen gehört, dass man mit dem Programm "MortScript" ein Script einpflegen kann, mit der man die Registry-Einträge setzen den MN6 starten, den POIWarner starten und auf Wunsch auch sonstiges starten lassen kann.
    Das ganze war mir dann aber doch zu aufwendig und kompliziert,
    also habe ich es gelassen!

    mfg
    bpmGURU

    Closed!