"AHCI" Akivieren?

  • geschlossen
  • Frage

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • "AHCI" Akivieren?

    Hallo FreeSoftis User,

    ich habe zwei System Laufen auf MB Asus-P5WDH-Deluxe, und zwar WinXP.Pro und VistaUlti.64bit
    Meine frage ist jetzt die, ich habe bei Vista die Ahci Aktiviert was ziemlich einfach war, nun aber bei WinXP. will das nicht Funktionieren, obwohl hatte ich schon jeder menge versuch, das stelle ich jetzt hier rein was ich bisher gemacht habe von Seite XP System.


    1.Dieses Registry-Skript AHCI_Trick.reg
    ; traegt den SATA-AHCI-Hostadapter
    ; des I/O Controller Hubs ICH7R
    ; der Intel-Chipsaetze 955X, 945P und 945G
    ; in die Registry einer Windows-XP-Installation ein
    ; (XP Home, Professional, x64 Professional Edition).
    ; --
    ; Der Treiber IaStor.sys muss man manuell kopieren
    ; in das Verzeichnis
    ; %SYSTEMROOT%\system32\drivers\iaStor.sys


    ; Weitere Informationen:
    ; ICH7R: Intel® I/O Controller Hub 7 (ICH7) Family Datatsheet
    ; IaStor.sys:
    ; Enthalten in Intel Matrix Storage Manager (IMSM), 32- und 64-Bit:
    ; Intel® Matrix Storage Manager - Intel® Matrix Storage Manager support
    ; Trademarks: Intel (intel.com), Microsoft (Microsoft Corporation)
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_8086&dev_27c1]
    "Service"="iaStor"
    "ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_8086&dev_27c5]
    "Service"="iaStor"
    "ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor]
    "Type"=dword:00000001
    "Start"=dword:00000000
    "Group"="SCSI miniport"
    "ErrorControl"=dword:00000001
    "ImagePath"="system32\\drivers\\iaStor.sys"
    "tag"=dword:00000019
    "DisplayName"="Intel AHCI Controller"
    ******************
    Also diese habe ich auch alles im regedit vorhanden, so wie in Verzeichnis
    ; %SYSTEMROOT%\system32\drivers\iaStor.sys kopiert.


    Nun wie gesagt habe Praktisch alles befolgt und trotz dem lässt sich XP nicht aktivieren, evtl hat hier niemand Vorschlag für mich, den ich bin schon am überlegen ob ich die Registrierung vom Vista kopieren soll ins XP den diese Datei ist eine 32.bit aber keine Ahnung ob das gut geht?
    Okay erst Mal mein Dank für Eure Aufmerksamkeit für mich! ;)

    Lg, Biolek :hot:
  • Hallo, leider kann ich selber dazu nicht soviel sagen, rate Dir aber mit "AHCI" zu Googeln, dort fand ich zB. diesen Hinweis (zum Einbau 2er SATA-Platten):
    Als erstes um AHCI (NCQ) zu aktivieren musst Du die Treiber bei der XP Installtion per F6 mit dem Diskettenlaufwerk einbinden. Oder Du integrierst sie in die CD per nLite oder ähnlichem. (Bei Vista ist das nicht mehr nötig).
    Man kann es auch nachträglich in ein laufendes XP integrieren, habe ich aber bisher noch nicht ausprobiert.

    Im Bios musst Du natürlich auch AHCI einstellen. Meist steht dort zur Auswahl IDE, RAID und AHCI.

    Treiber findest Du von Intel z.B. hier. Dort gibt es auch ein Tool um die Diskette zur XP Installation zu erstellen.
    Support Intel
    (Kontrollliere aber ob dieser Treiber Deinen Controller unterstützt).

    Soweit der Hinweis.
    Ich habe ein älters Abit-Mainboard und das bietet soweit ich's sehe diese AHCI-Funktion im Bios nicht.
    Hoffe, Du kommst weiter damit.
    Grüsse

    PS: sehe in Google gerade noch diesen Hinweis:
    AHCI wird von XP erst ab SP2 unterstützt, soll aber erst mit Vista rund laufen, daher unter XP nicht zu empfehlen.