Navigon auf einem PNA installieren

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Navigon auf einem PNA installieren

    Wegen einiger Nachfragen zu diesem Thema habe ich mich entschlossen, eine nachvollziehbare Schritt-für-Schritt Anleitung aufzuschreiben. Es ist sicher richtig, dass alle Infos schon mehrfach, und nicht nur in diesem Board hier, aufgeschrieben stehen. Als Anfänger kommt man aber ganz schön ins Schleudern beim Zusammensuchen - und wie ich aus den Nachfragen sehe schaffen es einige doch nicht und müssen aufstecken.

    Deshalb fangen wir mal ganz vorn bei den Grundlagen an, auf die Gefahr hin dass jetzt einige (selbsternannte) Gurus darüber lachen werden. Was mich, selbst noch vergleichsweise grün hinter den Ohren, betrifft: Hätte ich diese Grundlagen gewußt wäre ich bei dem ganzen Vorhaben einige Stunden schneller gewesen! Also, was ist der Unterschied zwischen einem PDA und einem PNA? Ein Personal Display Assistant ist ein richtiger kleiner Computer, auf dem auch andere Anwendungen ausgeführt werden können. Dahingegen ist ein Personal Navigation Assistant, wie der Name schon sagt, soweit abgespeckt dass er, ohne weiteres Zutun, in der Tat nur für Navigation zu verwenden ist.

    Startet man einen PDA, so landet man, wie beim richtigen PC, erst mal auf dem Desktop, der PNA führt sogleich das Navigationsprogramm aus - den Windows-Desktop bekommt man erst garnicht zu sehen. Und genau an dieser Stelle ist die erste Maßnahme erforderlich: Man muss dem PNA diesen Autostart des Navigationsprogramms abgewöhnen. Das Ziel ist es, auch hier zum Windows-Desktop zu gelangen. Dieses Thema ist eigentlich sehr gut dokumentiert. Sucht man auf dem Netz nach "Desktop freilegen" oder "Desktop freischalten", so wird man mit Suchergebnissen regelrecht überschüttet.

    Anliegen meines Posts ist es aber nicht Verweise aufzulisten, sondern wirklich ALLES, und das möglichst VOLLSTÄNDIG, mal an einer Stelle explizit aufzuschreiben. Also in medias res!

    Der Autostart des Navigationsprogrammes auf einem PNA wird in der Regel durch einen Eintrag in der Registrierdatenbank bewerkstelligt. Diesen Mechanismus findet man, nebst dem wohl bekannten Autostart-Ordner, auch auf jedem normalen PC. Auch wenn jetzt einige noch nie etwas von der Registrierdatenbank (zu Neudeutsch: Registry) gehört haben - es hilft nichts, da muss man durch. Ohne Entfernung dieses Eintrages in der Registry ist es nicht möglich an den Desktop des Navis heranzukommen und Navigon, oder auch jede beliebige andere Navigationssoftware, zu installieren.

    Es gibt nun 2 Möglichkeiten dieses Entfernen zu bewerkstelligen. Die eine, ich würde sie mal als Kanonenschuss auf einen Spatzen bezeichnen, nenne ich nur der Vollständigkeit halber. Es gibt einen Remote-Mobile-Registry Editor, mit dem man die Registrierdatenbank des Navis auf dem PC bearbeiten kann. Voraussetzung dafür ist, u.a., die Installation des Net-Frameworks auf dem PC, welches sich dort mit (glaub ich, genau weiss ich es nicht mehr) einigen hundert Megabyte breit macht. Wer's meint so machen zu müssen: Das Net-Framework gibts beim großen Windowsproduzenten in Redmont (sorry, links sind im Forum verboten), und wegen des Registrierdatenbankeditors mal auf dem Internet nach

    Remote Registry Editor Windows CE

    suchen. Die praghmatische, wenngleich vielleicht nicht ganz so komfortable, Methode ist, diesen Registry Eintrag auf dem PNA selbst zu entfernen. Der Vorteil bei dieser Vorgehensweise ist, dass der zweite Schritt zum freien Desktop gleich mit erledigt wird. Denn, was nützt schon ein leerer Dekstop mit NICHTS drauf? Das Mindeste was man braucht ist die Startleiste, über die man erst Programme ausführen kann. Und die fehlt in der Regel auf dem PNA auch.

    Wer bisher aufmerksam gelesen hat wird sich vielleicht fragen: Wie nun? Ich soll die Registry auf dem PNA selbst ändern. Wie kann das gehen wo der doch sofort den Navigator startet und mich garnichts machen läßt? Das ist doch ein Henne-Ei-Problem!
    Richtig, denn genaugenommen ist die Reihenfolge anders als oben aufgeschrieben. Zuerst die Henne=Startleiste, und die legt dann das Ei=freier Desktop. Ich hab es nur zunächst so herum aufgeschrieben weil (i) der freie Desktop als Begriff weitaus verbreiteter ist und einige ihn deshalb schon kennen dürften und (ii) bei der Methode mit dem Remote Registry Editor zuerst das Ei kommt.

    Bevor wir nun zur ersten Tat schreiten noch die Voraussetzung dazu. Die Taskleiste ist ein winziges Progrämmelchen, gerade mal 3 Kilobyte groß, aber auch das muss vom PC erst mal auf das Navi. Dazu bedient man sich des Programms ACTIVE SYNC. Dieses liegt oft dem Navi auf einer CD bei, falls nicht kann man es sich bei Microsoft kostenfrei herunterladen. Der Name sagt schon, dass es hauptsächlich zur Synchronisation von Daten zwischen einem PC und einem PDA gedacht ist. Wird das Navi über USB angschlossen und eingeschaltet, meldet sich ACTIVE SYNC deshalb zunächst auch mit einer Frage: "Möchten Sie eine Partnerschaft festlegen?" Diese ist zu verneinen, das Gerät soll nur Gast sein. Danach läßt man sich über Datei/Durchsuchen den Inhalt des mobilen Gerätes anzeigen. Hier geht man zum Verzeichnis \Windows\Autostart, welches auf einem jungfräulichen PNA leer sein müßte. Nun könnte man mit der Maus per drag and drop die Taskleiste direkt in das Autostartverzeichnis schieben - wenn man eine hätte.

    Das bereits o.g. winzige Programm heisst showtaskbar.exe und wird an vielen Stellen zum downloaden angeboten. Wer's nicht abwarten kann, der gehe bitteschön schon mal auf die Suche. Ich werde in den nächsten Tagen auf jeden Fall einen UP posten, in dem die Taskleiste und auch ein Editor für die Registrierdatenbank enthalten sind.

    Diesem ersten Streich folgt sogleich der obligatorische zweite. Neben der Taskleiste wird noch der Editor für die Registry benötigt. Viele Geräte, zumindest bei meinem Typhoon 3500 Go war es so, haben diesen schon on board. Mal nachschauen ob da etwa schon ein "regedit.exe" o.ä. vorhanden ist. In meinem Fall, und ich glaub bei Medion-Geräten auch, war es so, er heisst dort "MioRegEdit.exe". Wenn nicht s.o., es wird ein UP folgen.

    Hat man diese beiden Programme auf dem Navi ist ein Soft-Reset erforderlich. Bevor hier irgend was schief läuft wieder eine Erklärung. Die meisten Navis haben 3 Taster/Schalter. Der offensichtlichste und größte davon, Otto-Normalverbraucher würde den für einen Ein-/Ausschalter halten, ist von seiner Wirkweise der harmloseste. Wird er gedrückt, geht tatsächlich das Display aus und man meint die Kiste sei abgeschaltet. Das ist grundlegend falsch - mit diesem Schalter wird der PNA in den standby Modus befördert. Und das ist KEINESWEGS ein Ausschalten. Eine Warnung gleich an dieser Stelle: Der PNA verkonsumiert, wenn auch wenig aber auch nicht vernachlässigbar, Strom im standby Modus. Läßt man ein derart abgeschaltetes Gerät wochenlang rumliegen so dass sich der Accu vollständig leert, sind alle Änderungen die man vorgenommen hat futsch! Also, bei Nichtbenutzen ab und an an die Steckdose mit dem Teil.
    Der zweite, von seiner Wirkung her stärkste, Schalter befindet sich, meist recht versteckt, auf der Rückseite des Gehäuses. Dies ist ein richtiger Ein-/Ausschalter. Hier gilt insbesondere die gleiche Warnung wie bei leeren Accus. Hat das Navi einmal keinen Strom, ist jede Änderung weg. Also, wenn Navigon mal drauf läuft: Bloß nicht! Dieser Schalter wird oft, auch in manchen Handbüchern, als Hard-Reset bezeichnet und ist idR. schwer zugänglich. Bei meinem Typhoon ist er vertieft auf der Rückseite und man kommt nur mit einem Spitzen Stift an ihn heran.
    Auch etwas schwerer zugänglich ist der von uns gesuchte Soft-Reset. Meist befindet er sich an einer Gehäuseseite hinter einem kleinen Löchlein, so dass man etwa eine aufgebogene Büroklammer benutzen muss um ihn zu betätigen. Dies ist kein Schalter, sondern in aller Regel ein Taster. Der Unterschied dieses Soft-Reset zum harten Reset via Ausschalten ist, dass der Speicherinhalt erhalten bleibt.

    Nach Drücken dieses Soft-Reset Tasters bootet das Navi neu, und wenn es damit fertig ist sieht man auf den ersten Blick keine große Änderung. Die Navigationssoftware startet wie gewohnt, lediglich am unteren Bildschirmrand sollte ein dünner grauer Streifen zu sehen sein. Ich betone noch einmal: "Sollte". Dieser Streifen ist die zusammengeklappte Taskleiste. Wie auch bei einem richtigen PC kann diese viele Zustände haben: Aufgeklappt, zugeklappt, immer im Vordergrund ... aber leider ist es auch möglich dass sie garnicht zu sehen (verdeckt) ist. Wie sich die Taskleiste verhält wird auch wieder über die Registrierdatenbank geregelt. Bei allen mir bekannten Geräten ist sie "automatisch ausgeblendet", aber auch "immer im Vordergrund", also als besagter dünner Strich zu sehen. Kein Mensch kennt natürlich alle Geräte, und sollte es bei dem einen oder anderen so sein dass wirklich nichts zu sehen ist, dann schreibt eine PN. Auch für diesen Fall gibt es eine Lösung und ich helfe gerne, nur an dieser Stelle würde dieser Sonderfall echt zu weit führen.

    Analog zum PC mit der Maus, klappt man nun auf dem PNA die Startleiste mit dem Stift auf und wählt "Ausführen". In dem sich öffnenden Fenster gibt es ein Eingabefeld, in welches man "regedit.exe", oder wie immer es bei euch heisst, direkt eintippen kann. Wer sicher gehen will, kann auch den vollständigen Pfad, sollte

    \Windows\regedit.exe

    sein, eintippen. Sollte man zu Übungszwecken ruhig mal machen, die Bildschirmtastatur erreicht man über das entsprechend Symbol auf der rechten Seite in der Startleiste. Wer hier experimentierfreudig ist, kann schon mal versuchen sich den Desktop anzeigen zu lassen. Das Symbol dafür befindet sich auch rechts in der Startleiste, neben demjenigen für die Bildschirmtastatur.
    Alternativ kann man sich auch über den Button "Durchsuchen" bis zum Registrierungseditor hangeln.

    Ist dieser gestartet, kommt der 4. und auch zugleich schwerste Schritt auf dem Wege zum Navigon auf dem PNA. Leider darf ich als Neuling offensichtlich noch keine Bilder einfügen, weshalb ich das nun mühsam verbal beschreiben muss. Direkt unter der Menüleiste des Registry-Editors (File Edit ...) befindet sich, ganz links, ein Eingabefeld (noch leer) mit einem grauen Button mit schwarzem "Nach-Unten-Pfeil" am rechten Rand. Auf diesen Button drückt ihr mit dem Stift. Es geht drunter ein kleines Fenster auf mit den Auswahlpunkten:

    LMachine
    CUser
    Users
    CRoot

    Tippt mit dem Stift auf LMachine. LMachine erscheint daraufhin in dem Eingabefeld, und in der Mitte werden die Schlüssel untereinander aufgelistet die zur Kategorie Local Machine gehören. Da das relativ viele sind, erscheint am rechten Rand ein Schieberegler. Weit nach unten gehen müsst ihr nicht, scrollt so lange bis "init" kommt, und Doppelklickt mit dem Stift darauf. Es passiert:
    (i) in dem langen grauen Kasten neben dem Eingabefenster mit LMachine steht jetzt init. (ii) in dem großen Fenster in der Mitte, wo zuerst die vielen Schlüssel standen, steht jetzt nur noch

    (Parent)
    BootVars

    und (iii) in dem kleinen Fenster ganz unten tauchen jetzt Unterschlüssel mit Werten auf. Das sollte in etwa so beginnen:

    Depend30 : Binary : 14 00
    .....

    Rechts an diesem Fenster sind wieder die Bedienelemente zum hoch- und runterscrollen. Sucht hier nach

    Launch80 : SZ : xxxxx.exe

    Ich habe xxxxx geschrieben, da ich nicht wissen kann wie die Datei auf Eurem Navi heisst. Wie sie bei mir hieß hab ich schon lange vergessen, auf jeden Fall ist dies der böse Eintrag der den Navigator autostarten läßt. Dieser Unterschlüssel muss ersatzlos gelöscht werden. Klar, dass er zuerst mal mit dem Stift selektiert werden muss. Es ist dann aber ein Trugschluss zu glauben, dass das Löschen mit dem ganz rechten Button mit der Aufschrift "Del" in der Reihe unter

    LMachine Init

    zu bewerkstelligen sei. Man muss ganz oben in der Menüleiste "Edit" antippen, und in der Pop-down-Leiste ganz unten "Delete Key" wählen. Die obligatorische Abfrage ob sie sich sicher sind wird entsprechend mit ja beantwortet. Sicherheitshalber sollte der Registry Editor über File/Exit verlassen werden bevor das Navi das zweite mal über Soft-Reset neu gestartet wird.

    Nach dem booten ist jetzt ein nackter Desktop mit der zusammengeklappten Startleiste zu sehen. Seid ihr hier angelangt ist das Meiste getan, der Rest ist ein Kinderspiel.

    Bevor ich dazu was sage, noch ein paar generelle Anmerkungen. In einem Beitrag in einem anderen Forum hat einer behauptet, er hätte MN6 auf einem PNA ganz einfach dadurch ans Laufen bekommen, indem er die SD-Karte, so wie von Navigon original ausgeliefert, eingesteckt und einen Soft-Reset durchgeführt hätte. Ammenmärchen sag ich da nur. Ich will dem Betreffenden nicht unterstellen dass er gelogen hat; wahrscheinlich hat er einen PDA und weiss nichts von seinem Glück. Auf einem PNA funktioniert das so einfach jedenfalls mal nicht; ohne wenn und aber ist hier das Freilegen oder Freischalten des Desktops zwingend erforderlich.
    An vielen Stellen liest man weiterhin, dass PNAs grundsätzlich nicht in der Lage seien andere Programme auszuführen als das was ab Werk darauf installiert ist. Das läge an fehlenden DLLs, das sind Laufzeitbibliotheken die zu Windows gehören. Es ist sicher richtig dass einem PNA, dem einen mehr und dem anderen weniger, solche Bibliotheken fehlen. Deshalb gibt es auch, zumindest bei Navigon, sowohl eine PDA- als auch eine PNA-Version. Es ist nicht gänzlich unmöglich eine PDA-Version auf einem PNA ans Laufen zu kriegen, dann wird man aber nicht umhin kommen sich die eine oder andere DLL zu besorgen. Und dies ist in der Tat ein schwieriges Unterfangen. Zunächst muss man mal wissen WAS eigentlich fehlt. Dafür gibt es sogenannte Dependency-Checker (Abhängigkeits-Prüfprogramme) die auf dem PNA ausgeführt werden müssen. Und dann kommt das Problem: WOHER kriegen? In einem Anflug von Sportsgeist hab ich tatsächlich die PDA-Version von MN6.2 auf meinem Typhoon 3500 Go erfolgreich installiert. Aber das war ÄTZEND, also Finger weg. Wozu auch, es gibt eine PNA-Version! Und die kommt, abgesehen von einem kleinen Schönheitsfehler (s.u.) ohne jegliche DLLs aus.

    Wen's interessiert da wir gerade bei einem generellen Thema sind: Auch TomTom 6.2 werkelt mittlerweile auf meinem Typhoon PNA. Hier war gerade mal eine einzige Bibliothek erforderlich (aygshell.dll).

    Nun, endlich, zum abschliessenden Kinderspiel. Ich gehe davon aus, dass ihr Navigon in der entsprechenden Form (für PNA) vorliegen habt. Falls nicht, schaut mal ganz unten unter P.S. nach. Auf der SD-Speicherkarte befinden sich:

    autorunce.exe
    mnavdce.cab
    <eine Karte>.map
    [MN6]

    Die eckigen Klammern stehen für einen Ordner, darin befindet sich das eigentliche Programm (wird später von Speicherkarte gestartet).

    Steckt die SD-Card jetzt ein und führt einen Soft-Reset durch. Der PNA bootet wieder auf den nackten Desktop. Startleiste hochklappen und wieder Ausführen auswählen. Dieses mal benötigen wird den "explorer.exe". Der Inhalt der SD-Karte befindet sich, je nach Navi, unter
    \Storage Card
    \SD Card
    .....
    oder so ähnlich. Ist eindeutig zu erkennen an dem schwarzen Buch oder IC was da auf dem Ordner drauf ist. Nicht verwechseln mit "My Flash Disk", es gibt zwei solcher Laufwerke. In "My Flash Disk" ist überlicherweise die ab Werk vorhandene Navigationssoftware enthalten, diese kann, wenn Navigon läuft, zwecks Sparens von Speicherplatz gelöscht werden.

    Geht also in das Verzeichnis \SD Card, und doppelklickt auf die "mnavdce.cab". Die Installation läuft an, und, das ist o.g. Schönheitsfehler, bleibt irgendwann hängen. Auch hier gilt wieder: War bei mir so und sollte auf Medion-Geräten auch so sein. Gut möglich dass es bei euch sogar saugend durchläuft. Ich habe den Verdacht, dass dieser Absturz tatsächlich an einer fehlenden DLL liegt, aber der ist nicht tragisch. Legt das Navi einfach 5 Minuten in die Ecke damit die Installation sicher fertig ist, und betätigt ein letztes Mal den Soft-Reset Taster. Im Explorer könnte ihr sehen, dass bei der Installation der Ordner "mnav" mit der Datei "mnavdce.exe" darin angelegt worden ist. Das bei der abgestürzten Installation tatsächlich einiges passiert ist könnt ihr auch unter

    Start/Einstellungen/Systemsteuerung/Programm entfernen

    sehen. Dort steht jetzt Navigon drin.

    Zum Betrieb von Navigon: Es ist ein ziemlich dickes Programm, welches die Ressourcen eines PNA schon recht ordentlich strapaziert. Startet es nicht aus dem Explorer heraus (der frisst gehörig Speicherplatz), sondern legt euch stattdessen eine Verknüpfung auf den Desktop. Dazu startet wieder den Explorer, geht nach

    \SD Card\MN6,

    selektiert "MN6.exe" und wählt unter Datei "Senden an/Desktop als Verknüpfung" aus.

    DAS WAR'S !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    Viel Spaß mit Navigon. Sollte irgendwo die Säge klemmen, außer bei o.g. Ausnahme wenn die Taskleiste verdeckt sein sollte, bitte keine PN schreiben sondern im Form posten. Denkt daran, dass auch andere an genau der gleichen Stelle hängen bleiben könnten, und die freuen sich dann wenn sie die Lösung des Problems gleich nachlesen können.


    Gruß an alle die es geschafft habe bis hierher zu lesen :P ,
    Andreas



    P.S.: Es gibt hinreichend UPs wo man sich einen Link für MN6 anfordern kann. Dennoch werde ich selbst in den nächsten Tagen einen UP mit MN6 posten. Da könnt ihr euch dann ganz sicher sein dass sie wirklich für einen PNA ist, und genau diese auf einem der miesesten und abgespecktesten Vertreter dieser Gattung Navis mit Erfolg installiert wurde.
  • Moin
    Danke erst mal für die tolle Anleitung.
    Hat bis jetzt alles gut geklappt.
    Habe auch das Typhoon 3500 Go, ist zur Zeit
    im Windows zustand.
    Suche jetzt nur noch eine funktionierende MN6.

    Danke Gruß Paps
  • Hallo,
    Ich versuche MN 6 (PNA-Version) auf einem Typhoon 3600 Go (ROM:1.00.19 /Bootloader: 0.27) zu installieren.
    Auf dem PNA läuft Win CE :NET 4.2 Core.
    Der Desktop ist freigelegt und die Taskleiste kommt auch.
    Die Installation von MN6 startet und bricht wie beschrieben ab.
    Wenn ich nach einem Softreset versuche MN6 zu starten kommt die Fehlermeldung: 'MN6' is not a valid Windows CE application
    Über hilfreiche Tips würde ich mich sehr freuen.

    Greetz
    MM2KC
  • Nochmal Hallo,

    zunächst ein ganz dickes Dankeschön für die Blumen, war ja einiges an Lob dabei. Wie ich gesehen habe, habt ihr euch die 2 Files die man benötigt schon anderweitig besorgt. Trotzdem, was man versprochen hat muss man auch halten. Deshalb wollte ich euch mitteilen, dass der UP zur Verfügung steht. Zu finden hier:

    freesoft-board.to/f158/desktop…n-284441.html#post2389499

    Wie ihr dort nachlesen könnte, ist a bisserl mehr drin als nur die Taskleiste und der Registry Editor. Der Screenshot zeigt sehr schön, dass bei der Verwendung der selbstinstallierenden CAB der Registry Editor gar nicht mehr bemüht werden muss. Der Eintrag wird einfach ge-"faked".

    Zu dieser CAB muss ich nochwas sagen. Ich hatte in meinem ersten Post geschrieben, dass keine DLLs benötigt werden. Im strengen Sinne stimmt das natürlich nicht. Selbstverständlich braucht die PNA-Version von Navigon DLLs. Aber halt eben keine ZUSÄTZLICHEN, diejenigen welche benötigt werden sind in der mnavdce.cab enthalten, und diese ist bei Navigon dabei.

    Gruß,
    Andreas
  • MM2KC schrieb:


    Ich versuche MN 6 (PNA-Version) auf einem Typhoon 3600 Go (ROM:1.00.19 /Bootloader: 0.27) zu installieren.
    Auf dem PNA läuft Win CE :NET 4.2 Core.
    Der Desktop ist freigelegt und die Taskleiste kommt auch.
    Die Installation von MN6 startet und bricht wie beschrieben ab.
    Wenn ich nach einem Softreset versuche MN6 zu starten kommt die Fehlermeldung: 'MN6' is not a valid Windows CE application


    Hallo MM2KC,

    da hast du ja fast dieselbe Kiste wie ich, ich habe einen 3500 Go. Auch die WinCE-Version ist dieselbe, und an der ROM- und Bootloaderversion kann es eigentlich überhaupt nicht liegen. M.a.W.: Es sollte mit dem Teufel zugehen wenn Navigon auf deinem Gerät nicht ans Laufen zu bringen wäre.

    Die Fehlermeldung "is not a valid Windows CE application" deutet darauf hin, dass bei der Installation etwas schiefgelaufen ist. Versuchen wir mal rauszubekommen was:

    1) Hast du schon unter Systemsteuerung/Programme entfernen (Pendant zu Systemsteuerung/Software auf einem PC) nachgeschaut ob Navigon dort auftaucht?

    2) Wie startest du Navigon? Wurde eine Verknüpfung erstellt, wenn ja wo, und WORAUF zeigt diese? Wie ich in meiner Anleitung schrieb: NICHT den Explorer starten, ins Verzeichnis gehen wo die MN6.exe steht, und die aus dem Explorer heraus ausführen. Navigon ist ein äußerst ressourcenintensives Programm, und möglicherweise verkraftet der PNA den Explorer nebenher nicht mehr.

    3) Bist du dir 100%-ig sicher dass du eine PNA-Version hast? Ich habe mir auch schon mal eine angebliche PNA-Version runtergeladen. Von wegen! Nach Stunden und ein paar grauen Haaren mehr hab ich dann feststellen müssen, dass die von einem PDA war. Also: Welche Version ist das genau? 6.0, 6.2 oder 6.5? Schreib mal die genaue Größe (bis aufs Byte - zieh dir das Teil per ActiveSync auf den PC und dann Eigenschaften nach rechtem Mausklick) auf. Vielleicht gibt dies etwas mehr Aufschluss.

    4) Wenn Navigon richtig installiert ist, muss ein neuer Ordner im Hauptverzeichnis auftauchen:

    \mnav

    Dort sollte eine Datei drinne stehen

    mnavdce.exe

    Ist das bei dir so?

    Check bitte mal die oben aufgelisteten Punkte. Wenn sich daraus kein Hinweis ergibt versuche ich selbstverständlich dir weiter zu helfen.

    Gruß,
    Andreas
  • 1) Navigon taucht bei den installierten Programmen auf.

    2) Ich habe die Verknüpfung zu SD_Card\MN6\MN6.exe auf den Desktop gelegt und versuche es so zu starten.

    3) Getestet habe ich es mit diesen Versionen:
    (Laufen ohne Probleme auf Acer n35
    -6.1.5
    -6.2

    PNA:
    (Laufen ohne Probleme auf Transonic 4000 - Der wurde aber auch mit MN5 ausgeliefert)
    -6.1.5
    -6.2
    -6.5.2

    4) Ordner und Verzeichnis sind vorhanden

    Bei den Tests mit den PDA Versionen hat es mir noch Einträge ins Startmenü geschrieben. Bei den PNA Versionen nicht.

    Vieleicht muss ich mal mit zusätzlichen DLLs testen oder mit einer anderen Version.

    Freue mich über jeden Tip

    Greetz
    MM2KC
  • MM2KC schrieb:

    1) Navigon taucht bei den installierten Programmen auf.


    Wie ich mittlerweile von anderen Boardmitgliedern gesagt bekommen habe, ist das auch der Fall wenn man eine PDA-Version versucht auf einem PNA zu installieren. Sicher ist es bisher bei Zweien, die angbeblich eine PNA-Version hatten, dass es sich um eine PDA-Version handelte. Also ist das Vorhandensein des Eintrags von Navigon in der Systemsteuerung bei den installierten Programmen leider keine Methode um herauszufinden ob man etwa ein MN6 für die falsche Zielhardware hatte.

    [2) Ich habe die Verknüpfung zu SD_Card\MN6\MN6.exe auf den Desktop gelegt und versuche es so zu starten.


    Mein diesbezüglicher Vorschlag war zwar nicht verkehrt, er zielte auf ein mögliches Speicherplatzproblem ab. Wenn man aber noch mal genau drüber nachdenkt, kann es das eigentlich nicht sein. Die Fehlermeldung hätte anders aussehen müssen, du hast "is not a valid CE application" bekommen. Man versucht halt eben alle Unwägbarkeiten auszuschliessen, aber ich komme mehr und mehr zum Schluss, dass das Problem hier tiefer liegt.

    3) Getestet habe ich es mit diesen Versionen:
    (Laufen ohne Probleme auf Acer n35
    -6.1.5
    -6.2


    Der Acer N35 ist ein PDA, und hat eine Bildschirmauflösung von 240 Pixeln horizontal und 320 Pixeln vertikal. Wenn du das was du auf diesem Handheld installiert hast auf einem PNA mit 320 Pixeln horizontaler und 240 Pixeln vertikaler Auflösung versuchst zu installierst wirst du mit Sicherheit Schiffbruch erleiden.


    PNA:
    (Laufen ohne Probleme auf Transonic 4000 - Der wurde aber auch mit MN5 ausgeliefert)
    -6.1.5
    -6.2
    -6.5.2


    Wir sollten hier zwischen Versionen (5,6.0, ..., 6.52) und Zielhardware (PDA, PNA) unterscheiden. Egal welche Version, was für die Zielhardware PDA vorgesehen ist wird nur schwerlich auf einem PNA zum Laufen zu bewegen sein. Ich habs mal gemacht, aber das ist echt nicht einfach. So ohne weiteres funktioniert sowas mit Sicherheit nicht.

    4) Ordner und Verzeichnis sind vorhanden


    Du meinst sicher Ordner=Verzeichnis und Datei. Also ist bei der Installation schon einiges passiert, d.h. sie ist zumindest mal weit fortgeschritten gewesen.

    Bei den Tests mit den PDA Versionen hat es mir noch Einträge ins Startmenü geschrieben. Bei den PNA Versionen nicht.


    Das ist logisch, gibt aber leider keine weiteren Aufschlüsse darüber was bei dir schiefgelaufen ist.

    Vieleicht muss ich mal mit zusätzlichen DLLs testen oder mit einer anderen Version.


    Wenn du (ich setzte jetzt einfach mal voraus dass dein Gerät, du schreibst es sei ein Typhoon 3600 Go, ein PNA ist) ein Navigon gleich welcher Version für die Zielhardware PNA installiert hast dürfte es auf keinen Fall zu dieser Fehlermeldung kommen die du erhalten hast. Bei jeder Navigon-Version für einen PNA sind ALLE benötigten DLLs dabei (!!!), die stecken in der MNAVDCE.cab welche sich im Hauptverzeichnis auf der SD-Karte befinden sollte.

    Wie gesagt, das Problem steckt tiefer.

    Um dir weiterhelfen zu können müßte erst mal 100%-ig abgeklärt werden, ob du tatsächlich einen PNA hast. Ich habe einen Typhoon MyGuide 3500 Go, der ist sicher ein PNA. Ich weiss aber auch, dass es einen Typhoon MyGuide 3500 gibt, der ein richtiger PDA ist. Ich weiss nicht genau wie der heisst, also was da statt des "Go" steht. Möglicherweise "mobile", "PocketPC", oder auch garnichts? Was mir aber bekannt ist: Das Display bei meinem Go ist quer (320x240), beim 3500-PDA hochkant (240x320). Es ist naheliegend, da du 3600 Go geschrieben hast, hier einen PNA zu vermuten. Check dies bitte zuerst aber noch mal BELASTBAR ab.

    Dann würde ich etwas Pragmathismus vorschlagen. Du scheinst ja einiges an Versionen für verschiedene Zielhardware gesammelt zu haben. Da ich überhaupt nicht beurteilen kann was das alles ist schlage ich vor, du probierst es mal mit einer "Distribution" von mir. Da weiss ich dass sie läuft, kenne die Voraussetzungen, und kann mir dann viel besser ein Bild über die Situation machen.

    Schreib mir eine PM, ich schicke dir dann einen link.

    Gruß,
    Andreas
  • &quot;Wasserdichte&quot; MN6.0 für PNA

    Hi,

    erst mal noch eine Danke für die reichliche und positive Resonanz und die Unmenge an PMs. Nachdem, wie sollte es anders auch sein, am Anfang die Meisten Probleme mit dem Freilegen des Desktops hatten, mehren sich nun die Schwierigkeiten mit dem Navigon selbst.

    Dass dieser letzte, oben schon mal von mir als "eigentlich nur noch ein Kinderspiel" bezeichnete Schritt noch solche Schwierigkeiten aufwirft hat einen bedauernswerten Grund. Es wird eine Unmenge an UPs angeboten, immer nur das Neueste, das Beste ... - ein Wettbewerb unter den UPpern die dann wohl im Eifer des Gefechts nicht die nötige Sorgfalt walten lassen. Einige der "Distributionen" sind unvollständig oder sonstwie zerschossen, die häufigste Fehlerursache die sich in den Nachfragen von einigen von euch herausgestellt hat war jedoch, dass hier angebliche PNA-Versionen doch nur für PDA waren. Ich hatte bereits in meinem ersten Beitrag angekündigt, dass ich vielleicht mal eine wirklich lauffähge, "wasserdichte" MN6 poste - und jetzt, wo sich der Bedarf danach deutlich herausgestellt hat, habe ich das dann auch getan. HAARGENAU die gleiche Version die auf meinem Typhoon MyGuide 3500 Go (ganz sicher ein PNA) klaglos und stabil werkelt findet ihr hier:

    freesoft-board.to/f158/vollsta…a-286288.html#post2412568

    Den link bekommt jeder, keine Mindestzahl an posts erforderlich, und sofern ich Zeit habe helfe ich auch gerne.

    Gruß,
    Andreas
  • Navigon 6 auf MyGuide Navigator 4000 TMC (LIDL)

    Sooo...

    Da ich es, nicht zuletzt mit deiner Hilfe, endlich geschafft habe Navigon 6.0 auf meinem MyGuide Navigator 4000 TMC (LIDL) zu isntallieren möchte ich meine Schritte hier nochmal kurz aufführen. Ich denke du kannst sie in deinem Thread irgendwie gut unterbringen das sie noch vielen anderen geplagten weiterhilft :)

    1. Hardreset (on off schieber auf der Rückseite des Gerätes)
    2. Navi an den PC anschliessen sodass über ActiveSync darauf zugegriffen werden kann
    3. Die Showtaskbar.exe in MP3Player.exe umbennenen und in den \Windows\ ordner auf dem Navi kopieren und überchreiben! Des weiteren die Showtaskbar nochmals kopieren und in den ordner \windows\StartUp kopieren (normalerweise reicht es die Showtaskbar nur in den Autostart ordner zu packen, bei mir war das Problem das die alte Navigationssoftware zu dominant war und mir keinen Zugriff auf die Startleiste gewährt hat!)
    4. Einen Softreset durchführen (auf der rechten seite des Navis zu finden)
    5. Nun im Menü auf das "MP3Player" symbol drücken, am unteren rand sollte eine graue Leiste erscheinen, darauf klicken und im Menüpunkt Programme den Explorer starten
    6. Im Windows ordner gibt es eine Datei namens MioRegEditor.exe diese starten
    7. In diesem Regeditor unter "HKEY_LOCAL_MACHINE" den eintrag "init" suchen, klicken und rechts im fenster den eintrag Launch80 löschen (draufklicken und oben das rote kreuz drücken) das bewirkt das die alte navisoftware nicht mehr geladen wird
    8. Softreset , nun sollte nur noch der Desktop zu sehen sein und unten die Leiste
    9. Eine 1GB (!!!) SD Karte mit folgenden Dateien versehen : mnavdce.cab, autorunce.exe, Ordner [MN6], eine *.map datei (Wichtig : Der Name dieser datei muss in der \MN6\NaviLib.ini angepasst werden : "Last used database directory=\SD Card\<euer map name>.map"
    10. über den explorer auf dem Navi die mnavdce.cab starten (doppelklick), die installation bleibt bei der hälfte stehen, das ist nicht schlimm! Wartet einfach 5 min. und macht erneut einen softreset
    11. Nun sollte das Programm erfolgreich installiert sein und im stammverzeichnis einen ordner angelegt haben sollte dies nicht der Fall sein den Vorgang nochmal widerholen :)

    12. Nun im Explorer auf die SD Karte wechseln, in den ordner (MN6) gehen und die MN6.exe anwählen, nun oben auf "datei" "senden an" -> Desktop

    Voila :)

    nun koennt ihr das programm über die verknüpfung auf dem desktop starten

    Nochmals dankeschön !!

    Gruß

    Pirase

    ps: Jetzt stellt sich mir natürlich die Frage, wie bekomme ich westeuropa auf meinem Navi zum laufen ( 1,4GB ... ) D A CH passt mit 450 locker... aber die anderen Länder in der Umgebung wären schon schön....

    Um den threadstarter ein wenig zu entlasten wendet euch doch bei dem Lidl model einfach an mich!