Programme zur Öffnen mit... Liste hinzufügen

  • geschlossen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Programme zur Öffnen mit... Liste hinzufügen

    Hallo,

    und zwar hab ich folgendes Problem:
    wenn ich eine Datei, in dem Falle .gvi's öffnen will, geh ich auf 'Öffnen mit...' und such mir das Programm unter Durchsuchen raus (GoogleVideoPlayer).
    Jetzt müsste das Programm normalerweise in der Liste erscheinen, macht es aber nicht.
    Das gleiche geht auch mit anderen unbekannten Dateien und dem Durchsuchen von deren Programmen nicht.

    Bis jetzt habe ich keine Lösung gefunden. Ich weis nur das man in der Registry Einträge verändern kann damit die nicht mehr in der Liste stehen, aber ich will ja, dass da neue Programme hinzugefügt werden.

    Betriebssystem ist Windows XP Pro SP2

    hoffe das ist das richtige Unterforum, wusste nicht so richtig wo's hingehört

    Vielen Dank
    ----------------------------
    George Best: "Ich habe viel von meinem Geld für Alkohol, Weiber und schnelle Autos ausgegeben.
    Den Rest habe ich verprasst."
    Mein PC
  • Wenn es nicht in der Liste steht, musst du auf Programm auswählen gehen.
    Dann steht es entweder unter andere Programme oder falls nicht gehe auf Durchsuchen und wähle das Anwendungsprogramm aus dem Fileordner!
    Danach steht aus bei diesem Filetyp immer in der Auswahl!
    [SIZE=1]Pubverleih: (Angebot)[/SIZE][SIZE=1]|1>100>200>300>400>[/SIZE][SIZE=1]500>[/SIZE][SIZE=1]600>[/SIZE][SIZE=1] 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 [/SIZE]
    [SIZE=1]Up: 1[/SIZE][SIZE=1]>[/SIZE][SIZE=1]56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93[/SIZE]
    [SIZE=1]Blacklist[/SIZE][SIZE=1] Seit 19.12.2009 bin ich nun zweifacher Papa von Töchtern![/SIZE]
  • wahrscheinlich habe ich mich falsch ausgedrückt,
    ich habe es genauso gemacht wie du gesagt hast, nur die Programme die ich bei Durchsuchen auswähle werden nicht auf der Liste hinzugefügt
    also die Liste wird nicht erweitert
    ----------------------------
    George Best: "Ich habe viel von meinem Geld für Alkohol, Weiber und schnelle Autos ausgegeben.
    Den Rest habe ich verprasst."
    Mein PC
  • Hallo!

    Mit Liste meinst du nicht die Liste im Kontextmenü, sondern das Dialogfenster Öffnen mit, das in Empfohlene Programme und Andere Programme unterteilt ist. Stimmts?

    Du klickst also im Kontextmenü auf Öffnen mit > Programm auswählen. Dann im Dialogfenster wählst du Durchsuchen..., dann die .exe Datei. Und dann sollte das Programm in der Liste erscheinen, was es aber nicht tut.

    Was steht denn im Regschlüssel der Erweiterung, also HKEY_CLASSES_ROOT\.gvi und im Schlüssel, auf den verwiesen wird?

    Probier mal Folgendes: Geh auf HKEY_CLASSES_ROOT\.gvi, dann erstelle den Unterschlüssel OpenWithList und darin wieder den Unterschlüssel mit dem Namen der .exe. Ich hab hier bspw. einen Schlüssel HKEY_CLASSES_ROOT\.tod\OpenWithList\ShowTime.exe. (Keine Ahnung was tod soll :confused: ) Du brauchst also nichts auf der rechten Seite zu tun.

    Gruß

    FeliX_22
  • zitat @Felix22

    Du klickst also im Kontextmenü auf Öffnen mit > Programm auswählen. Dann im Dialogfenster wählst du Durchsuchen..., dann die .exe Datei.


    einen hacken in das kästchen

    bei Dateityp immer mit dem ausgewählten programm öffnen

    ist einfacher für die leuts die sich nicht in der registry auskennen:D


    gruß wakiya:drum:


    mit dieser reg datei stellst du deine standardwerte wieder her


    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Unknown\shell]
    @="openas"

    [HKEY_CLASSES_ROOT\Unknown\shell\openas]

    [HKEY_CLASSES_ROOT\Unknown\shell\openas\command]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
    00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,72,00,75,00,\
    6e,00,64,00,6c,00,6c,00,33,00,32,00,2e,00,65,00,78,00,65,00,20,00,25,00,53,\
    00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,00,5c,00,73,00,\
    79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,65,00,6c,00,6c,\
    00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,4f,00,70,00,65,00,6e,00,41,00,\
    73,00,5f,00,52,00,75,00,6e,00,44,00,4c,00,4c,00,20,00,25,00,31,00,00,00



    füge dies in eine txt-datei und benenne diese um in shell openas command.reg


    dieses ist nur für XP


    für vista ist dieses

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Unknown\shell]
    @="openas"

    [HKEY_CLASSES_ROOT\Unknown\shell\openas]
    "MultiSelectModel"="Single"

    [HKEY_CLASSES_ROOT\Unknown\shell\openas\command]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
    00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,72,00,75,00,\
    6e,00,64,00,6c,00,6c,00,33,00,32,00,2e,00,65,00,78,00,65,00,20,00,25,00,53,\
    00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,00,5c,00,73,00,\
    79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,65,00,6c,00,6c,\
    00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,4f,00,70,00,65,00,6e,00,41,00,\
    73,00,5f,00,52,00,75,00,6e,00,44,00,4c,00,4c,00,20,00,25,00,31,00,00,00
    "DelegateExecute"="{e44e9428-bdbc-4987-a099-40dc8fd255e7}"

    [HKEY_CLASSES_ROOT\Unknown\shell\opendlg]
    "LegacyDisable"=""
    "MultiSelectModel"="Single"

    [HKEY_CLASSES_ROOT\Unknown\shell\opendlg\command]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
    00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,72,00,75,00,\
    6e,00,64,00,6c,00,6c,00,33,00,32,00,2e,00,65,00,78,00,65,00,20,00,25,00,53,\
    00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,00,5c,00,73,00,\
    79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,65,00,6c,00,6c,\
    00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,4f,00,70,00,65,00,6e,00,41,00,\
    73,00,5f,00,52,00,75,00,6e,00,44,00,4c,00,4c,00,20,00,25,00,31,00,00,00


    nenne diese vista shell openas command.reg
  • @wakiya
    genau das geht eben nicht ;)

    @felix
    vielen dank für deine Hilfe
    ich werd ma sehen ob ich das hinbekomme, ich kenn mich nämlich in der registry nicht aus

    wenns probleme gibt hoffe ich ihr könnt mir nochmal helfen

    so long
    yeti

    edit:
    ich hab das mal probiert aber es funktioniert nicht
    also ich habe praktisch - wie du gesagt hast - die Unterordner erstellt bei .gvi
    ausserdem steht bei Wert, wenn ich in den .gvi ordner gehe, 'Google Video Player.exe' also das Programm was die Datei öffnen soll ??
    ----------------------------
    George Best: "Ich habe viel von meinem Geld für Alkohol, Weiber und schnelle Autos ausgegeben.
    Den Rest habe ich verprasst."
    Mein PC
  • Hi,

    versuche es mal mit Systemsteuerung ---> Ordneroptionen--> Reiter Dateitypen. Unter "Neu" kannst du, wenn bisher nicht registriert, Dateitypen registrieren und unter "Ändern" (Dateityp .gvi vorher makieren) mit dem dazugehörigen Programm verknüpfen.

    MfG hei1911
  • @hei1911
    Klar, warum die Registry benutzen, wenn man Systemeinstellungen verwenden kann. Manchmal denke ich zu kompliziert.

    So, ich habe jetzt extra für dich den Google Video Player installiert. Erstelle eine Datei gvi.reg mit diesem Inhalt aus einer frischen Installation und führe die Datei aus. Wenigstens das sollte funktionieren, ansonsten wähle Öffnen mit, .... :weg:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.gvi]
    @="Google Video Player.gvi"

    [HKEY_CLASSES_ROOT\.gvp]
    @="Google Video Player.gvp"

    [HKEY_CLASSES_ROOT\Google Video Player.gvi]
    @="Google Video file"
    "BrowserFlags"=dword:00000008
    "EditFlags"=dword:00010000
    "PreferExecuteOnMismatch"=dword:00000001

    [HKEY_CLASSES_ROOT\Google Video Player.gvi\DefaultIcon]
    @="\"C:\\Programme\\Google\\Google Video Player\\GoogleVideoPlayer.exe\",1"

    [HKEY_CLASSES_ROOT\Google Video Player.gvi\shell]
    @="Play"

    [HKEY_CLASSES_ROOT\Google Video Player.gvi\shell\Play]

    [HKEY_CLASSES_ROOT\Google Video Player.gvi\shell\Play\command]
    @="\"C:\\Programme\\Google\\Google Video Player\\GoogleVideoPlayer.exe\" \"%1\""

    [HKEY_CLASSES_ROOT\Google Video Player.gvp]
    @="Google Video file"
    "BrowserFlags"=dword:00000008
    "EditFlags"=dword:00010000
    "PreferExecuteOnMismatch"=dword:00000001

    [HKEY_CLASSES_ROOT\Google Video Player.gvp\DefaultIcon]
    @="\"C:\\Programme\\Google\\Google Video Player\\GoogleVideoPlayer.exe\",2"

    [HKEY_CLASSES_ROOT\Google Video Player.gvp\shell]
    @="Play"

    [HKEY_CLASSES_ROOT\Google Video Player.gvp\shell\Play]

    [HKEY_CLASSES_ROOT\Google Video Player.gvp\shell\Play\command]
    @="\"C:\\Programme\\Google\\Google Video Player\\GoogleVideoPlayer.exe\" \"%1\""



    Mal was ganz anderes. Ich habe mir dein System angesehen, du hast einen RAM-Riegel auf der orangefarbenen Bank, den anderen Riegel auf der grünen Bank. Somit hast du den Dual-Channel-Mode deaktiviert. Du solltest beide Riegel auf einer Bank installieren, die erste ist wohl orange.

    Gruß

    FeliX_22
  • Hallo,
    also ich hab bis jetzt noch folgendes probiert:
    -Standartwerte mit der .reg Datei wiederhergestellt
    -die Werte unter Unknown -> Shell -> Openas usw. kontrolliert
    -mit und ohne Haken Programm ausgewählt
    -bei Ordneroptionen und Datentypen ists das gleiche: Programm wird ohne Fehlermeldung nicht zur Liste hinzugefügt
    -Reg Datei von Felix erstellt und ausgeführt, unter HKEY_CLASSES_ROOT\.gvi befindet sich aber kein weiterer Schlüssel
    habe ich da was falsch gemacht?

    OT: das mit meinem RAM stimmt schon so wie's ist
    ich hab extra für dich nochmal ins HAndbuch geschaut :D
    ----------------------------
    George Best: "Ich habe viel von meinem Geld für Alkohol, Weiber und schnelle Autos ausgegeben.
    Den Rest habe ich verprasst."
    Mein PC
  • Hallo!

    Ja das ist schon richtig so. Der Schlüssel .gvi verweist, wie du rechts unter Wert sehen kannst, auf den Schlüssel "Google Video Player.gvi" In diesem Schlüssel ist dann die Bezeichnung, das DefaultIcon und die zu startende Anwendung eingetragen. Das selbe dann mit .gvp.

    Und es funktioniert immer noch nicht, wenn du eine .gvi startest? Hast du den Player im Standardpfad installiert?

    OT:
    Ich habe auch eben im Handbuch des MSI MS-7250 K9N SLI nachgesehen (sofern das deiner ist), hier steht:
    Bestimmung Zweikanalbetrieb: Die DIMM Slot(s) des Kanals A sind in GRÜN gehalten. Die DIMM Slot(s)
    des Kanals B sind ORANGE.


    Dagegen heißt es in der Platinum version mit dem schwarzen Mainboard, die du nicht hast:

    In dual-channel mode, make sure that you install memory modules of the
    same type and density in different channel DDR DIMMs.


    Gruß

    FeliX_22
  • also in der registry steht bei Wert unter .gvi und .gvp 'Google Video Player.exe'
    trotzdem will er die Dateien immer mit 7zip öffnen, weil das Prog auch unter 'Empfohlene Programme' der 'Öffnen mit...' Liste steht

    der Player ist aber nicht im Standartpfad gespeichert
    bei mir ist nur XP auf C: und der Player unter
    D:\Videobearbeitung\Video-Player\Google Video Player

    weiter bei OT: :D
    cpuz zeigt an ...........Channels # Dual.................
    ----------------------------
    George Best: "Ich habe viel von meinem Geld für Alkohol, Weiber und schnelle Autos ausgegeben.
    Den Rest habe ich verprasst."
    Mein PC
  • Hi!

    Da scheint ja einiges nicht zu stimmen. Ich rate dir den Player zu deinstallieren und neu zu installieren, dauert ja nicht lange. Dabei sollte er sich wieder die Dateierweiterungen krallen. Und wenn du ihn wieder unter (D:) installieren willst, dann musst du natürlich den Pfad anpassen.

    Zur Sicherheit solltest du evtl. verwaiste Schlüssel sofort nach der Deinstallation löschen, sonst hast du nachher ein größeres Durcheinander.

    Sollte also nach der Neuinstallation das Problem nicht behoben sein, dann (und nur dann) führst du diese Reg-Datei aus:

    Quellcode

    1. Windows Registry Editor Version 5.00
    2. [HKEY_CLASSES_ROOT\.gvi]
    3. @="Google Video Player.gvi"
    4. [HKEY_CLASSES_ROOT\.gvp]
    5. @="Google Video Player.gvp"
    6. [HKEY_CLASSES_ROOT\Google Video Player.gvi]
    7. @="Google Video file"
    8. "BrowserFlags"=dword:00000008
    9. "EditFlags"=dword:00010000
    10. "PreferExecuteOnMismatch"=dword:00000001
    11. [HKEY_CLASSES_ROOT\Google Video Player.gvi\DefaultIcon]
    12. @="\"D:\\Videobearbeitung\\Video-Player\\Google Video Player\\GoogleVideoPlayer.exe\",1"
    13. [HKEY_CLASSES_ROOT\Google Video Player.gvi\shell]
    14. @="Play"
    15. [HKEY_CLASSES_ROOT\Google Video Player.gvi\shell\Play]
    16. [HKEY_CLASSES_ROOT\Google Video Player.gvi\shell\Play\command]
    17. @="\"D:\\Videobearbeitung\\Video-Player\\Google Video Player\\GoogleVideoPlayer.exe\" \"%1\""
    18. [HKEY_CLASSES_ROOT\Google Video Player.gvp]
    19. @="Google Video file"
    20. "BrowserFlags"=dword:00000008
    21. "EditFlags"=dword:00010000
    22. "PreferExecuteOnMismatch"=dword:00000001
    23. [HKEY_CLASSES_ROOT\Google Video Player.gvp\DefaultIcon]
    24. @="\"D:\\Videobearbeitung\\Video-Player\\Google Video Player\\GoogleVideoPlayer.exe\",2"
    25. [HKEY_CLASSES_ROOT\Google Video Player.gvp\shell]
    26. @="Play"
    27. [HKEY_CLASSES_ROOT\Google Video Player.gvp\shell\Play]
    28. [HKEY_CLASSES_ROOT\Google Video Player.gvp\shell\Play\command]
    29. @="\"D:\\Videobearbeitung\\Video-Player\\Google Video Player\\GoogleVideoPlayer.exe\" \"%1\""
    Alles anzeigen


    zum OT:
    Ich gebs auf.

    Gruß

    FeliX_22