VPN-Verbindung automatisch herstellen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • VPN-Verbindung automatisch herstellen

    Moin FSB-ler,

    ich wußte nicht, in welchen Bereich dieses Thema wirklich gehört - eigentlich ja in Internet und Telekommunikation, aber dort gibt´s kein passendes Unterforum.
    Darum habe ich es jetzt hier erstellt, sollte es doch wonaders hingehören, bitte ich einen Mod, es zu verschieben.

    Jetzt zu meiner Frage:

    Ich nutze seit kurzem eine VPN-Verbindung. Diese muss ich nach jedem PC-Start manuell herstellen.

    Gibt es eine Möglichkeit, dass die VPN-Verbindung automatisch - wie die normale Internet-Verbindung - nach dem Systemstart hergestellt wird?

    Ich muss zugeben, dass ich so manchmal "vergesse", die VPN-Verbindung herzustellen :depp:, oder dass es mir erst nach ein paar Minuten einfällt, und das ist ja wirklich nicht Sinn der Sache.

    Habe beim "ixquicken" nix gefunden, was mir wirklich hilft.

    mfg Earthling
  • Hallo Earthling!

    Ich nehme an, das Problem ist noch aktuell...

    Wenn ja, schau dir mal fürs erste den Befehl rasdial an (rasdial/? in cmd eingeben).

    Mit welcher Software stellst du die VPN-Verbindung her?

    Ansonsten fällt mir zu "automatisch" wie immer ein selbstgebasteltes VBScript ein :D Aber dafür bräuchte man eben mehr Informationen.

    Gruß

    FeliX_22

    EDIT:
    Hättest du statt ixquicken gegoogelt, wär dir sicher das begegnet: Klick :D (Habs mir jetzt nicht durchgelesen)
  • Hi,

    das Problem ist nach wie vor aktuell.

    Ich verwende keine Software dafür, wenn du genaueres wissen möchtest, gerne per PN.

    Die Seite von FeliX_22 hatte ich auch gefunden (sogar mit Ixquick :D) - aber ich kann damit nicht wirklich was anfangen. Es ist auch nicht das, was ich eigentlich möchte:
    Soll beim Start von Windows automatisch eine VPN-Verbindung via Internet zu einem Server hergestellt werden, zusätzlich eine Netzwerkverbindung zu einem Laufwerk bzw. Ordner auf dem Server erstellt werden und das Ganze für den PC-User unbemerkt geschehen, geht man wie folgt vor.

    Ich möchte ja, dass beim Windows-Start zuerst die ganz normale Internet-Verbindung hergestellt wird - wie sonst auch - und direkt danach gleich die VPN-Verbindung.

    Von selbstgeschriebenen Scripts verstehe ich leider nicht allzu viel..... mein Wissen beschränkt sich in erster Linie auf VisualBasic-Grundwissen.... bzw.VBA mit Excel.....

    Die Verknüpfung in den Autostart zu legen, bringt leider auch nicht das gewünschte Ergebnis - sprich, es passiert gar nix :(.

    Gruß Earthling
  • Earthling schrieb:

    Ich möchte ja, dass beim Windows-Start zuerst die ganz normale Internet-Verbindung hergestellt wird - wie sonst auch - und direkt danach gleich die VPN-Verbindung.


    Da fällt mir ein du hast ja eine fest IP! Deshalb weiß ich nicht, wie du nach dem Start die Internet-Verbindung herstellen willst, ein Modem/Router ist ja immer verbunden. Aber gut, die normale Internetverbindung ist hier nicht das Problem.

    Ich glaub echt, ich habe hier zu wenige Informationen, weil ich selbst nur das Cisco-Programm kenne. Kannst du bitte (hier, PN, ICQ) genau schreiben welche Schritte du ausführst um die Verbindung zu starten? Wenn du jeden Schritt eingibst, dürfte ein Script schnell geschrieben sein.

    Im Übrigen, wenn du VB/VBA kennst, kennst du schon die VBS-Syntax. Es gibt hier eben nur andere Befehle (z.B auf Explorer-Ebene).

    Gruß

    FeliX_22
  • Moin FeliX_22,

    die Internet-Verbindung wird ja direkt beim System-Start hergestellt, wenn der PC startet, dauert es immer ein paar Sekunden, bis sie steht. Die VPN-Verbindung darf erst dann hergestellt werden, wenn die normale Internet-Verbindung bereits hergestellt ist - sonst funktioniert es nicht.

    Zur VPN-Verbindung:
    Inzwischen habe ich eine VPN-Verbindung über Swiss VPN, kennst du bestimmt. Diese habe ich im Netzwerk-Center eingerichtet, mit den entsprechenden Zugangsdaten.
    Wenn ich sie herstellen möchte, kann ich das entweder über den Netzwerk-Center oder über das Netzwerk-Icon im Tray machen.
    Brauchst du noch irgendwelche Infos? Mir fällt dazu grad nix mehr ein.

    Gruß Earthling
  • Morgen!

    Nein, wie gesagt kenne ich als einzige VPN-Software nur den Cisco-Client. Hab mir eben mal kurz SwissVPN angesehen. Jetzt hab ich auch mal die normale VPN-Verbindung mit Windows-Mitteln entdeckt :)

    Da ich nicht weiß, wie es genau aussieht, wenn man den PC (und nicht den Router) mit dem Internet verbinden muss: Wenn du in den Netzwerkverbindungen die Eigenschaften der SwissVPN-Verbindung anzeigst, siehst du dann unter Andere Verbindungen zuerst wählen einen Eintrag, der für deine Internetverbindung zuständig ist?

    Gruß

    FeliX_22

    EDIT:
    Netzwerkverbindungen oder Netzwerk Center... Ich bin noch bei XP :P

    Ich probier grad was aus...
  • Hi FeliX_22,

    die Verbindung kann man über Netzwerk- und Freigabecenter oder über Netzwerkverbindungen herstellen.

    Unter der Option "andere Verbindungen zuerst herstellen" habe ich keine Auswahlmöglichkeit - das Drop-Down-Feld enthält keinen Eintrag.
    Davon abgesehen muss zuerst die "normale" Internetverbindung stehen - sonst lässt sich die VPN-Verbindung nicht herstellen.


    Gruß Earthling
  • Hi!

    Sorry, war den ganzen Tag beschäftigt, also wenn das geklappt hat, dann würde schon ne bat-Datei ausreichen. Aber die sind, naja, veraltet. Außerdem hast du ja Vista, funktionieren die da überhaupt noch? Dann kannst du einfach mal ne BAT in deinen Autostart ziehen. Ich benutz aber lieber VBScripts, hier also etwas Code, sieht aus wie zusammenkopiert :D

    VPNConnect.vbs

    Quellcode

    1. ' Script verbindet den PC mit einer VPN-Verbindung
    2. Set WSHShell = WScript.CreateObject("WScript.Shell")
    3. ' Variablen
    4. vbConnectionName = "SwissVPN"
    5. vbConnectionUser = "swissvpntest"
    6. vbConnectionPassword = "swissvpntest"
    7. vbConnectWith = "rasdial" & " """ & vbConnectionName & """ """ & vbConnectionUser & """ """ & vbConnectionPassword & """"
    8. ' 20 Sekunden warten, bis alle Tasks hochgefahren sind
    9. 'WScript.Sleep 20000
    10. ' Verbindung herstellen
    11. WSHShell.Run vbConnectWith
    Alles anzeigen



    Das mit den 20 Sekunden sollte klar sein. Da ist keine Fehlerbehandlung oder so drin, die hab ich rausgenommen, kann dir noch ne debugdatei reinschreiben.

    Möchtest du vor dem Herunterfahren noch explizit die Verbindung trennen?

    VPNDisconnect.vbs

    Quellcode

    1. ' Script trennt den PC von einer VPN-Verbindung
    2. Set WSHShell = WScript.CreateObject("WScript.Shell")
    3. ' Variablen
    4. vbConnectionName = "SwissVPN"
    5. vbDisconnect = "rasdial" & " """ & vbConnectionName & """ /DISCONNECT"
    6. ' Verbindung trennen
    7. WSHShell.Run vbDisconnect


    Grüße

    FeliX_22
  • Moin FeliX_22!

    Zuerst einmal vielen Dank für deine Hilfe! :danke:

    Wenn ich das 1. Script im laufenden Betrieb ausführe, wird die VPN-Verbindung (sofort) hergestellt.
    Ich habe sie in den Autostart gezogen und beim Systemstart funktioniert es leider nicht. Das cmd-Fenster öffnet sich - wartet auch eine gewissen Zeit ab - dann kommt eine Fehlermeldung "RAS Fehler 711" und die VPN-Verbindung wird nicht hergestellt.

    Dachte erst, dass die 20 Sekunden ev. zu knapp sind und habe es auf 40 Sekunden geändert - es kommt aber die gleiche Fehlermeldung.

    Was mir noch aufgefallen ist:
    Wenn ich das Script aus dem laufenden System starte, steht im cmd-Fenster "Benutzername und Kennwort werden überprüft....." - beim Systemstart steht vor der Fehlermeldung nix im cmd-Fenster (kA, ob das normal ist).

    Gruß Earthling
  • Hallo!

    Hab mir jetzt mal Vista Business 64bit auf VMware installiert. Zunächst hatte ich genau das selbe Problem wie du: Script wird beim Anklicken korrekt ausgeführt, aber im Autostart-Ordner als Verknüpfung nicht, wenn das System hochgefahren ist.

    Dann hab ich unter Systemsteuerung > Verwaltung > Dienste einige Einträge, die Deaktiviert waren (weiß leider nicht mehr welche das waren) auf Automatisch gestellt. Im Besonderen aber die Einträge: Routing und RAS, RAS-Verbindungsverwaltung, Telefonie, Plug & Play und Remoteprozeduraufruf (RPC). Einige dieser Einträge sind schon standardmäßig auf Automatisch.

    Tja und jetzt funktionierts bei mir, auch ohne 20 Sekunden Wartezeit. Sofort nach dem Neustart und Login wird die Verbindung hergestellt, da ich die Verknüpfung zum Script im Autostart Ordner habe. :)

    Das komische: Ich habe den Dienst Routing und RAS wieder auf Deaktiviert gesetzt und trotzdem funktioniert die Anmeldung.

    Vielleicht kannst du was damit anfangen. Wenn nicht, werd ich Vista neu installieren und diesmal genau darauf achten, welche Dienste ich umgestellt habe.

    Viel Glück!

    Gruß

    FeliX_22
  • Hi FeliX_22!

    Habe die von dir genannten Dienste durchgesehen und ich glaube, es waren 3, die nicht auf Automatisch eingestellt waren.

    Und was soll ich sagen: Jetzt funktioniert es bei mir auch!

    Ich danke dir vielmals für die Mühe, die du dir damit gemacht hast (sogar Vista auf VMware installiert - das geht ja nicht in 5 Minuten)!

    Hätte echt nicht gedacht, dass ich das je hinbekomme!




    Gruß Earthling