Frage zu UTF-8

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Frage zu UTF-8

    Hi,

    ich habe eine Frage zu UTF-8

    Immer wenn ich was damit mache, also codiere oda wie das heißt :D (und anderes kann ich nicht verwenden)

    Dann wird der Text perfekt gechrieben!

    Soweit so gut, aber ich finde imme irgendwo sowelche Zeichen: ��������

    Und das merkwürdigste ist ... die stehen da, wo eig. kein Text steht ...

    Was soll ich machen?

    MfG

    wassilij
  • UFT-8 beihaltet nur das lateinische Alphabet und ein paar Symbole. Alles, was aus dem Rahmen fällt wird mit diesem Platzhalter bestückt.
    Also kannst du davon ausgehen, dass dort nicht das Leerzeichen, sondern ein anderes Symbol verweilt. Vielleicht ja Einschübe.
    Probiere einfach mal die Platzhalter mit Leerzeichen zu ersetzen.

    Gruß
    Broken Sword
  • Broken Sword schrieb:

    ???
    Was meinst du damit?


    Wie gesagt, dort wo Kästchen sind einfach Leerzeichen schreiben, dann sollten diese Verschwinden.


    Aber wo diese Kästenchen sind ist ja garnix, das ist es ja!

    Das ist zwischen einem Titel und einem include (per php) ... da ist garnix mehr ... da habe ich auch alle leerzeichen weggemacht ... da sollte eig. nix sein ...
  • versuchs mal damit:

    HTML-Quellcode

    1. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    2. "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    3. <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de" lang="de">
    4. <head>
    5. <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    6. </head>