flashFXP, problem: 'passive mode'

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • flashFXP, problem: 'passive mode'

    hi alle zusammen

    das problem mit der passive mode in proxy server habt ihr sicher schon gehört. nun, ich habe mich in diesem und anderen foren ein wenig durchgelesen, doch ich konnte bis jetzt noch keine Lösung für mein Problem finden.
    Mein Problem ist folgendes ...
    Wenn ich mich über einen proxyserver verbinde, dann sehe ich keine dateien.
    bzw. :

    WinSock 2.0
    Connecting to xxx.xxx.xx.xxx via Proxy (xxx.xxx.xxx.xx:1080)
    220 sicodinetser Microsoft FTP Service (Version 5.0).
    331 Anonymous access allowed, send identity (e-mail name) as password.
    PASS (hidden)
    230 Anonymous user logged in.
    SYST
    215 Windows_NT version 5.0
    PWD
    257 "/" is current directory.
    TYPE A
    200 Type set to A.
    PASV
    227 Entering Passive Mode (xxx,xxx,xx,xxx,18,195).
    Socks: request rejected or failed
    LIST
    425 Can't open data connection.
    List Complete: 0 bytes in 39,50 (1,00 KBps)
    (ich sehe aber keine dateien)

    so, wenn ich nun uppen will, dann meldet er folgendes:

    TYPE I
    200 Type set to I.
    PASV
    227 Entering Passive Mode (xxx,xxx,xx,xxx,18,220).
    Socks: request rejected or failed
    STOR filexxx.zip
    425 Can't open data connection.
    Transfer Failed!
    TYPE A
    200 Type set to A.
    PASV
    227 Entering Passive Mode (xxx,xxx,xx,xxx,18,221).
    Socks: request rejected or failed
    LIST
    425 Can't open data connection.
    List Complete: 0 bytes in 38,63 (1,00 KBps)
    Transfer queue completed
    1 File failed to transfer

    so...
    nun gibt es bei fxp wie bei fast allen ftp programmen die option:
    use passive mode, die man deaktivieren kann um diese fehler zu vermeiden.

    nun zum eigentlichen proglem:
    wenn ich diese option in .preferences>.proxy/firewall/ident deaktiviere, aktiviert sie sich von selbst wieder wenn ich mit OK bestätigt habe.

    Ich habs auch bei quick connect und im site manager deaktiviert, obwohl die option dort ja nicht für den server, sondern ja eigentlich für den proxy gedacht ist wenn ich den aktiviert habe.

    fakt ist, wenn ich bei quick connect oder im site manager, den proxy umgehe (bypass proxy server for this connection), dann klappt es und er wendet den command 'PASV' nicht an.

    meine Frage nun:

    ist euch dieses problem bekannt?
    wieso aktiviert sich die option 'use passive mode' in .preferences>.proxy/firewall/ident vonselbst wieder?
    wie bringe ich meinen proxy dazu sich aktiv und nicht passiv anzumelden?

    wäre froh wenn mir jemand diese fragen beantworten könnte, da ich sicher nicht der einzige bin der dieses problem hat und ich noch keine Lösung gefunden habe.

    noch ein par angaben zu meinem pc

    OS: winXP Professional
    CPU: AMD Athlon XP 1800+
    RAM: 512MB DDR Ram
    NET: Cable 1024/256

    vielleicht störende Programme: G6 FTPserv, emule, kazaa, mIRC
  • Ich hab das Problem auch schön öfter gehabt!!
    und wusste auch nie wirklich ne klare Lösung!!
    was ich weiß das, wenn man nen proxy reingeht der Passive mode glaube ich immer an sein muss, sonst funz net!!

    aber gehst du mit nem router in´s i-net??

    MfG LuZiFFeR
  • nein, nur kabelmodem

    aber wenn man die mode immer an haben muss, wieso gibts diese option?
    ausserdem muss es ja irgendwie möglich sein sich übern proxy zu verbinden und dann auch was zu machen ( uppen etc )