VPNC unter Ubuntu zickt rum!!

  • Problem

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • VPNC unter Ubuntu zickt rum!!

    hey leutz,
    bin noch relativ neu hier im board und muss nun auch mal meinen allersten Thread eröffnen:)

    Vielleicht, könnt ihr mir ja bei meinem Problem helfen :cool:

    Also um was gehts?

    1. Zugriff von zu Hause auf Uninetz via VPN vom lappy/desktop-pc über wlan
    2. Benutzung von vpnc um mich zu connecten ->Verbindungserror
    3. Allerdings wenn lappy/desktop-pc via kabel zum router verbunden sind funzt das vpnc 100%ig

    Woran könnte das nun liegen, das vpnc einen fehler bringt wenn die besagten Rechner per wlan zum Router verbunden sind?

    kurze Zusammenfassung:

    1. Windows + wlan -> cisco-vpnclient funzt 1A -> liegt kein routerproblem vor
    2. ubuntu + virtuelles windows -> cisco-vpnclient funzt 1A
    3. ubuntu + wlan -> vpnc läuft nicht
    4. ubuntu + lan -> vpnc funzt 1A

    wäre sehr dankbar für eine hilfestellung:) ..

    mfg jtjaneway
  • Hallo,

    Ich hatte ein ähnliches Problem mit Ubuntu und dem VPN-Netzwerk der Uni.

    Versuch mal, den originalen Cisco-VPNClient für Linux zu verwenden, das hat wenigstens bei mir geholfen.
    Eine Installationsanleitung gibt es hier: Cisco-VPN-Client - ubuntuusers Wiki
    Ich habe den Eindruck, dass der VPNC, der ja Open-Source ist, mit neueren Cisco-Servern nicht richtig kompatibel ist.

    mfg, albirdy
  • hey vielen dank für die fixxe aw:) ,
    problem is nur der cisco-vpnclient für ubuntu lies sich leider nicht installieren :(. hatte ich näml. auch schon mal.

    was mir nur schleierhaft ist, ist das vpnc ja unter ubuntu 100%ig läuft sobald mein rechner/lappy via kabel am router hängt. es will nur eben leider nicht wenn der rechner/lappy via wlan mit dem router verbunden ist, dh. vpnc funzt ja mit unserem uni-vpn

    grüße
    jtjaneway

    ps:
    könnt mich gern auch via icq anschreiben
  • Hmm, das ist in der Tat ziemlich seltsam, denn es gibt ja netzwerktechnisch keinen Unterschied zwischen LAN und WLAN. Es kann also nur daran liegen, dass vpnc versucht, sich mit dem falschen Netzwerkinterface zu verbinden.
    Während du mit dem WLAN verbunden bist, deaktiviere mal den LAN-Adapter mit

    Quellcode

    1. sudo ifconfig eth0 down

    und versuch dich mit dem vpnc zu verbinden.
    Sollte das nicht helfen, gib bitte mal folgendes in eine Konsole ein und poste die Ausgabe von

    Quellcode

    1. ifconfig
    2. route
    3. cat /etc/vpnc/*.conf (Zugangsdaten bitte nicht posten ;) )

    und die Ausgabe von vpnc beim Verbindungsversuch.
  • huhu,
    also..werds glei wieder testen
    hab bevor ich deins gelesen habe nomma versucht via ubuntu-livecd zzgl. pakete resolvconf+vpnc+nm-vpnc installiert...dh ich werd glei nomma deinen vorschlag testen :)

    meine conf

    ## generated by pcf2vpnc
    IPSec ID xxxxxxxxxxx
    IPSec gateway xxxxxxxxxxxxxxx
    IPSec secret xxxxxx

    IKE Authmode psk

    ## To add your username and password,
    ## use the following lines:
    # Xauth username <your username>
    # Xauth password <your password>
    #Target networks xxxxxx


    nun nehm ich mein profil und starte es mit vpnc-connect "profil" und es kommt

    "vpnc-connect: no response from target"


    dann hab ich mir mal die syslog angeguggt un da steht

    "tun0: Disabled Privacy Extensions".


    ach un mit hilfe des network-managers kommt diese meldung

    "The VPN login failed because the VPN program could not connect to the VPN server."


    bloß wiegesagt via kabel funzte das 100%ig selbst als ich s mit livecd testete!!

    grüße

    ps:
    ich poste dir denne dein vorschlag ;)

  • [email protected]:~$ ifconfig
    eth0 Link encap:Ethernet Hardware Adresse 00:11:09:8a:86:72
    UP BROADCAST MULTICAST MTU:1500 Metrik:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:23 Basisadresse:0x8000

    eth0:avahi Link encap:Ethernet Hardware Adresse 00:11:09:8a:86:72
    inet Adresse:169.254.6.20 Bcast:169.254.255.255 Maske:255.255.0.0
    UP BROADCAST MULTICAST MTU:1500 Metrik:1
    Interrupt:23 Basisadresse:0x8000

    lo Link encap:Lokale Schleife
    inet Adresse:127.0.0.1 Maske:255.0.0.0
    inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
    UP LOOPBACK RUNNING MTU:16436 Metrik:1
    RX packets:13666 errors:0 dropped:0 overruns:0 frame:0
    TX packets:13666 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:0
    RX bytes:683300 (667.2 KB) TX bytes:683300 (667.2 KB)

    wlan0 Link encap:Ethernet Hardware Adresse 00:11:09:5a:a6:91
    inet Adresse:192.168.2.102 Bcast:192.168.2.255 Maske:255.255.255.0
    inet6-Adresse: fe80::211:9ff:fe5a:a691/64 Gültigkeitsbereich:Verbindung
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
    RX packets:8231 errors:0 dropped:0 overruns:0 frame:0
    TX packets:5455 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:1000
    RX bytes:10704602 (10.2 MB) TX bytes:704016 (687.5 KB)

    wmaster0 Link encap:UNSPEC Hardware Adresse 00-11-09-5A-A6-91-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)



    [email protected]:~$ route
    Kernel-IP-Routentabelle
    Ziel Router Genmask Flags Metric Ref Use Iface
    192.168.2.0 * 255.255.255.0 U 0 0 0 wlan0
    link-local * 255.255.0.0 U 0 0 0 eth0
    default speedport.ip 0.0.0.0 UG 0 0 0 wlan0
    default * 0.0.0.0 U 1000 0 0 eth0


    so aber hab alles so gemacht wie vorgeschlagen aber leider ohne erfolg :(

    grüße jtjaneway
  • Hey,

    also ich bin mit meinem Rat am Ende :confused:
    Die Netzwerkkonfiguration ist ganz normal, da ist nichts was den Fehler verursachen kann. Wenn es mit Kabel-LAN auch nicht funktionierte, hätte ich noch tausend Lösungsvorschläge, aber so...
    Das einzige was mir jetzt noch einfällt ist das testweise Ausschalten der SPI Firewall vom Router, aber wenn dort das Problem wäre, so müsste sich das normalerweise auch auf das LAN auswirken. Aber probieren kannst du es mal...

    Gruß, albirdy
  • so, hab wohl nun den fehler rausgefunden, dank dir :)

    muss wohl am router liegen aber wo ich was einzustellen habe weiß ich net da der router auch nich grad mir gehört^^

    jedenfalls liegts am router, da bei mir zu hause das vpnc via wlan 100%ig funzt :).

    vlei weißt du ja wo man da beim speedport w700v guggen muss. ich bin ehrlich ratlos, ich raffe es immernoch nich das vpnc via kabel funzt aba via wlan nich :(

    viele grüße & nice WE