Verschiedene Alter berechnen

  • geschlossen
  • Problem

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Verschiedene Alter berechnen

    Ich hab da ein Problem.
    Ich Arbeit mit einer Datenbank mit 200 Namen und den üblichen Informationen dazu. Bei den Geburtstagen muss ich das Minimun, Maximum und Durchschnittsaler ausweisen. Das habe ich mit "Min", "Max" und "Mittelwert" berechnet.
    Nun muss ich die Anzahl 18 bis 3o Jährigen, 30 bis 40 Jährigen, 40 bis 50 Jährigen und 50 bis 65 Jährigen berechnen.
    Kennt jemand eine Formel mit der ich das berechnen kann. Habe es mit "Datediff" versucht, ist aber fehlgeschlagen.

    Ich wäre über jede Hilfe sehr dankbar.

    Viele Grüsse

    Belmont
  • Hallo belmont,

    wenn du datedif so verwendest, sollte es funzen:

    Quellcode

    1. =DATEDIF(A1;JETZT();"y")

    Und ja, nur mit einem F! In Access ist es mit 2 F, ich weiß ... :(

    Ansonsten geht es auch so:

    Quellcode

    1. =JAHR(HEUTE())-JAHR(A1)

    damit kriegst du das gleiche Ergebnis.
    Internette Grüße
    von der Nautilus
    cpt. Nemo
  • Hi cpt. Nemo,

    Danke für deine Antwort. Aber leider geht es mit diesen Formeln nicht. Ich bekomme nur ein Datum, ich brauche aber eine Zahl.
    Ich denke ich habe mein Problem schlecht erklärt.

    Also ich habe in "A1:A200" 200 verschiedenen Geburtstage drin, zb. 01.02.1953. Der Aelteste ist 64 Jahre alt, der Jüngste 17. In B1 muss ich nun ausweisen wieviele Leute zwischen 18 und 30 Jahre alt sind zb. 15 Leute. In C1 wieviele zwischen 30 und 40 Jahre alt sind. In D1 wieviele zwischen 40 und 50 Jahre usw.

    Ich hoffe du, oder jemand, kannst mir helfen. Habe das Problem schon etliche male gegoogled, aber keine Chance.

    Schon mal Danke für eure Hilfe.

    Gruss

    Belmont
  • Hallo!

    belmont schrieb:

    Ich bekomme nur ein Datum, ich brauche aber eine Zahl.


    Dann stell einfach das Format der Zelle auf Ganzzahl um.

    Ich hab mal selbst was probiert, ich weiß nicht ob du nun das Alter möchtest oder die Anzahl der Personen in den Altersbereichen. Deshalb hab ich mal die Anzahl ganz unten hinzugefügt.



    Zu dem (langatmigen) Formeln:

    B2 =WENN(JAHR(HEUTE())-JAHR($A2)>17;WENN(JAHR(HEUTE())-JAHR($A2)<31;JAHR(HEUTE())-JAHR($A2);"");"")
    C2 =WENN(JAHR(HEUTE())-JAHR($A2)>30;WENN(JAHR(HEUTE())-JAHR($A2)<41;JAHR(HEUTE())-JAHR($A2);"");"")
    D2 =WENN(JAHR(HEUTE())-JAHR($A2)>40;WENN(JAHR(HEUTE())-JAHR($A2)<51;JAHR(HEUTE())-JAHR($A2);"");"")
    E2 =WENN(JAHR(HEUTE())-JAHR($A2)>50;WENN(JAHR(HEUTE())-JAHR($A2)<61;JAHR(HEUTE())-JAHR($A2);"");"")
    F2 =WENN(JAHR(HEUTE())-JAHR($A2)>60;WENN(JAHR(HEUTE())-JAHR($A2)<71;JAHR(HEUTE())-JAHR($A2);"");"")
    G2 =WENN(JAHR(HEUTE())-JAHR($A2)>70;WENN(JAHR(HEUTE())-JAHR($A2)<81;JAHR(HEUTE())-JAHR($A2);"");"")
    H2 =WENN(JAHR(HEUTE())-JAHR($A2)>80;WENN(JAHR(HEUTE())-JAHR($A2)<91;JAHR(HEUTE())-JAHR($A2);"");"")
    I2 =WENN(JAHR(HEUTE())-JAHR($A2)>90;WENN(JAHR(HEUTE())-JAHR($A2)<101;JAHR(HEUTE())-JAHR($A2);"");"")
    J2 =WENN(JAHR(HEUTE())-JAHR($A2)>100;JAHR(HEUTE())-JAHR($A2);"")

    Leider sind die Formeln alles andere als handlich, aber sie führem zum Ergebnis. Wenn du die Zellen B2:J2 markierst, kannst du sie runterkopieren. Und für die Anzahl nimmst du einfach die Standard-Formel:

    B26 =ANZAHL(B2:B25)
    usw...

    Hoffe das hilft dir weiter.

    Gruß

    FeliX_22
  • Hallo FeliX_22

    ich habe es gleich ausprobiert und ich muss zu meinem Erstaunen sagen, es funktioniert. Ich bin sehr froh darüber. Ich habe da noch andere Probleme mit dieser Datenbank aber sie sind sehr schwer zu formulieren.

    Aber zuerst mal, vielen Herzlichen Dank für deine Super Hilfe. Du hast dir viel Mühe gemacht. Auch ein Dankeschön an cpt. Nemo. Solche Hilfe findet man sonst selten.