Bild schneller als der Ton!

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Bild schneller als der Ton!

    Guten Morgen zusammen!

    Habe folgendes Problem mit Super 2008 converter, bei der Umwandlung einer mkv.datei in divx. datei bekomme ich zwar ein Ergebnis, das aber nicht zu verwerten ist. Das Bild läuft mit zwei oder vierfacher Geschwindigkeit und der Ton normal.
    Ich stelle folgendes ein.
    Einstellung Decoder: ffmpeg oder M Encoder
    Output Container: avi
    Output Video Codec :divx
    Output Audio Codec: ac3
    Auflösung: 720*480
    Seitenverhältnis: 16:9 Aspect wird automatisch auf 3:2 gestellt
    Audio: AC3 : 192kps

    Und dann lasse ich ich arbeiten. Wenn ich das fertige Ergebnis betrachte, läuft der Film, wie gesagt, als wenn ich ich ihm im Schnelldurchlauf ansehen würde, doch der Ton ist richtig. Neustes Divx und AC3 codec ist auch drauf.
    Ebenso wurde der Combined Community Codec Pack und K-lite Codec Pack installiert.
    Da ich es auch schon mit winavi doer oder mkvtoavi probiert habe, doch diese mit den Codec´s nciht klar kommen, möchte ich Super 2008 weiter benutzen.
    Das Programm WIN AVI funktioniert leider nicht mehr, da es bei 99% die Arbeit nicht abschließt. Und MKV läuft erst wenn ich den K-lite Codec Pack installiert habe, obwohl doch der Combined Community Codec Pack vorgesehen wäre. Leider kommt da auch kein Ergebnis zustande.
    Als Anmerkung möchte ich auch noch hinzu fügen, dass meine Rechner genügend Rechenpower hat. Trotzdem möchte ich Euch nicht mit den letzten beiden Programmen nerven, daher geht es mir vorrangig um das Converten mit Super 2008!

    Falls mir jemand helfen kann, wäre dies sehr nett von Euch.

    Gruß Quake
  • Hallo quake,
    Es gibt einen mittlerweile schon älteren Kalauer :
    "wer Codec-Packs nutzt ist selber schuld"
    Die sind berüchtigt dafür diverse Probleme zu bereiten.
    Es reicht vollkommen ffDShow zu installieren.
    (und vielleicht noch DviX/XviD und x264)
    weil alle drei häufig aktualisiert werder.
    Dir ist hoffentlich klar, das Du mit dieser Umwandlung die Bildqualität
    verschlechterst ?
  • Guten Morgen!

    Also einmal zu dem Kommentar zu Coldriddick, "Wer lesen kann ist klar im Vorteil"!!
    Da ich ja oben schrieb, dass ich Super benutze.
    Und zu Stoppel kann ich nur sagen, dass ich bis dahin noch nie Probleme mit einem Codec Pack hatte. Und ja, mir ist klar dass die Qualität des Films schlechter wird. Aber da ich halt nicht wie Du über einen MKV-fähigen DVD Player verfüge, muß ich sie halt umwandeln. Desweiteren hänge ich den ganzen Tag vor dem PC, da hab ich wirklich keine Lust auch noch nen Film dort an zu sehen.
    Bis jetzt war keine Aussage hilfreich, da sich keine Antwort mit dem Problem beschäftigt hat. Daher wenn möglich, Kommentare bringen, die sich auf meine Frage beziehen. Danke!
    Übrigens hab ich es gestern mal mit xvid versucht und siehe da, ein super Ergebnis.
    Dennoch würde ich es auch gern mit Divx schaffen!

    Gruß quake
  • Hi,

    könnte es sein, dass Du eventuell etwas an der Framerate geändert hast?

    zum Beispiel 60 Frames? dann würde ein Film, der ursprünglich mit 24 Bildern/s lief dann ungefähr drei mal so schnell ablaufen.

    Dieselbe Problematik gibt es bei Audio wenn man ein File, das in 44,1kHz aufgezeichnet wurde in 88,2kHz abspielen will.

    Da Du aber sagst, dass der Sound OK ist, läuft also der Ton normal in 44,1kHz (oder wie die Abtastrate war) und das Bild wird schneller abgetastet.

    Das ist doch in ungefähr der Effekt, der bei dir auftritt, oder?

    Ich persönlich würde an Deiner Stelle alle Codec-Packs deinstallieren und mir den VLC-Player installieren. Dann noch ein oder zwei ausgewählte Codecs deiner Wahl. Mehr brauchst Du im Zweifel eh nicht.

    Beste Grüße

    Disko
    [SIZE="2"]"Fachchinesisch kann jeder. Die wahre Kunst ist es, das Fachwissen auf ein für Jeden verständliches Maß herunterzubrechen."[/SIZE]
    [SIZE="1"] - Ich -[/SIZE]
    [SIZE="1"]p.s.: Bei Fragen zu Cubase, VST-Instrumenten oder so - immer gerne per PN an mich! ;)[/SIZE]
  • hallo quake,
    die Deinstallierung der Codec-Pack bezog sich auf Dein Problem.
    Bevor du das nicht versucht hast ist jeder andere Tip
    vergebliche Liebesmühe.
    Ich würde dir ja gerne helfen.
    Aber Ferndiagnosen erfordern das du uns genauer beschreibst
    was du versucht hast und mit welchen Einstellungen.
    (Bevor du die Kodierung startest also nachdem du das mkv-file geladen und
    Zielformat und so eingestellt hast müßte sich unter den temporären files
    die der Converter erzeugt hat ein file mit der Endung .avs befinden.
    Das läßt sich mit dem Editor öffnen, wie eine normale Texrdatei.
    Wenn du das postest, kann ich dir zumindest sagen, ob es an diesem Program liegt.)
    Wenn du sagst doppelte Geschwindigkeit dann vermute ich mal das einer
    deiner Codecs den mkv Container falsch ausliest.(die Framerate wird auch im
    Container angegeben)
  • Guten Abend!

    Hallo Dirk, also ich veränderte dirFrame Rate zur Orginal Datei nicht. Den Ton hab ich auf 48000 AC3 gesetzt.
    Hab nun alle Codec Packs wieder deinstaliert und wie von Stoppel vorgeschlagen nur noch Divx, xvid und H264 installiert. Mal sehen ob ich nun ans Ziel komme.
    Hallo Stoppel, ich versteh halt nur nicht warum der xvid codec den mkv codec richtig auslesen kann und der divx codec nicht. Meiner Meinung nach kann es also nicht an der mkv Datei auslesen liegen.
    Wie gesagt, nehme ja geren ernstgemeinte Ratschläge an, da ich ja hier bin, um etwas dazu zu lernen.
    So, hab es gerade mit ner avi. datei probiert diese einfach in Bereich der Video Scale Size zu neu zu converten. Leider wie dem gleichen Ergebnis, dass der Film viel schneller durchläuft als der Ton. Hab diesen Film mit dem Media Player Classic abgespielt
    Und nun kommt das Tollste, ich hab ihn darauf mit dem Divx Player abgespielt, da ist der Film im richtigen Tempo, jedoch der Ton voll langsam. Echt genialer Effekt. :)
    Der Orginal Film hatte eine Audio Sampling Frequenz von 44100 und ich hab sie auf 48000 gestellt. Könnte es doch daran liegen??

    Gruß quake
  • Äußerst kurios !
    Ich versuche das Problem irgendwie einzukreisen.
    !. MediaPlayerClassic hat eine Funktion Videos schneller abzuspielen,
    kann es sein das diese Funktion permanent aktiviert ist ?
    (Die Schalter zwischen "play;pause;stop" und "Audio on/out"

    2.Ich verstehe nicht was "Video Scale" bedeutet, ist das eine Funktion des
    VideoKonvertierungsprogramms ?

    3.Was gibt denn "GSpot" oder "MediaInfo" an Information aus, wenn du damit die Videodateien untersuchst ?

    Zur Information : avi , mkv , mp4 sind nur Kontainer, vergleichbar etwa mit einem Briefumschlag. Sie können die unterschiedlichsten Sachen enthalten.
    Codec = Codierer + Encodierer ; komprimiert und dekomprimiert Video oder
    Audio Daten (mpg, XviD, h264 usw.)

    Nur Geduld wir kriegen das schon irgendwie hin.
  • Guten Morgen Stoppel!

    Also zu 1. kann ich sagen, dass ich den richtigen Play-Button benutze. Klappt ja bei anderen Filmen auch.

    2. Video Scale gibt die Auflösung wieder, die ich eingestellt habe. Bei mir 720X480, da mein DVD Player dies maximal unterstütz.

    3. Foglende Aufstellung kommt zu Tage mit Media Info

    Format : Matroska
    File size : 1.14 GiB
    PlayTime : 1h 24mn
    Bit rate : 1924 Kbps
    Encoded date : UTC 2008-08-02 09:49:53
    Writing application : mkvmerge v2.2.0 ('Turn It On Again') built on Mar 4 2008 12:58:26
    Writing library : libebml v0.7.7 + libmatroska v0.8.1

    Video #0
    Codec : AVC
    Codec/Family : AVC
    Codec/Info : Advanced Video Codec
    Codec profile : [email protected]
    Codec settings, CABAC : Yes
    Codec_Settings_RefFrames : 3
    PlayTime : 1h 24mn
    Bit rate : 1455 Kbps
    Nominal bit rate : 1604 Kbps
    Width : 720 pixels
    Height : 304 pixels
    Display Aspect ratio : 2.35
    Frame rate : 25.000 fps
    Chroma : 4:2:0
    Interlacement : Progressive
    Bits/(Pixel*Frame) : 0.293
    Writing library : x264 - core 60 r928 4816918
    Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x133 / me=hex / subme=6 / brdo=1 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=0 / threads=3 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / bime=1 / keyint=250 / keyint_min=25 / scenecut=40(pre) / rc=2pass / bitrate=1604 / ratetol=1.0 / rceq='blurCplx^(1-qComp)' / qcomp=1.00 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=2:1.00

    Audio #0
    Codec : AC3
    PlayTime : 1h 24mn
    Bit rate mode : CBR
    Bit rate : 384 Kbps
    Channel(s) : 6 channels
    Channel positions : Front: L C R, Rear: L R, LFE
    Sampling rate : 48.0 KHz
    Language : German

    Um die Kuriositäten weiter zu vervollständigen kann ich nun folgendes berichten. Obwohl mein Media Player den Film zu schnell wieder gibt, hab ich ihn mal auf ne DVD gebrannt und siehe da es funktioniert nun auch mit Divx und xvid auf dem TV-Gerät. Gerettet, mehr wollte ich ja nicht. Doch nun kommt das Problem. Auf dem PC ist der Film vollständig drauf. Brenne ich diesen jedoch auf DVD, fehlen mir zum Schluß ca. 20 Minuten. Hab schon die Bitrate rauf gedreht, damit der Film größer wird, aber trotzdem fehlt zum Schluß hin wieder diese 20 min. Ich kenn mich bald nimmer aus.
    Hatte bis jetzt mit noch keinem selbst codierten Film von vob nach avi ein Problem, aber diese mkv datei nervt mich.

    Mehr Infos kann ich zur Zeit nicht liefern.

    Wünsch Dir noch nen schönen Sonntag und Danke für Deine Hilfestellungen!

    Gruß Quake
  • Wenn garnichts geht, kannst du den Fehler ja auch manuell beheben :D

    Sound abtrennen
    Mit Audacity verlangsamen
    Wieder auf den Film schieben

    Feddich

    Mal sehen, wei lange man braucht, um die richtige Geschwindigkeit zu findne :D


    Greetz,

    kingfinn
  • Hallo quake,
    ich habe versucht mir die ganze Geschichte nochmal durch den Kopf gehen zu lassen. Ich weiß jetzt nicht ob du andere Player ausprobiert hast; ich nehme
    das einfach mal an.
    1.Dann bleibt noch die Möglichkeit das mit dem mkv-file etwas nicht stimmt.
    "Yamb" ist ein kleines Programm zum demuxen von mkv und MP4.
    (wie VirtualDub für Avi's)
    Einfach mal demuxen (RAW Streams) und mit mkvtoolnix wieder zusammenfügen.(ist schnell gemacht)
    2.Die Framerate im Media-Info ist ohne Auffälligkeiten;sieht alles ganz normal aus.
    3.Wenn Dir die letzten 20 Minuten fehlen ; würde ich wieder 1. vorschlagen.
    Super2008 scheint die letzten 20 Minuten nicht zu bekommen.
    4.Enfernte Möglichkeit das AviSynth falsch installiert ist
    (Super benutzt es als FrameServer)
    d.h. alle Programme die AviSynth nutzen kurzfristig deinstallieren,
    (Suche Funktion nutzen !)
    Neueste stabile AviSynth Version installieren und danach erst Super oder andere Videobearbeitungsprogramme.
    Wenn du mit Vista arbeitest kann es auch daran liegen.
    Im Augenblick war das mein ganzes Latein.
    Gruß stoppel
  • Sorry Stoppel wenn ich mich hier einmische, aber:
    Super benutzt kein AviSynth, und erst recht nicht als Encoder.
    Super ist auch keine GUI für AviSynth, es bietet nur Support für AviSynth-Scripte.

    Super benutzt:
    FFMPEG, Mencoder, M-Player, X264, FFMPEG 2 Theora, die Libav Codec Library und das Theora Real Producer's Plugin als Encoder und Decoder.

    Gruß gipo
  • Hallo zusammen!

    Vielen Dank für Eure Rückmeldungen und sorry, dass ich mich so lange nicht gemeldet hab. Aber Urlaub muß ja auch mal sein. :D

    So nun kann ich schon mal einen Erfolg verkünden. Da ich es geschafft habe einen MKV Film in einen AVI Film umzuwandeln, der bei mir auf dem Rechner ganz normal und vollständig abgespielt werden kann. Hierbei halfen mir die Programme von Xilisoft Media Converter und Any DVD Converter.

    Dennoch bin ich noch nicht ganz glücklich, da immer noch das Problem auftritt, dass der Film nicht vollständig im Stand Alone DVD Player abgeslpielt werden kann. Es fehlt immer der Schluß, obwohl dieser vollständig auf der gebrannten DVD drauf ist und man ihn auch auf dem PC nun bis zum Ende und im richtigen Tempo ansehen kann.

    Ich brenne mit Nero 6, mit dem ich noch nie Schwierigkeiten hatte. Trotzdem testete ich auch eine andere Brennsoftware (Deepburner) mit dem gleichen Ergebnis, dass der Schluss fehlt. Ich habe auch versucht einen fertigen anderen AVI Film mit annähernd der selben größe auf die DVD zu brennen. Und hier gab es dann keine Probleme, da ich den Streifen bis zum Ende auf meinem DVD - Player ansehen konnte.

    Nun ist bei mir die Frage aufgetreten, woran es scheitern könnte, dass mein selbst konvertierter Film vor dem Ende Schlapp macht.
    Übrigens hab ich es auf meinem anderen neueren DVD Player auch ausprobiert, doch dieser spielt den Film ebenso nicht zu Ende.

    Über hilfreiche Antworten bin ich sehr dankbar.

    Noch nen schönen Tag!

    Gruß Quake
  • 1.Tipp
    Versuch mal nur das Video neu zu encodieren und das Audio nur mit DirectCopy einbinden.
    Denke mal dass es evtl. von AC3 6 Kanal zu AC3 Stereo zu Problemen kommen kann.
    Ich liege doch richtig mit meiner Annahme dass Du bei nur 192 kb/s nach Stereo konvertierst?

    2.Tipp
    Öffne das schon erstellte Video mit VirtualDub. Hake im öffnen Dialog -Ask for extended options after this dialog- vor dem öffnen ab. Im nächsten Dialog wähle -Re-derive keyframe flags- klicke auf OK. VirtualDub schreibt neue Indexe (Keyframe-Indexe), dies wird einige Zeit dauern. Bei fehlerhaften Videos stürzt VirtualDub des Öfteren ab.

    Ist er nicht abgestürzt, dann wähle -Video > Direct Stream copy- danach mit -File > Save as Avi…- die Datei neu speichern.

    Hinweis:
    Zum öffnen von Videos mit AC3 in VirtualDub wird ein Plugin benötigt,(fccHandler) erstes posting von mir.
    freesoft-board.to/f255/vob-to-avi-315899.html

    Nachtrag:
    Auch wenn mich jetzt jemand steinigen wird, aber Super und Konsorten verwenden ffmpeg oder MEncoder zum de & encodieren. Ich halte persönlich nix davon. Es gibt hin und wieder Probleme mit der Audio synchronität oder andere eigenartige Phänomene.
    Würde Dir da gerne Avidemux - Main Page ans Herz legen, aber hatte erst neulich das gleiche Problem mit diversen MPEG2 Dateien. Also, keine Empfehlung, aber einen Test wert!

    Gruß gipo

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von gipo () aus folgendem Grund: Nachtrag

  • Grüß Dich!

    Hab es mal mir Virtual Dub versucht, leider hat der mir meinen 1,4GB großen Film auf 89GB hochgerechnet, obwohl ich dies bestimmt nicht wollte.
    Aber ich habe eine andere Kuriosität entdeckt, da ich meinen Film in zwei Packete aufsplitten wollte und dann anschließend anstatt der 1,4 GB nur noch 1,0 hatte. Es gab einen Teil mit ca. 720MB und dann mit 300MB und genau dort hört der Film auch auf, wenn ich ihn auf dem DVD Player ansehe. Irgendwas läuft hier grundlegend schief und übrigens, den Film hab ich so bekommen und wurde von mir nicht umgewandelt.
    Langsam verzweifel ich schon ein bischen, an was dies alles liegen könnte.

    Gruß quake
  • quake_88 schrieb:


    Hab es mal mir Virtual Dub versucht, leider hat der mir meinen 1,4GB großen Film auf 89GB hochgerechnet, obwohl ich dies bestimmt nicht wollte.

    Dann haste nicht Direct Stream Copy ausgewählt so wie ich es zuvor erwähnt habe. VirtualDub encodiert dann alles als Unkompremiertes Video!

    quake_88 schrieb:


    Es gab einen Teil mit ca. 720MB und dann mit 300MB und genau dort hört der Film auch auf, wenn ich ihn auf dem DVD Player ansehe.

    Also wenn VirtualDub nach dem einlesen der divx Datei das Video nicht bis zum Ende abspielen kann, dann hat das auch mit VirtualDub keinen Sinn!

    Wenn doch, dann wiederhole mein vorheriges Posting und wähle auch Direct Stream Copy unter Video aus.

    Gruß gipo
  • Hallo zusammen!

    Ich habe gute Neuigkeiten. Endlich hat es funktioniert. Genau mit der Methode die Du, Gipo mir vorgeschlagen hast.
    Daher möche ich mich bei Dir und den anderen nochmals bedanken, dass ihr mich nicht hängen gelassen habt.
    Echt super!

    Wünsche Euch allen noch ein schönes Wochenende.

    Gruß Quake

    PS: Nun würde mich nur noch interessieren, was die Ursache ist, dass es nicht von Anfang mit meiner Methode klappt! :confused:
  • Das freut mich für Dich und für mich! Mal ein Tipp der auch fruchtet. :)

    Super und dergleichen verwendet wie schon erwähnt ffmpeg oder MEncoder. Wenn es ums normale abspielen geht verwende ich unter anderem ffdshow das ebenfalls auf ffmpeg aufbaut.

    ffmpeg ist aber etwas anfällig bei nicht 100% Fehlerfreien Dateien. Deine war eben solch eine (fehlerhafte Header Informationen im Stream). Entstanden z.B. durch schon fehlerhaftes Ausgangsmaterial oder durch ein schlechtes Konvertierungstool.

    Zum wieder flicken fehlerhafter Videos gibt es für MPEG2-Dateien ProjectX oder VideoReDo , für AVI Container gibt es außer VirtualDub noch diverse andere Tools. VirtualDub geniest da aber in jeder Beziehung mein volles Vertrauen.

    Gruß gipo