ich habe ein problem und würde mich über desen lösung freuen...

  • geschlossen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • ich habe ein problem und würde mich über desen lösung freuen...

    ich wollte firefox 3 auf meinem rechner (mit debian)
    installieren aber dies war nicht möglich weil das programm
    die fehlermeldung auswarf das dies nur mit gtk+ ab version 2.10 möglich sei.
    deswegen habe ich mir aus dem internet die datei gtk+-2.12.11 heruntergeladen.
    diese wollte ich dann installieren und ich bin nach dem install text vorgegangen.
    ich bekam darauf fogende fehlermeldung:

    [email protected]:~/Desktop/gtk+-2.12.11$ ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... no
    checking for mawk... mawk
    checking whether make sets $(MAKE)... yes
    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking for native Win32... no
    checking for gcc... no
    checking for cc... no
    checking for cl.exe... no
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details.
    [email protected]:~/Desktop/gtk+-2.12.11$
    [email protected]:~/Desktop/gtk+-2.12.11$


    diese config-log habe ich niergendswo gefunden
    aber ich habe den g++-4.1_4.1.1-21_i386 c compiler installiert und noch mal versucht gtk+ zu installieren um dann
    firefox 3 zu installieren.
    dieser wurde aber anscheinend nicht erkannt den ich bekam die selbe fehlermeldung ausgeworfen wie sie oben steht.
    also wie muss ich jetzt weiter vorgehen damit gtk+ installieren kann um firefox 3 zu installieren?
  • Evtl mit einem Paketmanager versuchen

    Hallo,

    versuch mal ob du über apt-get den paketmanager synaptic installieren kannst der sollte benötigte paktetabhängigkeiten selber lösen können.
    Bitte dann eine kurze Rückmeldung obs geklappt hat.

    mfg
    Martin
  • ich habe kein internet an meinem pc :( ,
    aber ich habe wo naders die möglichkeit in's
    internet zu gehen deswegen muss ich mir mit
    mit deb paketen und dem compilieren von programmen helfen,
    wobei letzteres nicht funktioniert hat wie man oben sehen kann.
  • Mein Tipp: Such dir eine Internetanbindung und steig um auf Testing. Ein Riesenvorteil von Linuxdistributionen wie Debian ist der hervorragende Paketmanager. Durch selbstkompilierte Pakete verunstaltest du nur das ganze System.

    Wenn du doch selber kompilieren möchtest: Schau dir zum einen CheckInstall an, dann hast du hinterher wenigstens die Software als Paket und kannst sie ggf. sauber entfernen, zum anderen fehlt dir evt. noch der gcc Compiler. Wenn du in der Debian Paketliste bei den Sourcen zu GTK+ guckst, dürfte da stehen was du alles zum Kompilieren benötigst.