MyBB Installationsfehler

  • geschlossen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • MyBB Installationsfehler

    Hi,

    ich hab mir mal von hier MyBB zugelegt und auf ohost.de hochgeladen. Installation, Datenbank hat alles super funktioniert (habe auch jeden Schritt befolgt). Dann am Ende, steht, dass es erfolgreich installiert wurde und ich jetzt ins Forum oder zum AdminCP gehen kann.

    Aber leider funktioniert das gehen eben nicht. Sobald ich versuche auf eines der beiden zuzugreifen, kommt folgende Fehlermeldung:

    "Fatal error: Cannot redeclare memory_get_peak_usage() in /usr/export/www/hosting/*****/forum/inc/functions_compat.php on line 120"

    Weiß jemand wie man das beheben kann, so, dass ich das Forum benutzen kann? Hab schon hundertmal neu installiert, hat aber nichts genutzt. :(

    Shadow

    @Mods: Wenn falsch hier, bitte moven. ;)
  • Hi Zerd,

    während der Installation hat MyBB gesagt, dass alle Vorraussetzungen erfüllt sind, aber hier:

    Quellcode

    1. if(!function_exists('memory_get_peak_usage'))
    2. { <--- Zeile 120
    3. function memory_get_peak_usage($real_usage=false)
    4. {
    5. return memory_get_usage($real_usage);
    6. }
    7. }


    Shadow
  • Hi,

    da steht nix davon, ich habe es jetzt aber so gemacht:

    Ich habe den ganzen memory_get_peak_usage "block" gelöscht. Und siehe da: Alles geht einwandfrei!

    Meine Frage: Glaubst du es könnte später ein Fehler auftreten ohne diese Funktion?

    Shadow
  • ich hätte vilt, bevor du einfach löscht, einfach mal die functions_compat.php neu hochgeladen. Welche version nutz du denn überhaupt?

    auch wenn das vilt hier nicht gerne gesehen ist, gehe am besten auf mybboard.de und meld dich da an, die haben mir bisher bei jeden Problem helfen können im Punkt mybb. Die werden dir auch sagen können, ob das was du getan hast, Probleme macht.

    Wie gesagt würde ich aber erst nochmal die Datei neu hochladen und wenn es nicht klappt, dann kannst du immer noch den Block löschen.


    (Fremdwerbung für andere Boards ist meist nicht gern gesehen, ich weiss, aber das halt nen spezielles Problem daher denk ich das es in den Fall ganz gut wäre ^^")
    play as long as you live
  • Hi Stormsyn,

    ich glaube nicht, dass es irgendetwas bringen wird, wenn ich die Datei nochmal hochlade (zumal ich das sowieso schon getan habe), da das ja ein Server-seitiges Problem ist.

    Ich belasse es jetzt erstmal so, da jetzt alles einwandfrei funktioniert.

    Daher kann hier auch ein Mod closen!

    Shadow

    btw: Nimm den Link lieber wieder raus, habs jetzt auch zur Kenntniss genommen. ;)