möchte auf Transonic 4000 andere Navisoft verwenden, am liebsten iGo8

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • möchte auf Transonic 4000 andere Navisoft verwenden, am liebsten iGo8

    ich habe folgendes Problem:
    mein Maqma GN401 ist kaputt, so besorgte ich mir ein anderes günstiges Navi. Es wurde ein Transonic 4000 mit MN5. Das Gerät funktioniert soweit gut, doch das Kartenmaterial ist veraltet und meine Heimatadresse hat einen total falschen Straßennamen. Also möchte ich die Navisoft ersetzen ohne schon wieder viel Geld aus zu geben. Am liebsten wäre mir IGO8 zum laufen zu bringen, was auf dem GN401 schon gut lief und mir sehr gut gefällt. Nur schaltet MN5 das Gerät immer gleich beim Beenden ganz ab, obwohl mir schon gelang den CE-Explorer aufzurufen.

    Das Gerät läßt sich nicht als Kartenlaufwerk anmelden, sondern "nur" über ActiveSync ansprechen, was aber auch unter Win98SE funktioniert.

    So habe ich mit ActiveSync zunächst einen Link zu \Windows\explorer.exe eingefügt, was auch funktionieren will (ich bekomme den immer nur kurz zu sehen) aber immer von der eingebauten Software überlagert wird.
    Zunächst deinstallierte ich Mobilenavigator5, was nicht leicht war, was nun dazu führt, daß immer im Vordergrund ein Screen erscheint, der zum einlegen einer SD-Karte mit Installationsdateien auffordert. Das bekommt man einfach nicht weg. Also Explorer ist kurz zu sehen aber wird gleich verdeckt. So kann man keine Software manuell starten.

    Ich habe auch versucht ShowTaskbar einzubinden, klappte aber nicht. ITaskMgr.exe bringt auch nur eine Fehlermeldung nicht starten zu wollen.

    Dann kam mir die Idee im Startup-Ordner eine Verknüpfung zur fremden Navisoft auf SD-Karte mittels ActiveSync anzulegen, was auch klappte.

    Ich legte also die Route66 SD-Karte rein, ging in den Ordner \Storage Card\r66\ auf r66Navigator7.exe, "kopieren", dann in den Ordner \Windows\StartUp\ und hier "Verknüpfung einfügen". Vorsorglich ebenfalls in \Application Data\ ein Link zu r66. :)

    Das scheint zunächst zu klappen, wenn man einen Softreset ausgeführt hat wird R66 mit etwas Glück auch gestartet und kommt nach vorne. Es dauerte die üblichen 25 Minuten bis das GPS-Signal zum ersten mal erkannt wurde, wie im Gerätehandbuch beschrieben. Alle Spezialtasten des Transonic 4000 lassen sich für R66 korrekt benutzen. R66 paßt sich auch automatisch an die Auflösung an, läßt sich aber nicht mehr, wie im GN401 möglich, beenden. Aber es verrichtet gewohnt seinen Dienst, bis es sich mal beim "Neuberechnen" aufhängte. Dann waren mehrere Softresets nötig damit es wieder startete.

    Nun war mir R66 auf dem GN401 schon zu "altbacken" und ich ersetzte es erfolgreich mit iGO8.

    Jetzt möchte ich iGO8 auch gerne auf dem Transonic 4000 benutzen und versuchte die gleiche Vorgehensweise, wie mit R66 klappte. Doch leider geht es nicht. Ich sehe nur viel zu kurz eine Fehlermeldung, die zu lesen man nicht schafft, grade so kann man iGo8 lesen. :confused:

    iGo8 lief zuvor in 480x272 mit Riks1.4mod-Skin von dieser SD-Karte. Da es jetzt mit 320x240 laufen muß habe ich schon in der sys.txt die Angaben geändert auf

    [folders]
    ;app="%SDCARD%/iGO8"
    app="%Storage CARD%/iGO8"

    [interface]
    ;landscape=1
    skin="ui_igo8" ; = default
    [rawdisplay]
    highres="0"
    ;screen_x=480
    ;screen_y=272
    screen_x=320
    screen_y=240

    aber iGO8 startet nicht und der eingebaute Screen mit der Installationsaufforderung dängt sich immer wieder in den Vordergrund.

    In nahezu jedem Ordner in dem PNA liegt eine desctop.inni mit immer dem selben Inhalt, dem Aufruf einer csshell.dll, die aber scheinbar nicht mit ActiveSync zu finden ist (als versteckt markiert?).

    Ich brauche also Ratschläge wo ich in den Konfigurationsdateien von iGO8 noch etwas ändern muß, damit es problemlos in 320x240 in StandardSkin startet ohne Fehlermeldung.
    -------------
    Ergänzung:
    Details über das Gerät:
    Transonic PNA 4000
    MD 95330
    Win.CE.NET 4.2 Core
    Viele Grüße
    roschka
  • Ok, nach ziemlich langem Suchen habe ich ein Programm gefunden, was den Desktop freischaltet:
    DesktopFree V4.1 full MD96900 PNA260T von ...
    Desktopfree V4 für MD96900 PNA260T | proppe.de /.info /.net /.us /.biz

    Damit gelang es mir den nervigen Screen auszublenden, der zum Einlegen der Installationskarte auffordert. Nun konnte ich iGo8 über den Explorer starten und die Fehlermeldungen lesen. Nach mehrmaligem Neubversuch bot iGo8 endlich an mit den werkseitigen Defaulteinstellungen neu zu starten, dabei gehen aber ALLE Benutzerdateien verloren.

    Doch nun Läuft iGo8 auf dem TS4000 --- bis dummerweise die Batterie mal alle war. Dann hatte ich wieder das "alte" Problem. Rückfall in die Werkseinstellung mit der nervigen Aufforderung eine Installationskarte einzulegen und alles war wie nach einem Hardreset.

    Um nun nicht jedesmal nach Stromtotalverlust die ganze umständliche Prozedur von vorn anfangen zu müssen, habe ich die beiden Dateien, die eigentlich in den \Windows\-Ordner kopiert werden sollen, direkt im Hauptverzeichnis der iGo8-SD-Karte abgelegt und umbenannt:
    ST.exe in autorunce.exe und
    freedesk.cab in mnavdce.cab

    Nun hoffe ich, daß die nach einem neuen unerwünschten (Hard)Reset entsprechend ausgeführt werden als installations-Programm für desktopFree.

    Ob es wirklich funktioniert habe ich aber noch nicht überprüft. Denkbar wäre es.

    DesktopFree V4.1 Full bringt eine Reihe nützlicher Hilfsmittel mit:
    Text-Editor, PeriodicalShowTaskbar, Softreset, MoveWindow, und einige andere.

    Jedenfalls kann ich iGo8 nun benutzen und Skins ausprobieren für 320x240.
    Momentan gefällt mir Bidru mit seiner Totaltransparenz am besten und mit der freigelegten Möglichkeit Straßenabschnitte zu BLOCKEN (z.B. hilfreich für zeitweilige Baustellungen mit Vollsperrung einer Straße., die man auch wieder zurücknehmen kann). Damit berechnet iGo8 gleich Routen um die Blockstrecke herum = besser als "umleitung".

    was mich an dem Transonic PNA 4000 immernoch stört, ist die viel zu dunkle Beleuchtung bei Tageslicht und der zu stark spiegelnde Bildschirm, selbst wenn man eine Displayschutzfolie aufgeklebt hat.

    Auch wüßte ich gern wo man die Belegung der Hardware-Tasten in iGo8 ändern kann, weil iGo die nicht so korrekt benutzt, wie Route66.
    Die Settingstaste geht gar nicht, die "Pfeil zurück"- taste bringt eine Routenübersicht, die ich da nicht will, die Fähnchen = Zielwahl-taste geht nicht richtig, die [-] & [+] verändern den "Tilt" in 3D nicht aber "ZoomIn" und "Zoom"out. Beim Steuerkreuz tun die Bewegungen "links" und "rechts2 das erwartete: sie schwenken die Ansich nach links und recht, aber hoch und runter zoomen, statt zu neigen.
    Das würde ich gern ändern, aber Skinunabhängig! nur wo?
    In Data.zip gibt es eine ganze Reihe von Geräte-definitionen mit Tastenbelegungen, nur keine passende für TS4000 oder das baugleiche BM6300.
    Viele Grüße
    roschka