Ubuntu 8.04 - verpixelte Filme

  • geschlossen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Ubuntu 8.04 - verpixelte Filme

    hallo.

    bin seit kurzem von windows auf ubuntu umgestiegen, und jetzt habe ich das dumme problem, dass dvd-filme verpixelt sind. die pixel sind nicht sehr groß, aber doch so groß, dass die bildqualität schlechter ist als die unter windows und besonders gegenstände, personen etc. in einiger entfernung sind schwer zu erkennen. ich habe schon etliche player ausprobiert und es ist jedes mal der selbe mist...:flag:

    weiß jemand, woran das liegen könnte ? ich hab bisher nur probleme mit linux gehabt:gelb:

    mfg solitary man

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Solitary Man ()

  • hast du unter applications -> add software
    schon die "restricted extras" (oder wie auch immer ubuntu das nennt ;) ) installiert?
    [COLOR="Green"]"A dream you dream alone is only a dream. A dream you dream together is reality"[/color]

    John Lennon

    [SIZE=1],,,[/SIZE][SIZE=1]*̡͌l̡*,,,,,,,,,,̡̡ ̴̡ı̴̴̡ ,,,,,,,,,*̡͌l̡*,,,,,,,,,,*̡͌l̡*̡̡ ̴̡ı̴̴̡ ̡̡͡|̲̲̲͡͡͡ ̲▫̲͡ ̲̲̲͡͡π̲̲͡͡ ̲̲͡▫̲̲͡͡ ̲|̡̡̡ ̡ ̴̡ı̴̡̡ *̡͌l̡*_,,,,,,,,̡̡ ̴̡ı̴̴̡ ,,,,,,,,*̡͌l̡*,,[/SIZE][SIZE=1],,,[/SIZE][SIZE=1],,,,,,̡̡ ̴̡ı̴̴̡ ,[/SIZE][SIZE=1],,[/SIZE]
    [SIZE="1"][COLOR="Purple"]Up 1[/color][/SIZE] [SIZE="1"] [COLOR="Olive"]Up 2_The_Beatles_Red_Album[/color][/SIZE]
  • also ich hab den proprietären grafikkartentreiber aktiviert (ist wohl der treiber von ati), wenn du das meinst. zusätzlich ist mir jetzt folgendes aufgefallen:
    wenn ich in die xorg.conf das hier bei der grafikkarte eingetragen habe:

    Quellcode

    1. Option "VideoOverlay" "on"
    2. Option "OpenGLOverlay" "off"
    3. Option "TexturedVideo" "on"


    war der film normal, also ohne diese fiesen pixel aufgetaucht sind. aber dafür hat im fenstermodus das filmbild geflackert...im vollbildmodus war es komischer weise normal (ohne verpixelungen und ohne flackern) !?? woran das nur wieder liegt...:confused:

    mfg solitary man

    edit
    joa, die restricted extras aus den paketquellen hab ich installiert
    "In den Bankhäusern sind mehr Nieten als in den Losbuden auf der Kirmes. Eine Mischung aus Halbstarken, Pyromanen und Gangstern." Franz Müntefering, SPD
  • Ich weiss ja nicht, womit du Filme anguggst, aber ich empfehle mal VLC

    Um damit unter Ubuntu o.ä. noch n sauberes movie output zu haben musst du folgende schritte unternehmen.

    VLC starten (ohne Film, einfach nur anschmeissen)
    Auf "Einstellungen" gehen
    unter "Video" den hacken bei "erweiterte Optionen" setzen
    dann auf "Ausgabemodul" gehen
    dort x11 als Ausgabemodul einstellen
    Sichern
    Beenden
    Neustart

    FERTIG


    MFG Tigger
  • @RinTinTigger: hm, also dein tipp klappt leider nicht. ich habe jetzt das ausgabemodul von VLC von standard auf "X11" gestellt (VLC benutze ich sowieso immer)...es ist alles so verpixelt wie vorher.

    @tux742: also ich habe gnome (was ubuntu ja verwendet, aber unter kubuntu mit kde ist es das gleiche), aber compiz fusion habe ich installiert...soll ich das mal deinstallieren ? (ich weiß ehrlich gesagt nicht, was ich mit synaptic alles rausschmeißen soll, weil da so viele pakete sind, die compiz im namen tragen...)

    mfg solitary man
    "In den Bankhäusern sind mehr Nieten als in den Losbuden auf der Kirmes. Eine Mischung aus Halbstarken, Pyromanen und Gangstern." Franz Müntefering, SPD

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Solitary Man ()

  • Also die xorg.conf sieht so aus:

    Quellcode

    1. # xorg.conf (X.Org X Window System server configuration file)
    2. #
    3. # This file was generated by dexconf, the Debian X Configuration tool, using
    4. # values from the debconf database.
    5. #
    6. # Edit this file with caution, and see the xorg.conf manual page.
    7. # (Type "man xorg.conf" at the shell prompt.)
    8. #
    9. # This file is automatically updated on xserver-xorg package upgrades *only*
    10. # if it has not been modified since the last upgrade of the xserver-xorg
    11. # package.
    12. #
    13. # If you have edited this file but would like it to be automatically updated
    14. # again, run the following command:
    15. # sudo dpkg-reconfigure -phigh xserver-xorg
    16. Section "InputDevice"
    17. Identifier "Generic Keyboard"
    18. Driver "kbd"
    19. Option "XkbRules" "xorg"
    20. Option "XkbModel" "pc105"
    21. Option "XkbLayout" "de"
    22. Option "XkbOptions" "lv3:ralt_switch"
    23. EndSection
    24. Section "InputDevice"
    25. Identifier "Configured Mouse"
    26. Driver "mouse"
    27. Option "CorePointer"
    28. EndSection
    29. Section "InputDevice"
    30. Identifier "Synaptics Touchpad"
    31. Driver "synaptics"
    32. Option "SendCoreEvents" "true"
    33. Option "Device" "/dev/psaux"
    34. Option "Protocol" "auto-dev"
    35. Option "HorizEdgeScroll" "0"
    36. EndSection
    37. Section "Device"
    38. Identifier "Configured Video Device"
    39. Driver "fglrx"
    40. Option "VideoOverlay" "on"
    41. Option "OpenGLOverlay" "off"
    42. Option "TexturedVideo" "on"
    43. EndSection
    44. Section "Monitor"
    45. Identifier "Configured Monitor"
    46. EndSection
    47. Section "Screen"
    48. Identifier "Default Screen"
    49. Monitor "Configured Monitor"
    50. Device "Configured Video Device"
    51. Defaultdepth 24
    52. EndSection
    53. Section "ServerLayout"
    54. Identifier "Default Layout"
    55. screen "Default Screen"
    56. Inputdevice "Synaptics Touchpad"
    57. EndSection
    58. Section "Module"
    59. Load "glx"
    60. EndSection
    Alles anzeigen


    gruß

    solitary man
    "In den Bankhäusern sind mehr Nieten als in den Losbuden auf der Kirmes. Eine Mischung aus Halbstarken, Pyromanen und Gangstern." Franz Müntefering, SPD
  • oha ati.... da hammer schon das Thema. Folgende Links bitte ich dich zu lesen.

    Link 1

    Link 2

    Bitt bearbeite diese Anleitungen in genau DER Reihenfolge.
    Normaler weise sollte Link 1 ausreichen um dein Problem zu lösen.
    Sollte das nicht der Fall sein, versuch Link 2.

    MFG

    Tigger
  • also ich habe jetzt radeon und radeonhd ausprobiert...radeon klappte nicht und bei radeonhd hatte ich auch ein unscharfes bild bei der videowiedergabe.
    jetzt habe ich wieder fglrx installiert. und ich habe die kantenglättung aktiviert. das scheint das problem behoben zu haben. folgendes habe ich in die xorg.conf (in die grafikkartensektion) geschrieben:

    Quellcode

    1. Option "FSAAEnable"
    2. Option "FSAAScale" "6"


    es scheint zu funktionieren...
    danke RinTinTigger für die links :lego:

    mfg solitary man

    edit
    ein problem gelöst und nun das nächste (kleine): jetzt klappen die compiz fusion-effekte nicht mehr :( ...
    "In den Bankhäusern sind mehr Nieten als in den Losbuden auf der Kirmes. Eine Mischung aus Halbstarken, Pyromanen und Gangstern." Franz Müntefering, SPD

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Solitary Man ()

  • Mach mal ne Konsole auf und gib ein

    sudo SKIP_CHECKS=yes compiz --replace

    Das sollte die Sache beheben.
    Zum Thema: fglrx überschreibt alle anderen Grafikeinstellungen.
    D.h. es kann sein, dass du dein Problem (nämlich den des Falschen Treibers) nicht behoben sondern nur umgangen hast. Sollte dies der Fall sein, wirst du die Compiz Effekte nicht mehr aktivieren können. aber auch dafür gibts Lösungen ;)
  • also ich kann compiz nicht wieder aktivieren. diese fehlermeldung erscheint:

    Quellcode

    1. Checking for Xgl: not present.
    2. Detected PCI ID for VGA: 01:00.0 0300: 1002:9581 (prog-if 00 [VGA controller])
    3. Checking for texture_from_pixmap: not present.
    4. Trying again with indirect rendering:
    5. Checking for texture_from_pixmap: present.
    6. Checking for non power of two support: present.
    7. Checking for Composite extension: not present.
    8. SKIP_CHECKS is yes, so continuing despite problems.
    9. Checking for nVidia: not present.
    10. Checking for FBConfig: present.
    11. Checking for Xgl: not present.
    12. /usr/bin/compiz.real (core) - Fatal: No composite extension
    Alles anzeigen

    außerdem ist mir jetzt aufgefallen, dass die bildqualität bei der videowiedergabe gut ist, aber dass jetzt in szenen, in denen die kamera schnell bewegt wird, grafikfehler auftreten (das bild ruckelt und flackert).

    so ein mist...ich gebs langsam auf. vllt installiere ich die tage mal kubuntu 7.10...hoffentlich sind da die probleme behoben.

    mfg solitary man
    "In den Bankhäusern sind mehr Nieten als in den Losbuden auf der Kirmes. Eine Mischung aus Halbstarken, Pyromanen und Gangstern." Franz Müntefering, SPD
  • ja ich habe auch schon andere player (totem z.b.) ausprobiert. es ist immer das gleiche. ich habe jetzt sämtliche ubuntu 8.10 varianten (kubuntu, mint 6 etc) installiert und jetzt will die grafische oberfläche nicht mehr starten...
    ich habe jetzt endgültig keine lust mehr auf linux:flags::flags::flags:. trotzdem danke für euere hilfe.
    über windows kann man auch meckern. aber da funktionieren wenigstens die einfachsten dinge...

    mfg solitary man
    "In den Bankhäusern sind mehr Nieten als in den Losbuden auf der Kirmes. Eine Mischung aus Halbstarken, Pyromanen und Gangstern." Franz Müntefering, SPD