Durchsuchen von Tabellen und Rückgabe eines Bezugswerts

  • geschlossen
  • Frage

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Durchsuchen von Tabellen und Rückgabe eines Bezugswerts

    Hallo!

    Ich benötige eure Hilfe. Ich komme einfach mit den Beschreibungen der Funktionen nicht zu Recht.

    Ich will mit einem Wert (hier 32) in einer Tabelle suchen (hier 11 - 33) wobei mir dann der Wert der ersten Spalte (CC) zurückgegeben wird.

    Tabelle 1:

    32 ?? <-- Wert CC


    Tabelle 2:

    AA 11 12 13
    BB 21 22 23
    CC 31 32 33

    Könntet ihr mir einen Tip geben, wie bzw. mit welchen Funktionen ich das Problem am leichtesten realisieren kann

    danke im voraus
  • Hallo,

    so, wie du es hier beschrieben hast, geht es m.E. nur mit einem Makro.

    Wenn du es mit einer Funktion (SVERWEIS) machen willst, dann muss die Tabelle 2 anders aufgebaut werden.

    Diese wäre dann:
    Spalte A die Zahlen und in Spalte B die Werte.
    Aus den beschrifteten Zellen dann eine Matrix machen (Namen vergeben z.B. "daten")

    Die Formel in Tabelle 1 heisst dann:
    (gesuchter Wert wird in Zelle "A1" eingegeben, dann ist die Formel in Zelle "B1"
    =SVERWEIS(A1;daten;2;0)

    Versuchs mal so.

    LG
    dark41836
    :read:
    [FONT="Comic Sans MS"][SIZE="3"][COLOR="DarkOrange"]---> Fehler sind da, um gemacht zu werden <---[/color][/SIZE][/FONT]
  • Helle00 schrieb:

    Aber so richtig toll, finde ich den Weg nicht. Ich dachte EXCEL wäre in der Tabellen-Verarbeitung mächtiger.


    OhOh,

    Excel ist schon mächtig.
    Aber in diesem Fall denke ich mal, dass du dich zuerst einmal mit den "mächtigen" Grundfunktionen des Excel auseinander setzen solltest, bevor du so ein Urteil hier abgibst.

    Setze bitte diesen Thread auf "erledigt", sonst gibts vom Mod noch einen auf den Deckel. :D

    LG
    dark41836
    :read:
    [FONT="Comic Sans MS"][SIZE="3"][COLOR="DarkOrange"]---> Fehler sind da, um gemacht zu werden <---[/color][/SIZE][/FONT]
  • Ist ja erledigt, von daher hier kein Code, sondern nur ein Tipp, was du bei Interesse in VBA machen könntest:

    • Schalte beim Öffnen der Datei die Arbeitsmappenberechnung aus
    • Vertausche die Werte der beiden Spalten
    • Lass die Zeile mit der SVERWEIS-Funktion neu berechnen
    • Vertausche wieder beide Spalten wie gewünscht


    Die Funktion VERWEIS könnte dich auch interessieren (Vektorversion).

    Gruß

    FelliX_22

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von FeliX_22 ()