Textdatei nicht mehr im Kontextmenue

  • geschlossen
  • Problem

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Textdatei nicht mehr im Kontextmenue

    Die Einträge unter ShellNew (NullFile) und PersistentHandler (Standart mit dem Wert {Se941d80-bf96-11cd-b579-08002b30bfeb} sind noch vorhanden. Wer weiß da mehr?
    :cool:

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von barnymaus ()

  • Das liegt an deiner Hardware, wie man auch daran erkennt, dass du das hier gepostet hast. Ich würde mal eine andere Festplatte ausprobieren. Unter Umständen kann es auch am RAM liegen, aber das kann man von vornherein nicht sicher sagen. :D

    Hm, vielleicht solltest du mal den .txt Schlüssel komplett löschen und neu einlesen, hier mal mein Schlüssel. Hast du in der Registry rumgespielt? Und so vielleicht NullFile als DWORD-Wert anstelle als Zeichenfolge eingefügt? Irgendwas muss ja passiert sein.

    Quellcode

    1. Windows Registry Editor Version 5.00
    2. [HKEY_CLASSES_ROOT\.txt]
    3. @="txtfile"
    4. "PerceivedType"="text"
    5. "Content Type"="text/plain"
    6. [HKEY_CLASSES_ROOT\.txt\PersistentHandler]
    7. @="{5e941d80-bf96-11cd-b579-08002b30bfeb}"
    8. [HKEY_CLASSES_ROOT\.txt\ShellNew]
    9. "NullFile"=""
    Alles anzeigen


    @Mod
    ==> Windows95 / 98 / 2000 / XP / Vista - Freesoft-Board

    Gruß

    FeliX_22
  • Hallo Felix, bei mir steht unter HKEY_CLASSES_ROOT\txt\ab(Standard) REG_SZ (Wert nicht gesetzt)
    Content Type REG_SZ text/plain
    HKEY_CLASSES_ROOT\PersistentHandler\ab(Standard) REG_SZ {5e941-d80-bf96-11cd-b579-08002b30bfeb}
    wie ich letzeren Wert ändere, weiß ich nicht.
    Vielleicht kannst du mir dabei mal helfen.
    Übrigens diese Einträge stehen nicht drin:
    HKEY_CLASSES_ROOT\.txt]
    @="txtfile"
    "PerceivedType"="text"
  • barnymaus schrieb:

    Hallo Felix, bei mir steht unter HKEY_CLASSES_ROOT\txt\ab(Standard) REG_SZ (Wert nicht gesetzt)
    Content Type REG_SZ text/plain
    HKEY_CLASSES_ROOT\PersistentHandler\ab(Standard) REG_SZ {5e941-d80-bf96-11cd-b579-08002b30bfeb}
    wie ich letzeren Wert ändere, weiß ich nicht.
    Vielleicht kannst du mir dabei mal helfen.
    Übrigens diese Einträge stehen nicht drin:
    HKEY_CLASSES_ROOT\.txt]
    @="txtfile"
    "PerceivedType"="text"

    [HKEY_CLASSES_ROOT\.txt\ShellNew]
    "NullFile"=""
  • Hi!

    1. Öffne Notepad/Editor
    2. Schreibe den Code rein, den ich gepostet habe (Kopieren & Einfügen)
    3. Speicher die Datei unter einem Namen ab: "Text.reg" (mit den Anführungszeichen)
    4. Dann öffne den Ordner mit der Datei im Explorer
    5. Doppelklicke auf die Datei Text.reg
    6. Bestätige die Frage, ob du die Informationen zu der Registrierung hinzufügen möchstest mit Ja.


    Wenn es mit der Erstellung der Datei nicht klappt, schicke ich sie dir per PN.

    Gruß

    FeliX_22
  • stelle gerade fest - Notepad/Editor ist auch nicht mehr im Kontextmenue - bekomme ich den auch anders?
    Habe unter Ausführen notepad, Notepad öffnen können!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von barnymaus ()

  • Habe ich gemacht! Nun kommt eine Meldung:
    C:\Dokumente und Einstellungen\Besitzer\Txt.reg kann nicht importiert werden. Die angegebene Datei ist keine Registrierungsdatei. Registrierungsdateien können nur innerhalb des Registrierungs Editors importiert werden.
    Anmerkung: Sie ist als Text.reg von mir abgespeichert worden.
  • Verstehe ich das richtig, dass du unter Rechtsklick neu, keine Textdatei zur Auswahl hast?

    Denn dieses Problem könntest du ganz einfach mit Tuneup erledigen!

    Tuneup System Control---->Dateitypen---> Menü "Neu"

    Hier einfach ein Häckchen bei Textdokument setzten bzw. , wenn dieses nicht aufgeführt ist, manuell hinzufügen. Und schon sollte dein Problem gelöst sein!

    Grüßle Phili 0815
  • Hab dir die reg datei geschickt. "Die angegebene Datei ist keine Registrierungsdatei." bedeutet, dass irgendetwas mit dem Dateiinhalt nicht stimmt.

    @Phili 0815
    Ich vermuite, dass die Tools nicht mehr machen, als den ShellNew-Schlüssel zu setzen. Aber das Problem ist wahrscheinlich, dass

    Übrigens diese Einträge stehen nicht drin:
    HKEY_CLASSES_ROOT\.txt]
    @="txtfile"
    "PerceivedType"="text"


    Gruß

    FeliX_22
  • Freut mich! Wo genau soll der Eintrag hin? Wenn dir das einfache Öffnen der Dateien fehlt, also "Öffnen", dann brauchst du diesen Schlüssel:

    Quellcode

    1. Windows Registry Editor Version 5.00
    2. [HKEY_CLASSES_ROOT\.txt]
    3. @="txtfile"
    4. "PerceivedType"="text"
    5. "Content Type"="text/plain"
    6. [HKEY_CLASSES_ROOT\.txt\PersistentHandler]
    7. @="{5e941d80-bf96-11cd-b579-08002b30bfeb}"
    8. [HKEY_CLASSES_ROOT\.txt\ShellNew]
    9. "NullFile"=""
    10. [HKEY_CLASSES_ROOT\txtfile]
    11. @="Textdatei"
    12. "FriendlyTypeName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\
    13. 00,6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,\
    14. 32,00,5c,00,6e,00,6f,00,74,00,65,00,70,00,61,00,64,00,2e,00,65,00,78,00,65,\
    15. 00,2c,00,2d,00,34,00,36,00,39,00,00,00
    16. "EditFlags"=dword:00010000
    17. [HKEY_CLASSES_ROOT\txtfile\DefaultIcon]
    18. @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
    19. 00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,\
    20. 65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,31,00,35,\
    21. 00,32,00,00,00
    22. [HKEY_CLASSES_ROOT\txtfile\shell]
    23. [HKEY_CLASSES_ROOT\txtfile\shell\open]
    24. [HKEY_CLASSES_ROOT\txtfile\shell\open\command]
    25. @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
    26. 00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,4e,00,4f,00,\
    27. 54,00,45,00,50,00,41,00,44,00,2e,00,45,00,58,00,45,00,20,00,25,00,31,00,00,\
    28. 00
    29. [HKEY_CLASSES_ROOT\txtfile\shell\print]
    30. [HKEY_CLASSES_ROOT\txtfile\shell\print\command]
    31. @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
    32. 00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,4e,00,4f,00,\
    33. 54,00,45,00,50,00,41,00,44,00,2e,00,45,00,58,00,45,00,20,00,2f,00,70,00,20,\
    34. 00,25,00,31,00,00,00
    35. [HKEY_CLASSES_ROOT\txtfile\shell\printto]
    36. [HKEY_CLASSES_ROOT\txtfile\shell\printto\command]
    37. @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
    38. 00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,6e,00,6f,00,\
    39. 74,00,65,00,70,00,61,00,64,00,2e,00,65,00,78,00,65,00,20,00,2f,00,70,00,74,\
    40. 00,20,00,22,00,25,00,31,00,22,00,20,00,22,00,25,00,32,00,22,00,20,00,22,00,\
    41. 25,00,33,00,22,00,20,00,22,00,25,00,34,00,22,00,00,00
    Alles anzeigen


    Kopiere ALLES aus dem Code-Bereich in die Datei, die ich dir geschickt habe. Du kannst den Inhalt der alten Datei ersetzten, weil er hier mit dabei ist. Hier stehen die Schlüssel .txt und txtfile.

    Es wäre sicherer, wenn du zuerst den Schlüsel txtfile löschst. Wie immer gilt bei Änderungen in der Registry: Alles auf eigene Gefahr! :D

    Oder möchtest du Notepad ins Senden an-Kontextmenü hinzufügen? Dann kopiere die Notepad-Verknüpfung aus dem Startmenü in den Ordner SendTo. Den öffnest du, indem du einfach sendto in Ausführen eintippst.

    Gruß

    FeliX_22
  • Felix - habe alles so gemacht - der Eintrag Notepad/Editor ist trotzdem nicht im Kontext. Auch nach erneutem booten nicht.
    Im Startmenue fehlt die Notepad - Verknüpfung! Die Editor Verknüpfung ist aber vorhanden - wird aber nach kopieren in Sendto nicht im Kontext sichtbar.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von barnymaus ()

  • Wie wärs wenn du mit mehr Informationen rausrückst? Hast du irgendwelche Programme zum Tweaken benutzt? Dass es um XP und nicht Vista geht, kann ich mir mittlerweile denken.

    der Eintrag Notepad/Editor ist trotzdem nicht im Kontext


    Wie genau soll der Eintrag aussehen? Eigentlich soll hier nur Öffnen, Bearbeiten und Drucken stehen.

    Im Startmenü heißt der (deutsche) Eintrag also Editor, eine Verknüpfung auf notepad.exe.

    Mach bitte mal einen Screenshot vom Problem. Mach einen Rechtsklick auf eine txt-Datei und drück auf DRUCK (meist oben rechts auf der Tastatur). Dann helf ich dir gern weiter. :)

    Gruß

    FeliX_22
  • Ja, ist am Anfang verwirrend :D Am besten du kopierst mal alle Linkmöglichkeiten aus imageshack hier rein, klickst aber nur auf Vorschau, dann suchst du dir das richtige aus. Du siehst ja welche 3 Links du gerade gepostet hast, wobei hier der 2. und 3. Link identisch sind (Textlink) und das erste Bild ist ein Bild mit Link.

    So, nun zum Bild: Du kannst jetzt über Neu > Textdokument eine neue .txt-Datei in einen Ordner (hier Desktop) erstellen. Was möchstest du als nächstes tun? Wenn es um das Senden an-Menü geht, dann musst du natürlich zuerst eine lesbare Datei (txt reg html vbs) markieren, die du an Notepad (Editor) senden kannst. Das sieht dann so aus:



    Wenn das Problem erledigt ist, stell das Präfix um. Wenn nicht, versuch doch bitte mit ein paar Sätzen dein Problem ausführlich zu formulieren.

    Gruß

    FeliX_22