Telnet Tutorial/Hilfe für Tomato Firmware

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Telnet Tutorial/Hilfe für Tomato Firmware

    Hallo!

    Habe hier einen WRT54GL mit Tomato Firmware. Seit neuesten funktioniert die WEB Oberfläche (http) nicht mehr:(, Telnet geht aber (kann es sein dass er gehackt wurde? Internet funktioniert aber noch)! Leider habe ich keine Ahnung was ich nach dem Einloggen machen muss um Einstellungen ändern zu können.

    Weiß jemand von euch ob es sowas wie eine Befehlsreferenz gibt dafür, oder ein Tutorial das einem erklärt wie man mit Telnet umgeht im Bezug auf die Tomato Firmware.
    Bzw. weiß jemand wie ich die Weboberfläche wieder aktivieren kann über Telnet.
    Hab bis jetzt folgendes zusammengebracht (d.h. einloggen kann ich mich mal:D):

    Quellcode

    1. C:\Dokumente und Einstellungen\Admin>telnet 192.168.0.150

    und dann als Benutzernamen root eingegeben und als Passwort das dass auch beim http Login verwendet wird. Damit bekomme ich folgende Ausgabe:

    Brainfuck-Quellcode

    1. unknown login: root
    2. Password:
    3. Tomato v1.21.1515
    4. BusyBox v1.2.2 (2008.07.26-14:43+0000) Built-in shell (ash)
    5. Enter 'help' for a list of built-in commands.
    6. # help
    7. Built-in commands:
    8. -------------------
    9. . : alias break cd chdir continue eval exec exit export false
    10. hash help let local pwd read readonly return set shift source
    11. times trap true type ulimit umask unalias unset wait
    Alles anzeigen


    Was muss ich aber jetzt machen? Wie kann ich hier was ändern bzw. wie kann ich mir hier was anzeigen lassen?

    Hoffe ihr könnt mir helfen! LG _THE_ONE_

    Ps: Habe einen Forumseintrag im Internet gefunden (da gibt es jemanden der exakt das selbe Problem hat), leider auch ohne Hilfe:
    Can't access WRT54G web interface after checking https and unchecking http

    Quellcode

    1. Everything was fine until I had the bright idea of checking https
    2. access and
    3. unchecking http. Now when I try to use any imaginable combination of
    4. 192.168.1.1 and http or https, I get an Unable To Connect error message
    5. from
    6. the browser instead of the User Name - Password window.
    7. I had it set up for remote access, and the same story goes for trying
    8. to
    9. access it remotely.
    10. The version of firmware that came with the router is v3.03.6
    11. I know I could fix this by resetting the thing and starting over, but
    12. I'd
    13. rather not do that just yet. I'm thinking I might be able to use telnet
    14. to
    15. recheck the http checkbox.
    16. I've never used telnet and wouldn't know
    17. where to find such commands, but it looks like I might be able to type
    18. set ? and get a list of all the things I can set in the router.
    Alles anzeigen

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von _THE_ONE_ ()

  • Seit neuesten funktioniert die WEB Oberfläche (http) nicht mehr

    Schonmal 192.168.0.150 probiert?

    Es wird etwas schwierig, aber du musst die Datei finden, wo du das wieder aktivieren kannst.

    Du kannst navigieren durch

    Quellcode

    1. cd [I]Ordnername[/I]


    mit

    Quellcode

    1. ls

    kannst du dir anzeigen lassen, welche Dateien bzw. im derzeitigen Ordner sich befinden.

    Eventuell hilft auch ein neuinstallieren der Firmware.
  • Hallo!

    Nach langem Suchen im Internet bin ich auf verschiedene nvram Befehle gestoßen. Leider aber nicht auf den passenden den ich benötigt hätte.

    Aber da ich ein klein wenig (wirklich kleine) Linuxkenntnisse besitze, habe ich einfach mal nvram eingegeben und dann wie erwartet die USAGE Meldung erhalten.
    In dieser Usage Meldung habe ich dann den find Befehl gefunden. Also habe ich dann

    Quellcode

    1. nvram find http
    eingegeben. Und siehe da es wurden mir alle Optionen in denen der String http enthalten war aufgelistet. Beim durchlesen habe ich dann die Option http_lanport gefunden und gesehen dass der Port für den LAN Zugriff auf 8080 stand und nicht wie gewohnt und angenommen auf 80.
    Darauf habe ich dann einfach 192.168.0.150:8080 eingegeben und siehe da es funktionierte.:blink:

    Dann bin ich noch schnell im jetzt wieder funktionierenden Webinterface auf Administration gegangen und habe dort das Port wieder auf 80 gestellt.

    MFG _THE_ONE_

    Ps.: Sollte noch jemand noch Kommentare dazu haben - dann scheut euch nicht hier zu schreiben.
    und hier noch ein Bsp. wie man eine Option direkt mit telnet verändern kann (nicht getestet).

    If you want to assign the WAN port to the LAN in Tomato,you have to disable the WAN port,then Telnet and run this command.

    Quellcode

    1. nvram set vlan1ports=""
    2. nvram set vlan0ports="0 1 2 3 4 5*"
    3. nvram set manual_boot_nv=1
    4. nvram commit
    5. reboot

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von _THE_ONE_ ()