MN7.4 TMC-Problem

  • geschlossen
  • Frage

  • TheFan
  • 1632 Aufrufe 9 Antworten

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • MN7.4 TMC-Problem

    Hallo Zusammen...

    auch nach langem stöbern im Forum und der Erkenntnis, dass wohl viele andere auch das Prob haben, erlaube ich mir, Euch um Hilfe zu bitten.

    Ich habe einen ASUS A636N mit der passenden TMC-Halterung. Zur Zeit hatte ich MN6 am laufen. GPS und TMC ohne Probleme.

    Nun habe ich mir die MN7.4-Version von 2much geladen (Navigon MN 7.4.0 speziell für PDA [ SD_READY ]). Nach langem probieren und lesen, habe ich die Version endlich zum starten gebracht.

    Ich musste die MobileNavigator.res austauschen und eine Navigator.exe in das Navigon-Verzeichnis kopieren. Anschließend noch eine MobileNavigator.exe in Verbindung mit NavLoader.cfg in den Programm-Ordner kopieren. Nun klappt es, dass MN7.4 startet.

    Da ich in der UserSettings.xml auch zufällig die korrekten Daten fpr GPS eingetragen hatte, hatte cih auch sofort GPS-Empfang und konnte ohne Probs navigieren.

    Leider gelingt es mir nicht, das TMC zu aktivieren. Ich habe in der UserSettings.xml schön sämtliche Variationen versucht. Ohne Erfolg.

    Das "Verkehr"-Symbol ist auch nur grau hinterlegt und kann nicht angeklickt werden.

    Kann mir jemand evtl helfen ?

    Hier meine Einstellungen in der UserSettinf.xml:

    <GPS>
    <Type>1</Type>
    <GPSPort>5</GPSPort>
    <Baudrate>38400</Baudrate>
    <DRVPrefix>COM</DRVPrefix>
    </GPS>
    <TMC>
    <RadioStationScan>0</RadioStationScan>
    <AutoRecalculation>0</AutoRecalculation>
    <PreferPay>1</PreferPay>
    <TMCPort>1</TMCPort>
    <TMCBaudrate>57600</TMCBaudrate>
    <DRVPrefix>COM</DRVPrefix>
    </TMC>


    2.Frage: Warum kann man in MN7 die GPS-Einstellungen nur über die UserSettings verändern und nicht wie in MN6 über Manuell oder sogar Wizzard ?
  • ASUS 696 PNA Version TMC

    Nach langem rumprobieren habe ich endlich die Lösung für das
    TMC Problem ASUS A696 mit TMC im Ladekabel für die PNA Versionen gefunden (kombinierter GPS/TMC).

    _______________________________________________________
    Hier die Lösung:

    1. internen Portsplitter konfigurieren
    Einstellungen --> GPS
    GPS Programmanschluss COM6
    GPS-Hardwareanschluss COM5 / 38400 Baud
    GPS automatisch verwalten (Haken setzen)

    2. UserSettings.xml von Navigon anpassen

    <Version>7.0</Version>
    <TMC>
    <RadioStationScan>0</RadioStationScan>
    <AutoRecalculation>0</AutoRecalculation>
    <PreferPay>0</PreferPay>
    <TMCPort>6</TMCPort>
    <TMCBaudrate>38400</TMCBaudrate>
    <DRVPrefix />
    <Freq>945</Freq>
    </TMC>
    <GPS>
    <Type>1</Type>
    <GPSPort>6</GPSPort>
    <TMCPort />
    <Baudrate>38400</Baudrate>
    <DRVPrefix>COM</DRVPrefix>
    <BluetoothDevice>
    <Name />
    <Address />
    </BluetoothDevice>
    </GPS>


    Mit dieser Konfiguration funzt GPS und TMC beim PDA
  • Danke für deine Hilfe.

    Leider kann ich im Portsplitter die 38400 Baud nicht auswählen. Gibt nur 4800,9600,19200,28800,33600,57600,115200

    Hatte dort bisher immer 4800 ausgewählt. Mit MN6 hatte es auch so geklappt. Komisch....
    ASUS A636N, TMC-Halterung
  • Dann versuchs einfach mal mit einer anderen Baudrate, vielleicht brauchst Du bei deinem ASUS Modell auch andere COM Ports
    Bei mir war halt immer COM5(COM3) der Standardanschluss bei MN5 und MN6.
    Deshalb habe ich auch lange gebraucht, um diese Lösung zu finden.
    Es funzt halt nur, wenn der Portsplitter benutzt wird.
    Bei der Original 7.3.1 PDA Version brauchste den Splitter nicht...

    Gruß Navigon
  • So habe mal alles ausprobiert. Aber leider ohne Erfolg. TMC lässt sich nicht aktivieren. Rechts oben in der Ecke ist immer nur das gps-symbol zu sehen.

    Ich glaube fasst, dass die von mir verwendete Version gar kein TMC unterstützt und irgendwie kastriert ist.

    Verwendet noch jemand diese Version auf einem A636N ?
    ASUS A636N, TMC-Halterung
  • Hi,

    du brauchst eventuell noch die zwei Dateien gpstmc.dll und gpstmc.pil.
    Wenn du diese nicht hast, kopiere sie einfach von der PDA Trial Version 7.3.1 von der Navigon Homepage rein oder von der MN6 PDA Version, dann müsste es funzen.
    Bei mir war es auch COM5 (COM3), habe jetzt testweise die Baudrate auf 4800 beim WIndows Portsplitter reduziert und in der UserSettings.xml die Baudrate im Abschnitt GPS nur für den GPS Eintrag auf 4800 reduziert.
  • Hallo,

    habe das mal von Navigon kopiert und die Werte eingetragen, die an meinem A-696 funktionieren.

    <Version>7.0</Version>
    <TMC>
    <RadioStationScan>0</RadioStationScan>
    <AutoRecalculation>0</AutoRecalculation>
    <PreferPay>0</PreferPay>
    <TMCPort>5</TMCPort>
    <TMCBaudrate>38400</TMCBaudrate>
    <DRVPrefix>COM</DRVPrefix>
    <Freq>945</Freq>
    </TMC>
    <GPS>
    <Type>1</Type>
    <GPSPort>5</GPSPort>
    <TMCPort />
    <Baudrate>9600</Baudrate>
    <DRVPrefix>COM</DRVPrefix>
    <BluetoothDevice>
    <Name />
    <Address></Address>
    </BluetoothDevice>
    </GPS>

    Es ist kein Fehler, daß GPS und TMC denselben Port haben. Asus hat intern einen Portsplitter. Kannst auch noch 4 und 6 probieren.
    Viel Erfolg,
    Gruß NaviFan
  • Also habe jetzt alles genauso gemacht, aber ohne Erfolg.

    Habe mir auch noch eine andere Version geladen. Die von "fertiges MN 7.4.0 für PDA zB: Loox N5xx & Medion 96xxx".

    Geht aber auch nicht. Genau das gleiche Problem.

    MN6 läuft ohne Probleme.

    Muss man nicht verstehen ?!?!??!
    ASUS A636N, TMC-Halterung
  • Habe mal bei Navigon nachgefragt:

    Folgende Antwort habe ich erhalten:

    vielen Dank für Ihre E-Mail.

    Kabelgebundendes TMC ist mit diesem Gerät nicht möglich. Dies kann über Bluetooth
    funktionieren.

    Für weitere Fragen stehen wir Ihnen gerne zur Verfügung.



    Also zurück zu 7.3.1.........!!!!
    ASUS A636N, TMC-Halterung