Ubuntu 16.04 x64 - Sound Blaster Z-Karte funktioniert nicht und weitere Fragen zu Ubuntu

  • Ubuntu

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Ubuntu 16.04 x64 - Sound Blaster Z-Karte funktioniert nicht und weitere Fragen zu Ubuntu

    huhu,

    habe jetzt mal n neues thema aufgemacht. also, ich habe bei mir ubuntu 16.04 x64 laufen und eine SBZ pcie karte verbaut. ubuntu hat sie nicht erkannt und ich weiss jetzt nicht genau, wie ich sie zum laufen bekommen soll/kann.

    --> Sound Blaster Z - - Creative Labs (United States) <-- um diese handelt es sich.

    und hier gabs schon was von mir zu diesem thema, aber da es nicht mehr zu dual-boot gehörte, hab ich dann n neues thema eröffnet @NeHe ;) (& @Bogomir @freefloating)

    um weiter zu machen, wie vorher, ja die soundkarte ist verbaut, aber woran erkenne ich, ob ich die unity-oberfläche habe usw? wie gesagt, ich kenne mich mit linux noch nicht soooooo gut aus :D



    mfg
    Nein, ich bin nicht die Signatur...Ich putz` hier nur... -.-
  • Hallo taker-

    Was genau ist denn dein Problem mit der Soundkarte? Was heisst: "Ich blicke nicht durch?". Ich nehme an, es ist eine Karte eingebaut, oder? Falls ja, müsste der Ubuntu-Linux-Kernel den Treiber automatisch erkennen und installieren. Ggf. wäre auch noch eine manuelle Nachinstallation möglich. Die Einstellungen für den Sound findest du unter den Systemeinstellungen - Klang. Hast du eine Unity-Oberfläche? Dann heisst es bei dir vielleicht etwas anders (Audio) und du kannst den Suchbegriff im Dash eingeben. Ich habe Ubuntu-Mate mit der klassischen Gnome 2-Oberfläche und etwas anderen Begrifflichkeiten.

    Gruss ff
    Carpe diem - pflücke den Tag!
  • ja, wie gesagt, ich habe 16.04 x64 installiert. ist das dann die unity oberfläche? habe von hier ubuntu.com/download/desktop die
    Ubuntu 16.04.2 LTS heruntergeladen. die iso mit win32 disk imager oder so ähnlich, die iso aufn usb stick gemacht und halt installiert.


    und ja, die soundkarte ist im pc verbaut. is ne pcie karte. im bios ist die onboard karte deaktiviert, also sollte linux die ja nicht mit installieren? irgendeine soundkarte wurde anscheinend erkannt und etwas installiert, aber es kommt halt kein ton ausm headset.

    und mit "ich blicke nicht durch" war auf den anderen thread bezogen. dort wurde mir was von nem fix, oder workaroud gesagt, wie man die zum laufen bekommen kann oder so. und das kapier ich nicht. ;)


    mfg
    Nein, ich bin nicht die Signatur...Ich putz` hier nur... -.-
  • Hallo taker,

    Leider kann ich mangels gleicher Hardware dein Problem nicht selbst nachstellen, kann aber zumindestens bei der Problemanalyse helfen.

    Führe bitte die eeinzelnen Schritte der folgenden Webseite auf deinem System durch. Die Dort angegebenen Ergebnisse und weiteren Schritte führen dich zu einer Konkretisierung deined Hard/Softwareproblems

    Ubuntu Sound Problembehandlung

    Poste bitte die Ergebnisse, wenn du weitere Hilfe benötigst

    Cheers, Bogi
    IRC war gestern, ... heute haben wir den Chat

    realize your tasks, then take a deep breath and go for it!
  • Hallo taker-

    Danke für die Präzisierung. :)

    Also, um es kurz zu machen. So wie es aussieht, wird deine Soundkarte nicht (oder noch nicht) von Linux unterstützt, sonst wäre sie nämlich schon längst ordentlich in Betrieb, denn der Treiber wird vom Kernel erkannt und gleich installiert. Ich empfehle dir, zwischenzeitlich deine Onboard-Soundkarte zu aktivieren und mal ein halbes Jahr abzuwarten. Zwischendurch kannst du sporadisch prüfen, ob mit den neuen Kernel-Updates der Treiber deiner Soundkarte erkannt wird. Es besteht allerdings auch (selten) die Möglichkeit, dass diese Soundkarte, aus welchen Gründen auch immer, niemals unterstützt wird. Das ist mir so bei einem externen WLAN-Empfänger so ergangen... bis zum heutigen Tag. Ich konnte auch im Netz keinen Treiber finden.

    Gruss ff
    Carpe diem - pflücke den Tag!
  • moin moin,

    habe gestern auf der arbeit viele stunden gelesen und gemerkt, dass es oft oder nur probleme mit der soundkarte gibt, besonders unter x64 OS's von linux, da einfach die treiberunterstützung fehlt. habe mir mal meine usb soundkarte angeschlossen und die funktionierte gleich. auch die ausgabe über hdmi an meinen monitor funktioniert. ich habe ehrlich gesagt keine lust da groß rumzutesten usw, sonst geht am ende gar nix mehr ^^

    ton hab ich ja jetzt. und falls ich zocken will, nutz ich eben windows. jetzt habe ich aber noch andere fragen (deshalb auch thread-titel-änderung, um es zu verallgemeinern)

    1) ich kann auf meine ssd (wo windows 10 pro x64 installiert ist) unter linux nicht zugreifen.
    Auf »SSD« kann nicht zugegriffen werden <-- überschrift

    Error mounting /dev/sda4 at /media/*username*/SSD: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda4" "/media/*username*/SSD"' exited with non-zero exit status 14: Windows is hibernated, refused to mount.
    Failed to mount '/dev/sda4': Vorgang nicht zulässig
    The NTFS partition is in an unsafe state. Please resume and shutdown
    Windows fully (no hibernation or fast restarting), or mount the volume
    read-only with the 'ro' mount option.
    windows ist bei mir "komplett" heruntergefahren und fastboot ist auch aus usw. laut google sollte ich
    sudo ntfsfix /dev/sda2
    versuchen. habe natürlich sda2 mit sda4 ersetzt.
    terminal spuckt das aus

    Mounting volume... Windows is hibernated, refused to mount.
    FAILED
    Attempting to correct errors...
    Processing $MFT and $MFTMirr...
    Reading $MFT... OK
    Reading $MFTMirr... OK
    Comparing $MFTMirr to $MFT... OK
    Processing of $MFT and $MFTMirr completed successfully.
    Setting required flags on partition... OK
    Going to empty the journal ($LogFile)... OK
    Windows is hibernated, refused to mount.
    Remount failed: Operation not permitted

    also auch wieder windows is hibernated?!

    meine zweite frage: habe mir teamspeak 3 installiert. habe mir eine desktopverknüpfung angelegt. die funktioniert auch. allerdings wird das logo einfach nicht geladen. habe den pfad genau überprüft und auf groß und kleinschreibung geachtet usw. aber es läd das icon.png einfach nicht. woran kann das liegen?

    und meine dritte: wie komme ich auf mein windows netzwerk, bzw. auf die freigaben? samba scheint installiert zu sein. gibt es hier keine netzwerkumgebung oder sowas? oder muss ich da alles einzeln einbinden? wenn ja, wie? :D

    und die letze: wie kann ich auf meine nas-hdds zugreifen? (4 hdds, die per usb an der fritz.box hängen). habe was gelesen von fstab? habe auch nur anleitungen gefunden, wie ich jede einzelne hdd einbinden kann. ich würde aber gerne den "ordner" so einbinden, dass wenn ich drauf klicke und ihn öffne, dass ich dann gleich alle 4 hdds sehe und drauf zugreifen kann (lesen und schreiben) ist das möglich?

    ps: sorry für den langen text ;)

    mfg
    Nein, ich bin nicht die Signatur...Ich putz` hier nur... -.-
  • Hallo taker

    natürlich kannst du auch im Linux den hibernate entfernen, du solltest dir aber gut überlegen, ob du das wirklich willst. ich habe dir mal 2 Commandlines hinzugefügt, die dir die Optionen darstellen:

    1. Entfernen des Hibernates beim Mount
    sudo mount -t ntfs -o "remove_hiberfile,uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda4" "/media/*username*/SSD"


    2. Option (vermutlich die Sichere) read only mounten
    sudo mount -t ntfs -o ro "/dev/sda4" "/media/*username*/SSD"

    wenn du dir nicht sicher bist, was das Entfernen eines Hibernates bedeutet, mounte bitte die Platte read only

    bitte erst auf einer Console ausprobieren, bevor du die passende Zeile in die /etc/fstab hinzufügst

    zu deiner 2. Frage (Icon zu Desktopstartflächen:
    mit der rechten Maustaste öffnest du die Eigenschaften der Startfläche auf deinem Desktop. im Eingenschaftendialog erscheint auf der linken Seite ein Icon, das dieser Datei/Anwendung zugeordnet ist. Wenn du darauf klickst, öffnet sich ein Dateibrowser, mit dem du ein benutzerdefiniertes Symbol auswählen kannst (also keine manuellen Pfadangaben, oder so)

    zu deiner 3. Frage Zugriff auf Windows Netzwerk:
    öffne den Dateiexplorer (Das Icon sieht aus, wie ein halb geöffneter Aktenschrank)
    ganz unten ist auf der linken Seite ein Menüpunkt mit der Bezeichnung "+ Andere Orte"
    dort stehen dir die lokalen Festplatten, wie auch ein Zugriff auf mögliche Windows Netzwerke zur Verfügung
    ganz unten kannst du die direkte Adresse deines Netzwerkes angeben, z.B.: smb://192.168.178.44/freigabe"

    zu deiner 4. Frage:
    eine ganz hervorragende Step-by-Step Anleitung findest du dazu hier: Ubuntu: Einbinden von fritz.nas

    Cheers, Bogi


    ------- @dd it -------
    sorry, ich sehe gerade, dass ich deine Anforderung überlesen hatte, gleich alle Netzplatten auf einen Blick zu sehen.

    Das ist nur über die Weboberfläche deines Fritz.Nas so einfach möglich. Der Zugriff erfolgt dann aber über das Web
    Mit Linux könntest du das auch haben, in dem du für jede einzelne Platte einen passenden mount Befehl in deine /etc/fstab einträgst damit hängst du dann deine Platten nativ über das Netzwerk in deine Linuxbox ein

    viel Erfolg
    IRC war gestern, ... heute haben wir den Chat

    realize your tasks, then take a deep breath and go for it!

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Bogomir ()

  • hallo taker,

    freut mich, dass alles so gut geklappt hat. Hibernate ist eine Möglichkeit, die z.B. von Windowssystemen genutzt wird um einen Laptop einfach zuzuklappen und beim Aufklappen direkt an der Stelle weiterzuarbeiten, an der du vorher aufgehört hast.

    Die Beschreibung hierzu auf der Microsoft Support Seite findest du hier

    Was passiert nun, wenn du bei einem Mount den Hibernate Sicherungspunkt einfach entfernst? ... wenn du ihn unter Windows erneut bootest, solltest du zwar ganz normal in dein System zurückkommen, aber nicht an der Stelle, an der du es vorher verlassen hattest.

    Früher (zu Anfang der ntfs Einbindungen) ist es immer ein Risiko gewesen, auch schreibend auf ein Windows System zuzugreifen. Heutzutage hat sich die Lage deutlich entspannt.
    Trotzdem solltest du dir mal überlegen, wann es überhaupt sinnvoll ist, schreibend auf dein ntfs System zuzugreifen (zumal du ja auch SAN Platten im Zugriff hast)

    Ich nutze die Option nfts schreibend zu mounten gerne, wenn ich bei Freunden eine "Virenentseuchung" starte hierzu ist es dann notwendig, das verseuchte Windows System für den Linux Virenscanner im schreibenden Zugriff zu haben.

    Ansonsten fällt mir speziell in deiner Konstellation kein Anwendungsfall ein, in der ein direkter schreibender Zugriff unbedingt notwendig wäre.

    Cheers, Bogi
    IRC war gestern, ... heute haben wir den Chat

    realize your tasks, then take a deep breath and go for it!
  • ok verstehe. danke dafür :)

    so habe nun mal übers terminal deinen befehl von option 2 getestet und bekomme folgende meldung:

    sudo mount -t ntfs -o ro "/dev/sda4" "/media/*meinname*/SSD"
    ntfs-3g-mount: failed to access mountpoint /media/*meinname*/SSD: Datei oder Verzeichnis nicht gefunden

    was nun?

    mfg


    //edit: ok, habs. musste mit sudo mkdir den SSD ordner erstellen ;) - wie genau muss ich den befehl denn nun in die fstab eintragen, damit es immer automatisch gemountet ist/wird?
    //edit2: habe bemerkt, wenn ich meine nas's eingebunden habe, wie auf dem screen zu sehen. (nach dem klick auf "mit server verbinden), dann ises nachm neustart auch wieder weg und ich musses erneut machen. geht das auch automatisch irgendwie? bzw. gibts da keine option, dass der server ei
    Bilder
    • Bildschirmfoto vom 2017-06-20 11-13-35.png

      431,81 kB, 1.920×1.080, 63 mal angesehen
    Nein, ich bin nicht die Signatur...Ich putz` hier nur... -.-

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von taker-` ()

  • ich sehe schon,

    der Befehl mount nimmt eine Dateisystemfreigabe eines "fremden" Systems (Netzwerk, oder aber auch lokale Platten) und hängt sie an eine Punkt in deinem Betriebssystem ein.
    du gibst im Befehl mount mit an, wo sich die Quellen befinden und wohin das System eingehängt werden soll. der Einhängepunkt muss für den Mountbefehl auch erreichbar sein.

    /media/"meinname"/SSD war nur ein Beispiel in dem du "meinname" durch etwas ersetzen solltest, was im System bereits vorhanden ist, oder was du manuell anlegst.

    zusätzlich werden beim Mount noch Optionen hinterlegt, wie das fremde System eingebunden werden soll (Formatierung, Benutzerberechtigungen, Anzahl der Zugriffe vor der Dateisystemüberprüfung, ...)

    Je nach dem, was du brauchst, solltest du das in den Optionen konfigurieren.

    die oben angegebene Zeile (Option2) wird in folgendem Verzeichnis /media/"meinname" ein Unterverzeichnis mit dem Namen "SSD" nutzen zum Zugriff durch den Systembenutzer root.

    Wenn der Pfad /media/"meinname" nicht existiert, wird der Mountbefehl fehlschlagen

    Cheers, Bogi


    ----- @add it -----

    nachdem du den Mount Befehl in der Console erfolgreich eingegeben hast, führst du einmal den folgenden Befehl auf der Console aus:
    cat /etc/mtab | grep SSD

    die Schreibweise SSD muss exakt mit der deines angelegten Verzeichnisses übereinstimmen - Groß/Kleinschreibung

    das was du da als Ergebnis bekommst, kopierst du in eine neue Zeile der /etc/fstab (die nur mit root Berechtigungen veränderbar ist)

    die Mountpunkte in deiner SAN Platten könntest du genauso in die fstab hineinschreiben (es gibt spezielle Optionen für Benutzer und Passwort)

    gute Quellen über die Syntax von mount und den Eintragungen in der /etc/fstab erhälst du über die Befehle:
    man mount
    man fstab

    alles was in der /etc/fstab steht, wird beim Hochfahren deines Betriebssystems automatisch gemountet (gemäß der von dir dort angegebenen Optionen)

    manchmal kann es sinnvoll sein, den Mount von Netzwerkverzeichnissen nicht zu automatisieren, da im Fall, dass dein Netzwerk mal nicht funktioniert, o der du auf dem System nur lokal arbeitest, diese Shares nicht existiern und dauerhafte Fehlermeldungen erzeugen
    IRC war gestern, ... heute haben wir den Chat

    realize your tasks, then take a deep breath and go for it!

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von Bogomir ()

  • alles klar. passt nun. :)

    habe eben mal ne runde cs probiert und dabei gemerkt, dass es nicht so flüssig rüber kommt. habe meine fps nachgeschaut und habe über 300fps. mein pc sollte auch weit mehr als ausreichend sein, um cs zu zocken ;)

    naja, ich hab einen 144hz monitor. kann linux das? wo und wie kann ich das einstellen? finde dazu nichts in meinen systemeinstellungen.

    im anhangsbild sieht man mal meinen pc. wegen modell, hardwarefragen usw.


    mfg
    Bilder
    • Bildschirmfoto vom 2017-06-20 11-33-03.png

      545,22 kB, 1.920×1.080, 56 mal angesehen
    Nein, ich bin nicht die Signatur...Ich putz` hier nur... -.-
  • hallo taker,

    es gibt mindestens zwei Stellen in deiner Ubuntu Oberfläche, um Einstellungen in der Anzeige zu ändern:

    1. Die Schaltfläche mit dem Zahnrad an deinem linken Bildschirmrand
    dort klickst du auf "Anzeigegeräte"

    2. du klickst auf der gleichen Leiste auf das alleroberste Icon (Rechner durchsuchen)
    dort tippst du nvidia ein
    Das System stellt dir daraufhin die "NVIDIA X Server Settings" als Auswahl zur Verfügung.
    hier hast du die gleichen Einstellungsmöglichkeiten, wie du sie auch unter Windows gewöhnt bist.

    Ursprünglich ist die Konfiguration von Bildwiederholfrequenzen von Grafikkarten und Monitoren in einzelnen Dateien des Linuxsystems explizit definiert worden. Diese Konfigurationen sind sehr aufwändig gewesen, da man die technischen Details sehr genau kennen musste, um sich sein Grafiksystem nicht zu zerschießen.
    Heute wird das größtenteils über den Grafiktreiber und Standardwerte selbst gesteuert. Bei Bedarf könnte aber spezifische Eigenschaften deines Monitors weiterhin in den Dateien eingetragen werden.

    Ohne, dass du genau weißt, was du tust, würde ich dir empfehlen, die Finger davon zu lassen und mit den grafischen Konfigurationsmöglichkeiten vorlieb zu nehmen ;)

    Cheers, Bogi

    ----- @dd it -----

    Ich würde dir empfehlen, es über die nvidia Einstellungen zu probieren. Ich gehe mal davon aus, dass diese Konfiguration bei dir auf dem Windows System bereits funktioiert (Dual Link DVI Kabel und Auflösung von 1920x1080)

    Damit du dich nicht vertun kannst, hier ein Link zu der Beschreibung (mit Screenshot) an der du die Konfiguration vornehmen musst. Wichtig ist, dass die Auflösung nicht auf Auto gestellt werden, sonder explizit mit dem einzig gültigen Wert angegeben werden. Nur dann kannst du die Refreshrate auch einstellen.
    144hz Screens mit Linux
    IRC war gestern, ... heute haben wir den Chat

    realize your tasks, then take a deep breath and go for it!

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Bogomir () aus folgendem Grund: Anpassungen gemäß Forenregeln

  • taker-` schrieb:

    ... dual link dvi kabel ... nutze aber displayport...
    ich habe einfach mal in das Manual zu deinem Monitor geschaut und dort festgestellt, dass nur eine einzige Auflösung mit der hohen Bildwiederholfrequenz unterstützt wird. Auf etlichen Webseiten wird über die Probleme diskutiert, dass der Monitor nicht mit der maximalen Taktfrequenz angesprochen werden kann. Die Lösung lag fast immer am verwendeten Kabel.

    Wichtig ist auch, dass die Ausgabe bei der hohen Frequenz nicht in 1080P erfolgt, sondern nur in 1080. Schau mal in dein Manual, dort findest du die Angaben bei den angegebenen Auflösungen. Von dort habe ich auch die Angabe zu dem empfohlenen Kabel.

    Solltest du dein Handbuch verlegt haben, findest du es online hier: VG248QE Handbücher

    Wenn unter Windows die hohe Frequenz erreicht wird, hast du dort ja alles richtig eingestellt. Mit den Hilfestellungen meines letzten Posts (Screenshot in verlinkter Webseite) sollte das auch auf deiner Ubuntu Box kein Problem sein.

    Cheers, Bogi
    IRC war gestern, ... heute haben wir den Chat

    realize your tasks, then take a deep breath and go for it!
  • habe mir mal eben die anleitung angeschaut. dort steht
    1920x1080* (DVI/DP) 144Hz 158,11KHz (2D)
    --> zu dem *
    * Hinweis: Sie müssen eines der „*“ Timings für die Aktivierung der 3D oder 144HzFunktionen mit einer kompatiblen NVIDIA-GPU Grafikkarte über eine Dual-Link DVIKabelverbindung auswählen.

    das verstehe ich jetzt nicht. was ist mit timings gemeint? die 144hz? 3d vision kit v2 hab ich zwar, nutz es aber gar net. und wenn ich im windows bin klappt mit dem displayport kabel alles wunderbar. 1920x1080@144hz. weil bei dem sternchen ja steht, das man ein duallink dvi kabel nehmen muss, ich aber trotzdem n displayportkabel hab und es ja geht.

    also kurze rede, langer sinn. wenn ich von der arbeit später daheim bin, dann werd ich es einfach mal testen. ich hoffe ja mal, falls dann mein monitor net mehr geht oder so, kann ich es normalerweise wieder "reparieren", wenn ich über die live version von ubuntu boote und dort in den configs zu dem nvidia einfach wieder auf 60hz runterstelle.

    oder geht das dann doch nicht so einfach? bzw. im endeffekt, schließ ich den monitor dann halt doch mit dvi an und net mit displayport. dann sollte es ja so oder so gehen?!


    mfg
    Nein, ich bin nicht die Signatur...Ich putz` hier nur... -.-
  • nunja, ... es ist relativ einfach wieder herzustellen, wenn man den Weg kennt, aber mach dir keine Gedanken, die Modi sind ja verifiziert - und somit wird das auch funktionieren.

    falls was schiefläuft, bootest du das Śystem ohne grafische Anmeldung und meldest dich auf der Konsole an. Mit dem folgenden Befehl:
    nvidia-settings -l

    öffnest du die grafische Konfiguration der nvidia Karte ohne, dass die grafische Umgebung dabei gestartet wird. Damit kannst du ggf. fehlerhafte Einstellungen zurücksetzen.Quelle: nvidia settings

    In der Tabelle stand ja ausdrücklich zu der Auflösung auch DP, das bedeutet Displayport. Du hast also alles richtig gemacht.

    Viele Vergnügen mit deiner Ubuntu - Box
    Gib bitte kurz Bescheid, wenn alles geklappt hat. Wenn die Probleme alle gelöst sind, kannst du hier auch den Thread schließen ;)

    Cheers, Bogi
    IRC war gestern, ... heute haben wir den Chat

    realize your tasks, then take a deep breath and go for it!
  • natürlich hab ich wieder ein problem xD habe mit sudo nvidia-settings den gui gestartet. dort die auflösung auf 1920x1080 gestellt und auf 144hz. und in ner datei abgespeichert in /home/*username*/.nvidia-settings/

    hat geklappt. nach nem neustart wars wieder auf auto, auflösung und hertz. also wieder auf 60hz.

    danach hab ich mal in die
    sudo nano /etc/X11/xorg.conf geschaut.so sieht die bei mir aus

    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 361.42 (buildd@lgw01-18) Tue Apr 5 14:33:28 UTC 2016



    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
    EndSection


    Section "Files"
    EndSection


    Section "InputDevice"


    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "InputDevice"


    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection


    Section "Monitor"


    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Ancor Communications Inc VG248"
    HorizSync 30.0 - 160.0
    VertRefresh 50.0 - 150.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce GTX 980 Ti"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "Stereo" "0"
    Option "nvidiaXineramaInfoOrder" "DFP-2"
    Option "metamodes" "1920x1080_144 +0+0"
    Option "SLI" "Off"
    Option "MultiGPU" "Off"
    Option "BaseMosaic" "off"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    dort steht doch aber 1920x1080_144 +0+0 - wieso geht das nach dem reboot des pcs nicht mehr?


    mfg
    Nein, ich bin nicht die Signatur...Ich putz` hier nur... -.-
  • ... weil du die nvidia settings mit sudo als root aufgerufen hast.

    Ruf die nvidia settings wie in einem meiner vorherigen posts beschrieben als Normalbenutzer auf, dann wird es in der lokalen Konfiguration des Benutzers gespeichert.

    Wie unter Windows gilt hier auch,... zuviel root tut nicht gut ;)

    Cheers, Bogi
    IRC war gestern, ... heute haben wir den Chat

    realize your tasks, then take a deep breath and go for it!
  • hab ich. passiert das selbe. speichert nicht. nachm reboot is wieder beides auf auto gestellt. :(

    //edit: habe eben nochmal auf fhd und 144 gestellt. gespeichert. dass pw eingegeben, wegen den privilegien. gui beendet und nochmal gestartet und sogar da war es gleich wieder auf auto gestellt. wie, wenn es gar net gespeichert hätte, oder die falsche file geladen hätte.
    Nein, ich bin nicht die Signatur...Ich putz` hier nur... -.-
  • Hallo taker,

    es sieht ganz so aus, als ob dein Arbeiten mit "sudo nvidia-settings" die Berechtigungen an den Konfigurationsdateien geändert hat, so dass sie zwar weiterhin lesbar, aber nicht überschreibbar sind.

    Lass mich mal ein wenig etwas Grundsätzliches zu diesem Thema erklären.

    1. X-Server allgemein

    Die grafische Oberfläche auf Unix/Linux Systemen wird durch eine sogenannte X-Server Technologie umgesetzt. Dieser X-Server läuft auf deinem lokalen System und ihm ist es egal, welche Grafikkarte, Monitor und Maus du an deinem Computer angeschlossen hast.
    Bei bestimmten Grafikkarten werden Treiber für die passenden X-Server zur Verfügung gestellt. Also kannst du dir einen X-Server als Äquivalent zu deiner Windows10 Oberfläche vorstellen und die Konfiguration deiner Grafikkarte so wie die Treiberinstalltion unter Windows.

    Dieses X-Server System bringt eine globale Konfigurationsdatei mit, die Grundwerte für das gesamte System beinhaltet (also quasi so eine Art Vorlage für alle Benutzer, die sich an deinem Linuxsystem anmelden. Diese Datei liegt im Standard hier:

    /etc/X11/xorg.conf

    Auf diese Datei hat im Standard nur der Superuser root (den du mit sudo aufrufst) volle Zugriffsrechte. Alle anderen Benutzer haben ausschließlich Leserechte, was völlig ausreicht.

    Mit dem folgenden Befehl kannst du überprüfen, wie die Berechtigungen auf dieser Datei aussehen:

    ls -lisa /etc/X11/xorg.conf

    Die Ausgabe auf der Konsole sollte dabei wie folgt aussehen:

    -rw-r--r-- 1 root root 1333 Nov 30 2016 /etc/X11/xorg.conf

    die "RW" Kombinationen ganz am Anfang zeigen an, welche Zugriffsrechte dort bestehen.
    r = lesen
    w = schreiben
    x = ausführen

    die ersten drei Zeichen beziehen sich auf den Besitzer dieser Datei (in diesem Fall root)
    die zweiten drei Zeichen beziehen sich auf alle Personen, die in der angegebenen Gruppe sind (in diesem Fall auch root)
    die dritten drei Zeichen beziehen sich auf alle weiteren Personen, die auf dieses System zugreifen können.

    In diesem Fall darf der Besitzer root also lesen und schreiben, alle Personen der Gruppe root nur lesen und alle anderen auch nur lesen.

    2. Nvidia X-Server im Besonderen

    Durch die Installation des nvidia X-Servers auf deinem System wird auch die globale Vorgabedatei /etc/X11/xorg.conf um den notwendigen Treiber und deine erkannte Grafikkarte erweitert.
    Durch den Aufruf der nvidia-settings (ein Programm, welches mit dem nvidia X-Server mitgeliefert wird) wird im Wurzelverzeichnis des Anwenders eine lokale Konfigurationsdatei angelegt, dessen Eintragungen die Werte der globalen Datei übersteuern.

    du kannst dir die Berechtigungen der Datei ganz einfach auf der Konsole ansehen:
    ls -lisa .nvidia-settings-rc

    Die Ausgabe sollte ungefähr so aussehen (ich habe die Gruppe und den Usernamen verallgemeinert:
    10227806 12 -rw-rw-r-- 1 user1 gruppe1 909 Jun 20 12:26 .nvidia-settings-rc

    Auch hier sehen die Berechtigungen ähnlich wie bei der globalen Konfigurationsdatei aus, nur das hier der Benutzer "user1" ist und die Gruppe "gruppe1!

    Wenn diese Datei statt dem Benutzer "user1" dem Benutzer root gehört, hast du die Konfiguration mit sudo gestartet und die Datei dann in das lokale Benutzerverzeichnis gespeichert.

    Wirf bitte mal einen kurzen Blick in diese nvidia Settings Webseite und zwar speziel auf das Kapitel Problemlösungen.

    Ich würde dir raten, dein System von ggf. fehlerhaften Konfigurationsdateien zu befreien, neu zu starten und danach die nvidia-settings als ganz normaler Benutzer ohne Root berechtigung (also ohne sudo) zu öffen und nach den vorgenommenen gewünschten Einstellungen zu speichern.

    überprüfe bitte die Berechtigungen auf den folgenden Dateien .nvidia-settings-rc und monitors.xml durch die Befehle:
    ls -lisa ~/.nvidia-settings-rc
    ls -lisa ~/.config/monitors.xml

    in jedem Fall sollte dein lokaler Benutzer der Besitzer dieser Dateien sein (und nicht etwa root)

    wenn die 2. Datei nicht vorhanden ist, ist das kein Fehler!

    Folgende Dateien müssten dabei gelöscht werden (du kannst sie auch gerne ubenennen, wenn du magst)

    rm ~/.nvidia-settings-rc

    rm ~/.config/monitors.xml

    sollten die Dateien wie oben geprüft root Berechtigungen haben, kannst du für die rm (remove) Befehle ein sudo mit folgendem Leerzeichen voranstellen, also etwa so:

    sudo rm ~/.nvidia-settings-rc

    nachdem dein System neu gestartet wurde, sind die Vorgabeeinstellungen deines X-Servers (also die in /etc/X11/xorg.conf) gültig.

    durch Aufruf von nvidia-settings als Benutzer ohne Root berechtigungen erzeugst du die gerade gelöschte .nvidia-settings-rc Datei neu

    Eigentlich ist ein kompletter Neustart des Systems gar nicht notwendig, es reicht ein Durchstarten des X Servers, aber bevor ich das erklärt habe, ist der Neustart schon durch :D


    Viel Erfolg bei der Bereinigung

    Cheers, Bogi

    ----- @dd it -----

    so, ... ich habe bei mir auf dem Laptop mal alles durchgetestet und kann schon mal sagen, dass du mit deinen Konfigurationen nichts falsch gemacht hast. Die Änderungen in der Auflösung werden, damit sie Gültigkeit bekommen in die globale Datei /etc/X11/xorg.conf geschrieben. Dafür ist eine Legitimation als root notwendig

    Die drei ausschlaggebenden Bereiche in der xorg.conf sind:
    • Monitor
      hier sind die angegebenen horizontal und vertikal Refresh Frequenzen wichtig
    • Device
      hier wird der zu ladende Treiber (X-Server) angegeben. Das Device muss hardwaremäßig den Monitor in der gewünschten Weise ansprechen können
    • Screen
      hier werden die vorherigen beiden Punkte miteinander verknüpft. Die Option mit den Metamodes sollte eigentlich die korrekte Wiederholfrequenz aktivieren


    Somit ist die von dir oben angegebene xorg.conf völlig korrekt. Wenn nach einem Systemneustart in dieser Datei die gleichen Werte weiterhin vorhanden sind, ist eigentlich alles korrekt

    Bei meinen Versuchen auf meinem System startet ein erneuter Aufruf der nvidia X-Server settings die ursprünglich gespeicherten Einstellungen



    ============================== Lösung =================================

    also gut, ... manche Konfigurationen werden tatsächlich vom jeweiligen Serverprogramm nur zur Laufzeit ausgelesen und aktiviert (merkwürdigerweise scheint es hier mit der Bildwiederholrate der Fall zu sein)
    Die Problembeschreibung und auch die dazugehörige Lösung findet sich hier: Ubuntu Wiki: RandR

    Das für dich relevante Kapitel beginnt mit "Hilfe zur Selbsthilfe"

    Du müsstest jetzt 3 Dinge tun:
    1. die von dir benötigten Werte herausfinden
    2. die Befehle auf der Konsole ausführen und kontrollieren, ob der gewünschte Effekt auftritt (Aktivierung der 144 Hz)
    3. wenn das alles funktioniert hat, im Verzeichnis ~/.config/autostart eine neue Textdatei erstellen, die die auszuführenden Befehle enthält.


    Also zum Punkt 1:
    der folgende Konsolenbefehl gibt dir die aktuelle Hardwarekonfiguration aus:
    xrandr --query

    Ausgabebeispiel:
    Screen 0: minimum 8 x 8, current 1920 x 1200, maximum 8192 x 8192
    LVDS-0 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 367mm x 230mm
    1920x1200 59.95*+
    DP-0 disconnected (normal left inverted right x axis y axis)
    DP-1 disconnected (normal left inverted right x axis y axis)

    Erklärung: das bedeutet, dass bei mir auf dem Ausgabegerät LVDS-0 die aktuelle Auflösung 1920x1200 mit 59,95 Hz eingestellt ist. Wichtig ist auch, dass bei dir die Ausgabe ggf. auf DP-0, oder DP-1 erfolgt. Das wäre dann anders als bei mir dargestellt. Auch die Auflösung wird vermutlich eine Andere sein (die mit dem * gekennzeichnete ist die Aktive)

    Der folgende Part bezieht sich auf das Kapitel Auflösung:

    Du möchtest eine Einstellung haben, in der die folgende Auflösung genutzt wird: 1920x1080 in 144 Hz. Dafür muss auf der Konsole der folgende Befehl eingegeben werden:
    cvt 1920 1080 144

    Ausgabebeispiel (das spuckt meine Konfiguration aus, bitte nutze unbedingt und ausschließlich deine eigenen zurückgegebenen Werte):
    # 1920x1080 143.88 Hz (CVT) hsync: 169.35 kHz; pclk: 452.50 MHz
    Modeline "1920x1080_144.00" 452.50 1920 2088 2296 2672 1080 1083 1088 1177 -hsync +vsync

    Erklärung:
    die Werte in der Zeile, die mit "Modline" beginnt enthält die Werte, die du benötigst

    Jetzt weiter zum Punkt 2:
    in der Konsole müssen jetzt die folgenden drei Befehle mit deinen eigenen Werten ausgeführt werden:
    xrandr --newmode "1920x1080_144.00" 452.50 1920 2088 2296 2672 1080 1083 1088 1177 -hsync +vsync
    xrandr --addmode DP-0
    xrandr --output DP-0 --mode "1920x1080_144.00"

    Erklärung: der neue Modus wird dem Server bekanntgegeben, danach auf der Ausgabe des Displayports DP-0 hinzugefügt und danach aktiviert
    Ganz wichtig: nimm bei der newmode Zeile ausschließlich deine oben selbst herausgefunden Werte und nicht die Werte aus diesem Beispiel
    Ganz wichtig: in den Zeilen addmode und output wähle bitte den Port, der dir oben bei xrandr --query angegeben wurde (bei mir wäre das LVDS-0, bei dir vermutlich DP-0)

    jetzt kontrolliere die Bildwiederholfrequenz deines Monitors (z.B. mit xrandr --query)

    hat alles gut funktioniert kommt jetzt der Schritt 3
    • wechsel in das Verzeichnis ~/.config/autostart
      cd ~/.config/autostart
    • erzeuge eine leere Datei namens 144hz und öffne sie zum Bearbeiten mit dem folgenden Konsolenbefehl:
      xedit 144hz
    • füge die folgenden Werte in die Datei ein (durch eigene Werte ersetzen)
      #!/bin/sh
      xrandr --newmode "1920x1080_144.00" 452.50 1920 2088 2296 2672 1080 1083 1088 1177 -hsync +vsync
      xrandr --addmode DP-0
      xrandr --output DP-0 --mode "1920x1080_144.00"
    • Klicke erst auf Save und dann auf Quit um die Datei zu sichern
    • mach die neue Datei ausführbar
      chmod 700 144hz
    Fertig

    ab jetzt solltest du nach jeder Neuanmeldung deinen Monitor in der passenden Refreshrate eingestellt haben.
    IRC war gestern, ... heute haben wir den Chat

    realize your tasks, then take a deep breath and go for it!

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Bogomir ()

  • Danke für den hilfreichen Text. Werde mich darum nach der Arbeit kümmern. Jetzt habe ich aber ein anderes Problem.

    Hatte eben ins Windows gebootet und da ne Runde CS gezockt. Da ich die USB Soundkarte dran hatte, hat Windows die Treiber installiert. Nachm zocken hab ich n Neustart gemacht und ich bin wieder ganz am Anfang. Kein bootmenü.

    Habe dann mit liveusb wieder ins Ubuntu gebootet. Dort habe ich mir dann eine win10 ISO gebrannt und wollte dort über die Eingabe Aufforderung den bootmanager reparieren, ohne Erfolg, obwohl es so immer funktionierte.

    Dann habe ich mir nochmal ne super grub 2 disk bzw. USB Stick erstellt. Wenn ich dort Versuch zu booten, findet es nix mehr zum booten. Der Bildschirm bleibt einfach schwarz.

    Was ist denn jetzt wieder passiert?!




    Mfg - Gesendet mit meinem Huawei P9 Lite
    Nein, ich bin nicht die Signatur...Ich putz` hier nur... -.-
  • Hallo taker,

    es sieht so aus, als ob der Bootsektor des Hauptsystems wieder mal defekt ist.

    Da das jetzt schon wieder passiert ist, würde ich dir doch dringend empfehlen, den Bootsektor deines Linuxsystems nicht mehr in den Hauptbootsektor zu schreiben

    Meine Empfehlung hierzu hast du ja bereits im folgenden Post: meine Empfehlung

    Auch ich habe auf meinem 17" MacbookPro ein Dualboot System installiert, muss allerdings zugeben, dass ich, seit ich Ubuntu drauf habe nur noch 1 mal ins MacOS gebootet habe, um zu kontrollieren, ob es noch funktioniert ;)

    sorry wegen der Umstände

    Cheers, Bogi
    IRC war gestern, ... heute haben wir den Chat

    realize your tasks, then take a deep breath and go for it!
  • achwas, nicht so schlimm. macht ja spaß. ich teste gerne rum. blos nervt es, das windows dabei kaputt geht ;)
    wie gesagt, bin bei linux recht neu und da hab ich mir schon gedacht, das es zu sowas kommen kann :D

    ich habe den bootsektor bei der ubuntu installation, also grub2? auf meine hdd installiert und nicht auf die ssd, deshalb wundert mich es, dass auch windows net mehr bootbar ist, auch mit der grub2disk net?
    hatte bei der installation explizit sda2 gewählt, da sda oder sda1 halt die ssd ist/war.


    mfg
    Nein, ich bin nicht die Signatur...Ich putz` hier nur... -.-