IIS läuft nicht :(

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • IIS läuft nicht :(

    Nabend,

    also ich hba hier ein kleines Problem. Ich hab grad IIS auf meinem Winxp media center edition installiert, aber es will nicht so richtig laufen.

    Also der Server ist gestartet und ich kann mich auch anpingen. Leider kann ich durch die eingabe von localhost nicht auf mein wwwroot zugreifen (es befinden sich index.html und test.asp in ihm)

    Ich habe gerade keine Software Firewall laufen und sitze hinter nem Router.
    Hat jemand ne Idee?

    Greetz
    "let's give him something nobody can take away from him!"
    "what, my dude?"
    "multiple fractures!"
    [SIZE=1].alexander 'alex' de large - clockwork orange[/SIZE]
  • Ja, bei Microsoft ist alles etwas anders. Der IIS erwartet, dass die erste Seite DEFAULT.HTM heisst (oder DEFAULT.ASP) und nicht INDEX.HTML.
    Das kannst du in der IIS-Konfiguration auch ändern (in der Verwaltungsgruppe INTERNETDIENSTE MANAGER und dann ab in die Eigenschaften der Standardwebsite).

    Grüße
    Michael
  • kelzoo schrieb:

    Ja, bei Microsoft ist alles etwas anders. Der IIS erwartet, dass die erste Seite DEFAULT.HTM heisst (oder DEFAULT.ASP) und nicht INDEX.HTML.
    Das kannst du in der IIS-Konfiguration auch ändern (in der Verwaltungsgruppe INTERNETDIENSTE MANAGER und dann ab in die Eigenschaften der Standardwebsite).

    Grüße
    Michael


    Hatte ich schon vorher geändert ;)

    Kleiner NAchtrag: Wenn ich anstatt von Localhost einfach meinen Computernamen eintippe, dann geht es. Zumindest werden HTML-Seiten angezeigt. ASP funzt immer noch nicht :(
    "let's give him something nobody can take away from him!"
    "what, my dude?"
    "multiple fractures!"
    [SIZE=1].alexander 'alex' de large - clockwork orange[/SIZE]
  • Wieso nimmst net einfach Apache?!? Das ist viel einfacher zum konfigurieren und um einiges sicherer! Bist du dir überhaupt über die Sicherheitslücken von dem Schrott informiert --> wenn nicht, lass es!! Kenn einen Bug, mit dem man deine ganzen Dateien einsehen kann (ja, auch den Inhalt der Dateien) und den gesamten Zugriff auf dein Sys hat!!
    Es wäre echt schwachsinnig, wenn du das nicht weißt das Teil online zu stellen!!
    greetz
    N1GHT-ÿ
    [size=1][font="Fixedsys"][/size]
  • Lieber N1GHT-R1D3R, dass Apache möglichersweise besser ist, mag zwar stimmen, hilft dOOfy aber nicht bei seinem Problem.

    Also: dass der Rechnername geht, aber nicht localhost ist sehr ungewöhnlich. Versuch mal in einer Eingabeaufforderung, ob ein ping localhost funktioniert. Falls nicht, hat dein PC keine 127er Adresse. Das Abzustellen geht aber nur in der Registry ?!? Oder hast in der Website-Konfiguration einen entsprechenden Filter eingeschaltet (Seite Verzeichnissicherheit, Rubrik "Beschränkungen für IP-Adressen")?

    ASP geht nicht: welche Sprache benutzt du in deinen ASP-Skripten? VB-Script? Normalerweise genügt es, wenn der Windows-Scripting-Host installiert ist. Aber Skripte müssen in der Konfiguration der Webseite erlaubt sein. Prüf das mal (Seite Basisverzeichnis).

    Grüße
    Michael
  • Jo, dass du localhost nicht aufrufen kannst ist sehr sehr merkwürdig.

    Sollte ein Ping auf localhost nicht funktionieren, dann probiere 127.0.0.1 aus. Funktionierts auf die IP, dann schaue in deiner HOSTS Datei im %systemroot%\system32\drivers\etc Verzeichnis nach, ob dort

    Quellcode

    1. 127.0.0.1 localhost


    drinne steht. Ansonsten nochmal melden...

    cya