FLi4L-Router und ICQ file transfers

  • geschlossen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • FLi4L-Router und ICQ file transfers

    Hi!

    Weiß zufällig jemand, was ich bei FLI4L einstellen muss damit die ICQ File transfers (wieder) funktionieren? Hab davon voll keinen peil... ;)









    mfg freax :hot:
  • Kannst du nie Files verschicken oder nur bei manchen Usern ?

    Bei mir ist das Problem, wenn ein anderer ne Firewall hat, dann klappts nicht mit der Verschickerei.

    Ansonsten hat ich mit dem Router und ICQ noch keine Probleme.
  • muss nicht an der firewall hängen

    hast du ipchains oder iptables ?
    ist das wirklich nur die disk version ?
    machst du icq über nen proxy oed rdirekt über ipforward (gateway)
    versuchs einfach mal ohne firewall ich könnte mir vorstellen das dann auch nix geht!


    mfg :hy:
    Neulinge * Forenregeln * F.A.Q. * Lexikon
    Suchfunktion * IRC * User helfen User

    The price of freedom is eternal vigilance!
  • Also ich hab ipchains und die one disk version! Damit geht eigentlich alles ausser eben die file transfers bei icq..

    Wenn ich die ports wüsste könnte ichs vielleicht hinbekommen.. aber die will mir ja keiner sagen....
  • Stell mal in den Einstellungen von ICQ folgendes ein:

    Connections-> Server

    Dann setzt Du den Punkt bei Using Firewall und Not using Proxy

    Das sollte klappen, bei mir geht es und ich habe auch den Fli4l One Disk Router

    Sonst geh mal auf die Seite von denen da steht auch noch was zu dem Thema ICQ und Files senden bzw. empfangen

    Fli4l

    So habe was gefunden dazu:



    Ich kann im ICQ keine Dateien empfangen,Chats annehmen usw. Woran liegt das?

    Das liegt an dem Prinzip von NAT (siehe oben). Im ICQ Client müssen folgende Einstellungen vorgenommen werden.
    preferences:connections:general: Permanent Connection,ICQ will determine IP automatically.
    preferences:connections:server: using firewall, not using proxy
    preferences:connections:user: not using proxy, use the following ports ( 5010 - 5030 )
    In der portfw.sh müssen die Ports 5010-5030 auf den Client weitergeleitet werden.

    Jetzt einmal probieren, ob der Filetransfer bzw. Chat schon funktionieren. Falls nicht, bitte folgende Schritte ausführen:

    a.)
    ICQ -> Main -> Preferences -> Connections -> User
    (das Fenster wo auch die Ports angegeben werden)
    Using Proxy -> Socks 4 auswählen und ICQ neustarten
    (nicht fragen warum, ist ein ICQ-Bug)


    b.)
    ICQ -> Main -> Preferences -> Connections -> User
    - Not using Proxy (Einstellung wie zuvor) und ICQ neustarten
    - Use the following TCP listen port for incoming event
    - 5010 - 5030


    c.)
    ICQ -> Main -> Preferences -> Connections -> Firewall
    - keine Einträge


    Ab jetzt sollte ICQ auf den angegebenen Ports lauschen und der Datentransfer funktionieren.
    Mit "netstat -a" (ohne ") unter Windows werden die aktiven Ports aufgelistet. Einer aus dem angegebenen Portbereich sollte nun sichtbar sein.



    Hier noch etwas falls Du ICQ 2001b hast


    Fli4l 2.0x und ICQ 2001b sollten bereits installiert sein ;)

    1.) Einstellungen für Fli4l Version 2.01

    in der config\base.txt (Beispiel)

    # Masquerading:
    ---------------
    MASQ_NETWORK='192.168.0.0/24' # networks to masquerade (e.g. our LAN)
    MASQ_MODULE_N='2' # load n masq modules (default: only ftp)
    MASQ_MODULE_1='ftp' # ftp
    MASQ_MODULE_2='icq' # icq (use with caution!)

    # Optional package: PORTFW
    #
    # If you set OPT_PORTFW='yes', you can also edit opt/etc/portfw.sh
    #----------------------------------------------------------------------------
    OPT_PORTFW='yes' # in-stall port forwarding tools/modules
    PORTFW_N='1' # how many portforwardings to set up
    PORTFW_1='5010-5030 192.168.0.2 tcp' # Ip-Nummer vom PC mit ICQ

    (Anmerkung: ich habe die Ports bei mir jetzt auf 5010-5014 eingeschränkt und noch keine Probleme
    damit bekommen)

    Nach den Änderungen eine neue Diskette erstellen bzw. die Dateien mit Imonc übertragen
    und den Router neu starten.

    (Alternativ kann das Portforwarding auch in der portfw.sh eingestellt werden, siehe hier)

    2.) Einstellungen in ICQ 2001b:

    Main/Preferences/ Connections / Server
    - Using Firewall
    - Not using Proxy

    Main/Preferences / Connections / Firewall
    - keine Einträge

    Main/Preferences / Connections / User
    - Not using Proxy
    - Use the following TCP listen port for incoming event
    - 5010 - 5030

    Jetzt einmal probieren, ob der Filetransfer bzw. Chat schon funktionieren.
    Falls nicht, bitte folgende Schritte ausführen:

    a.)
    ICQ -> Main -> Preferences -> Connections -> User (das Fenster wo auch die Ports angegeben werden)
    - Using Proxy -> Socks 4 auswählen und ICQ neustarten (nicht fragen warum, ist ein ICQ-bug )

    b.)
    ICQ -> Main -> Preferences -> Connections -> User
    - Not using Proxy (Einstellung wie zuvor) und ICQ neustarten
    - Use the following TCP listen port for incoming event
    - 5010 - 5030

    c.)
    ICQ -> Main -> Preferences -> Connections -> Firewall
    - keine Einträge

    Ab jetzt sollte ICQ auf den angegebenen Ports lauschen und der Datentransfer funktionieren.
    Mit "netstat -a" (ohne ") unter Windows werden die aktiven Ports aufgelistet. Einer aus dem
    angegebenen Portbereich sollte nun sichtbar sein.