einfach mal reinschauen bitte!!!

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • einfach mal reinschauen bitte!!!

    Hi!

    ich weiß nicht wie ich das am besten erklären soll was ich machen soll.
    ok ich habe eine seite komplett in flash!
    diese seite hat einen rahmen und links ein menu in der mitte dieses rahmen erscheint der text wenn man auf einen button klickt. ganz oben habe ich so eine art tabelle darunter der text.wie kann ich das jetzt machen wenn man auf ein word in dieser tabelle klickt das unten dazu die erklährun erscheint.bzw kann ich das machen sowie bei einer html seite da kann ich ankerpunkte setzen zu denen man spint wenn man 1 button klickt. habt ihr eine idee wie ich das am besten machen könnte???

    Danke
  • Hy layla!

    Ich könnte dir vielleicht helfen nur weiß ich nicht wie du die seite bis jetzt aufgebaut hast! Wenn du mir das zeigen, erklären oder so kannst, kann ich dir wahrscheinlich helfen!

    mfg
    brucky :hot:

    PS: hab gar nicht gewusst das du auch aus Österreich bist! :D
  • ok
    ich hab links ein menu einen rahmen in dem der text erscheint.meine texte sind alle in mc´s .ich rufe sie mit root.gotoandplay(bildnum) ab.
    also ich habe im hauptfilm eine ebene auf auf den frames 5,10,15... der text ist.und ober dem habe ich eine ebene mit jeweils einem stop auf 5,10,15...!
    wie steuer ich jetzt am besten die die unter buttons an die man findet bei manchen texten findet?
    ich hab es genau so versucht wie bei den andern das geht aber nicht!

    ich hoffe das hilft dir weiter!

    Ps: ändert das was?bist du auch aus Ö?
  • ???

    kannst du die swf nicht mal uppen ... ??

    normalerweise kannst du in _root auf rechts auf dein button klicken und dann aktion ....
    dann:
    on (release)
    {
    gotoAndPlay(5)
    }
    das würde frame 5 der aktuellen szene also root abspielen ... meinst du so was??

    und das mit dem text .. bei nem on mouse over, kannst du doch einfach den button doppelt klicken .. und dann auf "Auf" den text noch ein wenig weiter unten hinlegen...also so ca. 70 px von den button entfernt, da wird der ja auch im movie angezeigt!
  • ja wo soll ich es denn uppen?

    ich weiß nicht genau wie ichs dir erklähren soll
    aber bei meinem hauptmenu rufe ich den text mit roo_gotoandplay(5) aber dann hab ich ja dieses untermenu das per loadmovie der text abgerufen wird!

    gibt mir mal deine email dann kann ich dir ja die swf oder die fla schicken!
  • ähh...duhh...schnubbi...

    sagt dir diese grafik: unter meinem beitrag was??? ;D :P

    klar, schick mal die swf wenn du die fla nicht rausgeben willst ... wenn dir das egal ist, dann schick mir halt auch mal die fla ;)

    ps: du machst ne hp und hast noch keinen webspace???

    dann guck mal hier ;)


    edit
    hups .. oh, sorry, wusste nicht, dass das bei euch auf dem board so mit dem mails gelöst ist ;) :(

    [email protected]
  • wie? welcher link??

    also wenn du zu faul bist, ein ftp prog zu starten und die swf bei dir auf den space zu legen, dann kann man dir auch nicht helfen!

    der link war dafür, weil ich dachte du hättest noch gar keinen webspace! ;)

    bzw. der andere link ist meine mail addy
  • ja, hab die files :D

    du kannst das doch genau so machen, wie du die buttons links belegt hast .. einfach einen frame in _root dafür freimachen und dann ist dein problem gelöst .. wenn es nur das mit den automarken war ....

    hab ich das soweit richtig verstanden?

    ps: dann ist auch diese überlagerung weg, wenn du erst alfa anklickst und dann audi ...
    wenn du die loadmovie aktion aber behalten willst solltest du dir mal über die unload movie function gedanken machen ;)
  • eigentlich ist mein problem wenn ich jetzt auf chiptuning gehe und dann auf alfaromeo klicke und dann doch wieder zurück auf chiptuning will kommt kein text!und wenn ich von alfa auf home will überlagern sich die texte!

    hast du eine ahnung wie ich das lösen könnte??
    muss ich auf home ein unload movie tun?

    wenn du willst kann ich dir ja mal den as für alle buttons posten!
  • dann mach es doch einfach so, dass du für jeden text ein frame auf _root hast!!!

    dann machst du auf jedem button nur ein kleines as von wegen
    on (release)
    {
    gotoAndPlay(home)
    }
    usw. .. gib den frames am besten namen, ist dann übersichtlicher!

    das ist die sicherste lösung und auch die einfachste!
    sonst schick einfach mal die fla ...
  • ok also ich hab ja die buttons home,chiptuning,tachtuning,kundenbreich.....
    auf diesen habe ich den as root_gotoandplay(hom,chip...)
    auf der bühne habe ich eine ebene fenster auf frame 5 habe ich den text von home auf frame 10 den text von chip!darüber eine ebene auf der bei den fames 5,10,15 ein stop liegt!
    so komme ich von home auf chiptuning ohne das sich der text überlagert!
    nur dann habe ich ja das untermenu unter chiptuning mit den automodellen. auf alfaromeo habe ich den as on (release) {
    _root.chip.gotoAndPlay (5);
    loadMovieNum ("alfatext.swf", 1);
    }

    ok so bekomme ich den alfatext ohne das der chiptext da ist!
    ok soweit so gut.nur will ich jetzt vom alfatext zurück auf den chiptext.klick ich ja links im menu auf chiptuning.nur dann kommt nichts!warum??
  • das kann ich dir ohne die fla nicht sagen :(

    und wieso willst du denn das unbedingt mit diesem doofen loadmovie realisieren?
    ich meine, wenn du ne file inclusion machst, dann rentiert sich das doch nur, wenn der inhalt dynamisch ist ... und das ist er bei dir im der "alfatext.swf" nicht!

    schick mal die fla, oder mach es einfach so, wie ich oben gesagt habe:
    dann mach es doch einfach so, dass du für jeden text ein frame auf _root hast!!!

    dann machst du auf jedem button nur ein kleines as von wegen
    on (release)
    {
    gotoAndPlay(home)
    }
  • ich habe das mit load movie gemacht weil das sonst nicht gefunkt hat mit dem unter menu und das er den text läd!
    weil ich habs so probiert wie mit den andern buttons aber das ging nicht!
    sonst schick ich dir mal die fla und du änderst es mal und schickst es zurück ok!
  • also ich hab jetzt um button chiptuning das gemacht was du gesagt hast!aber es hat sich nichts verändert!
    wenn ich auf alfa bin und auf chiptuning will dann komme nichts!
    könntest du das mal in der fla die ich dir geschickt habe ändern und mir dann bitte zurück schicken damit ich sehe was du meinst bzw obs bei dir geht!?

    Danke :bounce:
  • es ist ganz egal, ob du den frame 5 mit chip benennst und anschließend mit chip oder 5 ansprichst ..
    wenn du ein string an die funktion übergibst musst du den nur in "string" setzen und wenn du nen int wert and die funktion übergibst musst du den nicht in irgendeiner art escapen!

    der übersichtlichkeit wegen nimmst du besser strings, wenn es aber gar nicht klappen sollte - das hatte ich mal - dann nimm einfach die int werte der frames!

    wichtig ist nur, dass du von dem button auch auf den richtigen frame springst ;)