Kein Connect über mySQLAdmin

  • geschlossen
  • MySQL

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Kein Connect über mySQLAdmin

    Habe hier ein Linux Server mit Debian Sarge und Kernel 2.6.8-2-386, dort wurde Gestern mySQL-client mySQL-server und mySQL-common in der Vers. 4.0.24-2 installiert.
    root PW wurde gesetzt mittels:

    Quellcode

    1. /usr/bin/mysqladmin -u root password 'meinpassword'
    in /etc/mysql wurde die my.cnf angepasst das ich eben über mySQLAdmin auf den server zugreifen kann.
    Aber ich bekomme eben beim connect immer diese Fehlermeldung:

    Quellcode

    1. MySQL Error Number 1130
    2. Host 'WINKISTE' is not allowed to connect to this MySQL server


    Hat jemand vielleicht einen Tip :confused:
  • es schaut so aus, als ob der user 'root' nicht die erlaubnis hat von nem anderen pc aus sich auf die DB zu verbinden!
    versuch mal auf dem server eine verbindung zu machen! also lokal!
    oder gehe ich falsch in der annahme, dass 'winkiste' ein PC in deinem netzwerk ist und nicht der hoster des mysql-servers ist!?

    ceeyaa.MeX
  • Ich kann mich lokal auf den mySQL server connecten.

    Der SQL-Server läuft auf Linux (IP 192.168.0.2), will aber von einem Windows Rechner (IP 192.168.0.4) mittels mySQLAdmin connecten.
  • mySQL wurde überapt-get installiert und da wurde bei der Inst. nichts angegeben oder abgefragt. Das was angegeben wurde ist eine kleine Änderung in der my.cnf und der Option

    Quellcode

    1. SKIP-NETWORKING


    so weit bin ich ja, das der Port 3306 bei mir im Netzwerk offen ist. Meinen Admin kann ich leider nicht fragen, die Pfeiffe.
    • bin ich selbst
    • und in Sachen mySQL und der Gleichen ein BLUTIGER Anfänger

    Jetzt stellt sich mir halt die Frage, wie es weitergeht :confused: ausser :read:
  • verbinde dich lokal auf den server! dann hast du eine DB mysql, dann eine table user! hier musst du einen datensatz fuer host % und user root und restliche felder alle Y anlegen!
    dann DB server neu starten und der connect sollte mal hinhauen!
    hoffe fuer dich, dass du eine graphische oberflaeche hast, wenn ned dann musst du alles in der shell machen, d.h. du musst mittels SQL befehle arbeiten! ^^

    ceeyaa.MeX
  • MeX schrieb:

    verbinde dich lokal auf den server! dann hast du eine DB mysql, dann eine table user! hier musst du einen datensatz fuer host % und user root und restliche felder alle Y anlegen!
    dann DB server neu starten und der connect sollte mal hinhauen!

    Ja, das ist doch mal was :D damit kann ein Anfänger doch wenigstens mal was mit anfangen :D

    MeX schrieb:


    hoffe fuer dich, dass du eine graphische oberflaeche hast, wenn ned dann musst du alles in der shell machen, d.h. du musst mittels SQL befehle arbeiten! ^^
    zu Spät :löl:
  • Habe eben, da ich das auf dem SQL-Server lockal nicht hinbekommen habe die User-Rechte zu ändern (wen wundert's :boing: ) phpmyadmin installiert.
    Über phpmyadmin kann ich jetzt auf den Server connecten und in die Datenbanken Reinschauen, und siehe da in der Spalte "Host" Zeile "TuxServer" ist für den "User" root überall ein 'Y' gesetzt.
    Desweiteren wurde in /etc/hosts meine Windows Kiste eingefügt, und trotzdem habe ich von meinem Windows Rechner über mySQLAdmin keinen Zugriff auf den SQL-Server. :confused:

    MeX schrieb:

    *nachdenk* was meinst du damit!?


    Na, das ich keine Graphische oberfläche Installiert habe :löl:
  • *gg* k ... alles klar!

    in der table usermuessen 2 datensaetze/eintraege fuer user root sein!
    einmal mit host localhost und einmal mit host %!!
    falls das sein sollte und der winkisten-connect trotzdem nicht hinhaut, dann mach mal einen eintrag in der table host!!

    und vergiss' nicht, den DB Server neu zu starten!!

    ceeyaa.MeX