Homepage online stellen!!!

Status
Für weitere Antworten geschlossen.

Rapfabrik

Registered +
Registriert
Juli 2008
Beiträge
256
Hy leute


ich wollte eben meine Offline Homepage online stellen da ich es mit Hilfe Joomla geschafft habe fertig zu bekommen.

Nun habe ich mich bei Funpic angemeldet und wollte halt meine Seite hochladen auf Joomla mit Filezilla habe mich angemeldet bei Filezilla aber nun kommt das Problem! Es funktioniert nicht :(

auf meiner Seite kommt nur die Datei die ich hoch geladen habe aber nicht der Designe usw...habe gegoogel und enteckt da man die config ein bisschen umstellen muss stimmt das? Oder lade ich was falsches hoch? bin echt ein Anfänger und würde mich um eine Hilfe freuen!

Da ich ein Anfänger bin würde ich mich unheimlich freuen eine eigene Homepage zu haben^^ die ich dann natürlich von Tag zu tag verbessern werde!


Danke MFG
 
ich war auch mal bei funpics, aber das hat überhauptnicht funktioniert.
geh zu KiLu.
da hast du 1 Gb speicher, es ist werbefrei, du kannst PHP benutzen UND DU HAST 5 mySQL datenbanken umsonst.

und das der die designs nicht mit hochläd liegt warscheinlich daran, dass du nicht alle dateien ausgewählt hast.
du musst ALLE dateien, die in dem ordner sind wo du das abgespeichert hast hochladen(bei kilu.de in den "WWW"-ordner, damit das im internet gezeigt werden kann).

mfg, ejone.next
 
Zuletzt bearbeitet von einem Moderator:
Hi,

leg dir lieber nen Account an bei Kilu oder bplaced.net.

Da ich davon ausgehe, dass es bei dir Offline lief, muesste es keine Probleme geben.

Rapfabrik schrieb:
habe gegoogel und enteckt da man die config ein bisschen umstellen muss stimmt das?

Jep. Nachdem du alles hochgeladen hast, musst du mal in der Config.php schauen nach: DB Username, DB Password und DB Name so in der Art sollte es heißen, hab keine config.php von joomla grad da. DB Host sollte normal localhost bleiben. Diese 3 Sachen editieren und anpassen mit den Daten die du von dem Hoster bekommen hast (steht im user cp) und dann sollte es einwandfrei laufen.

kevin
 
Danke für eure Hilfe Leute

ich habe mich nun bei bplaced angemeldet und nun mein Filezilla geöffnet und mich halt in meiner neuen leeren Homepgae eingeloggt .

drinnen waren schon 3 Ordner: filemana... , Mysql... , Pgsqla... , wo soll ich meine daten jetzt hochladen?

Einfach so hochladen oder muss es in bestimmten Ordner rein?

Danke für eine Antwort


MFG

Edit: das ist meine config. was muss ich da nun ändern?
Code:
class JConfig {
var $offline = '0';
var $editor = 'tinymce';
var $list_limit = '20';
var $helpurl = 'http://help.joomla.org';
var $debug = '0';
var $debug_lang = '0';
var $sef = '1';
var $sef_rewrite = '1';
var $sef_suffix = '1';
var $feed_limit = '10';
var $gzip = '0';
var $error_reporting = '-1';
var $xmlrpc_server = '0';
var $log_path = 'C:\\xampp18\\htdocs\\Joomla150\\logs';
var $tmp_path = 'C:\\xampp18\\htdocs\\Joomla150\\tmp';
var $live_site = '';
var $offset = '0';
var $caching = '0';
var $cachetime = '15';
var $cache_handler = 'file';
var $memcache_settings = array();
var $ftp_enable = '0';
var $ftp_host = '127.0.0.1';
var $ftp_port = '21';
var $ftp_user = '';
var $ftp_pass = '';
var $ftp_root = '';
var $dbtype = 'mysql';
var $host = 'localhost';
var $user = 'root';
var $db = 'joomla150';
var $dbprefix = 'jos_';
var $mailer = 'mail';
var $mailfrom = ';
var $fromname = ;
var $sendmail = '/usr/sbin/sendmail';
var $smtpauth = '0';
var $smtpuser = '';
var $smtppass = '';
var $smtphost = 'localhost';
var $MetaAuthor = '1';
var $MetaTitle = '1';
var $lifetime = '30';
var $session_handler = 'database';
var $password = '';
var $sitename = '';
var $MetaDesc = '';
var $MetaKeys = 'zzzzzzzzzzzzzzzzzzzzzzzzz';
var $offline_message = 'Diese Website ist zurzeit im Wartungsmodus. Bitte kommen Sie später wieder.';
}
?>
 
Zuletzt bearbeitet von einem Moderator:
Rapfabrik schrieb:
drinnen waren schon 3 Ordner: filemana... , Mysql... , Pgsqla... , wo soll ich meine daten jetzt hochladen?

Einfach so hochladen oder muss es in bestimmten Ordner rein?

Jep, einfach da rein. Beachte die 3 anderen einfach nicht ;)

Und an der Config.php musste nur folgende Sachen aendern:

Rapfabrik schrieb:
var $log_path = 'C:\\xampp18\\htdocs\\Joomla150\\logs';
var $tmp_path = 'C:\\xampp18\\htdocs\\Joomla150\\tmp';

nick.bplaced.net/logs und /tmp rein

Rapfabrik schrieb:
var $ftp_host = '127.0.0.1';
var $ftp_port = '21';
Port wird 21 sein und bei ftp host "nickname.bplaced.net". ggf. noch FTP username & PW eingeben jedoch sehe ich keinen sinn warum man das braucht?!

Rapfabrik schrieb:
var $host = 'localhost';
var $user = 'root';
var $db = 'joomla150';
[...]
var $password = '';

host sollte localhost bleiben, $user editiern, $db editieren und $password sollte auch das DB passwort rein. Sollte dann denk ich alles sein. Hab noch nie Joomla installiert aber so vom theoretischen her muesste das richtig sein.

Dann vom localhost nen DB Backup machen (wuerd ich mysqldumper nehmen) und dann auf der HP wiederherstellen.

Noch Fragen? :) Falls ja, einfach stellen..

kevin
 
ok jetzt habe ich es so gemacht:
Alels mit xxxx habe ich geändert!!!
Code:
class JConfig {
var $offline = '0';
var $editor = 'tinymce';
var $list_limit = '20';
var $helpurl = 'http://help.joomla.org';
var $debug = '0';
var $debug_lang = '0';
var $sef = '1';
var $sef_rewrite = '1';
var $sef_suffix = '1';
var $feed_limit = '10';
var $gzip = '0';
var $error_reporting = '-1';
var $xmlrpc_server = '0';
var $log_path = 'xxxxxxx.bplaced.net\\logs';
var $tmp_path = 'xxxxxx.bplaced.net\\tmp';
var $live_site = '';
var $offset = '0';
var $caching = '0';
var $cachetime = '15';
var $cache_handler = 'file';
var $memcache_settings = array();
var $ftp_enable = '0';
var $ftp_host = 'xxxx.bplaced.net';
var $ftp_port = '21';
var $ftp_user = 'xxxxxxx';
var $ftp_pass = 'xxxxxxxxx';
var $ftp_root = '';
var $dbtype = 'mysql';
var $host = 'localhost';
var $user = 'xxxxxx';
var $db = 'joomla150';
var $dbprefix = 'jos_';
var $mailer = 'mail';
var $mailfrom = 'hendrik-boss@hotmail.com';
var $fromname = 'Freestyle-Rap';
var $sendmail = '/usr/sbin/sendmail';
var $smtpauth = '0';
var $smtpuser = '';
var $smtppass = '';
var $smtphost = 'localhost';
var $MetaAuthor = '1';
var $MetaTitle = '1';
var $lifetime = '30';
var $session_handler = 'database';
var $password = 'xxxxxxxx';
var $sitename = 'Freestyle-Rap';
var $MetaDesc = 'Freeystyle-Rap ...weil das dein Leben verändert';
var $MetaKeys = 'zzzzzzzzzzzzzzzzzzzzzzzzz';
var $offline_message = 'Diese Website ist zurzeit im Wartungsmodus. Bitte kommen Sie später wieder.';
}
?>


Sorry das ich jetzt so blöd frag aber was kommt bei DB (datebase) ?
Bin echt ein Noob bei sowas !!!

Und sonst ist alles richtig oder?
 
Zuletzt bearbeitet von einem Moderator:
Sorry das ich jetzt so blöd frag aber was kommt bei DB (datebase) ?

Der Name der Datenbank.

Und ja, der rest sieht denk ich richtig aus, nur hier:

var $log_path = 'xxxxxxx.bplaced.net\\logs';
var $tmp_path = 'xxxxxx.bplaced.net\\tmp';

sollte etwa so aussehen:

var $log_path = 'http://xxxxxxx.bplaced.net/logs';
var $tmp_path = 'http://xxxxxx.bplaced.net/tmp';


Siehste ja dann, aber ansonsten sollte alles stimmen ;)

kevin
 
Danke erstmal wieder um deine Hilfe

wenn ich auf meiner Homepage ( .. bplaced.net ..) raufgehe dann kommt das hier :

Database Error: Unable to connect to the database:Could not connect to database

importieren und exportieren habe ich auch schon..
 
Hallo Rapfabrik,

hast du nun auch die Datenbank rüberkopiert? Er scheint diese ja nun nicht zu finden - entweder du hast dich in den Datenbankdaten vertippt oder die datenbank existiert einfach nicht.

Gruß Justus
 
also meiner meinung nach muss man in PHPmyAdmin die datenbak importieren und nicht hochladen...

mfg,ejone.next
 
ejone.next schrieb:
also meiner meinung nach muss man in PHPmyAdmin die datenbak importieren und nicht hochladen...

ahja und was ist nun der Unterschied dazwischen? Beim Importieren wird die Datenbank hochgeladen und dort eingefuegt.

Zu dem Error:

Ich tippe eher darauf, dass die MySQL Daten falsch sind, user/pass/db ansonsten wuerde er connecten oder nen anderen error anzeigen.

kevin
 
Abend,

Ich habe nun diese Video Anleitung intensiv befolgt und es hat mir leider auch nicht weitergeholfen :( fehlt vielleicht noch irgend was?

Wenn ich das eingebe

1. (meine nickname).bplaced.net : diese fehlermeldung :

Parse error: syntax error, unexpected T_LNUMBER, expecting T_FUNCTION in /users/(nickname)/www/configuration.php on line 40


aber ich glaube localhost muss ich ändern oder? weil im video erwähnt er doch das man unbedigt denn localhost ändern muss! Wenn ja was muss ich dann da eingeben?

Hier nochmal wie es bei mir zur zeit ausschaut:

Code:
class JConfig {
var $offline = '0';
var $editor = 'tinymce';
var $list_limit = '20';
var $helpurl = 'http://help.joomla.org';
var $debug = '0';
var $debug_lang = '0';
var $sef = '1';
var $sef_rewrite = '1';
var $sef_suffix = '1';
var $feed_limit = '10';
var $gzip = '0';
var $error_reporting = '-1';
var $xmlrpc_server = '0';
var $log_path = 'http://[nickname].bplaced.net/logs';
var $tmp_path = 'http://[nickname].bplaced.net/tmp';
var $live_site = '';
var $offset = '0';
var $caching = '0';
var $cachetime = '15';
var $cache_handler = 'file';
var $memcache_settings = array();
var $ftp_enable = '0';
var $ftp_host = '[nickname].bplaced.net';
var $ftp_port = '21';
var $ftp_user = '[nickname].bplaced.net';
var $ftp_pass = '[mein password]';
var $ftp_root = '';
var $dbtype = 'mysql';
var $host = 'localhost';
var $user = '[nickname]';
var $db = '[nickname]';
var $dbprefix = 'jos_';
var $mailer = 'mail';
var $mailfrom = '[meine email]';
var $fromname = '[MEINE HOMEPAGE]';
var $sendmail = '/usr/sbin/sendmail';
var $smtpauth = '0';3
var $smtpuser = '[nickname]';
var $smtppass = '[password]';
var $smtphost = 'localhost';
var $MetaAuthor = '1';
var $MetaTitle = '1';
var $lifetime = '30';
var $session_handler = 'database';
var $password = '';
var $sitename = '[Meine Homepage]';
var $MetaDesc = '[meine Homepage] ... ';
var $MetaKeys = '';
var $offline_message = 'Diese Website ist zurzeit im Wartungsmodus. Bitte kommen Sie später wieder.';
}
?>



MFG Rapfabrik
 
Zuletzt bearbeitet von einem Moderator:
Dein Fehler kommt daher:
Code:
var $smtpauth = '0';3
Die 3 hat da nichts zu suchen.

Ach und poste PHP-Code bitte in
PHP:
 oder [code] Tags. Und das Passwort ($secret) brauch auch niemand wissen. :rolleyes:

Gruß
Broken Sword
 
@ Danke Broken Sword werde ich nächstes mal machen ;)

aber nun kommt diese Fehlermeldung O_o

"c Database Error: Unable to connect to the database:Could not connect to MySQL "

Was heißt das denn schon wieder :( ?
 
lol... was könnte diese Fehlermeldung wohl bedeuten? oO

vielleicht, dass er nicht zur MySQL DB verbinden kann?!

Nein, bestimmt nicht :rolleyes:


überprüf mal ob du die richtigen Logindaten angegeben hast!


mfg Undeath
 
Ja meine Daten habe ich 10 x abgechekt !!! Die sind richtig !!!

Verstehe ich echt nicht.... ist doch alles ok!!! Offline Modus hat es ja 1A funktioniert!!!

Hoffe jemand hat noch ein tipp der mich weiterhelfen könnte!


P.S. Glaub hier muss was verändert werden oder?

Code:
var $dbtype = 'mysql';


Edit:

Habe gerade das in googel gefunden:

Zitat:

Joomla setzt dort ja automatisch "localhost" ein, in letzter Zeit gab es ab und an Hoster die den mySQL-Server auslagern, was dann verständlicherweise zu einem anderen Pfad führt. Der genaue Pfad zur Datenbank sollte im Kundenpanel, wo die Datenbank angelegt und bearbeitet wird ersichtlich sein. Ansonsten mal mit einer netten Mail beim Support des Hosters nachfragen.


was könnte sonst bei:

Code:
var $smtphost = 'localhost';


ersetzt werden.
 
Zuletzt bearbeitet von einem Moderator:
localhost stimmt bei bplaced, aber hast du auch den DB-Namen und das DB-Passwort von der bplaced MySQL-DB angegeben?

ich hab das gefühl du versuchst Joomla auf deine lokal installierte DB zugreifen lassen zu wollen


mfg Undeath
 
P.S. Glaub hier muss was verändert werden oder?

Code:
var $dbtype = 'mysql';

Nö. MySQL Datenbank Typ ist MySQL. Das muss so bleiben.


was könnte sonst bei:

Code:
var $smtphost = 'localhost';


ersetzt werden.

Oehm nix? smtphost hat mit der MySQL Datenbank nichts, aber auch gar nichts zu tun.

Wenn dann musste das aendern:

var $host = 'localhost';

Aber warum sollte der DB host nicht localhost sein? Sicher das alle Dateien die bei dir Offline im Ordner liegen hochgeladen sind? MySQL Daten von bplaced.net genommen?

Und joomla sollte errors auch normal besser ausgeben und nicht nur einfach "konnte nicht mit db verbinden.." eh nen schlechtes CMS.

kevin
 
OK! jetzt habe ich alles wieder gelöscht und alles wieder hoch geladen!!!

Nun bekomme ich diese Fehlermeldungen:

de
Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /users/kifbis/www/configuration.php:1) in /users/kifbis/www/libraries/joomla/session/session.php on line 412

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /users/kifbis/www/configuration.php:1) in /users/kifbis/www/libraries/joomla/session/session.php on line 412

Warning: Cannot modify header information - headers already sent by (output started at /users/kifbis/www/configuration.php:1) in /users/kifbis/www/libraries/joomla/session/session.php on line 415

Aber jetzt kommt zwar wenn ich nickname.bplaced.net/administrator der Backend Login aber kann mich dennoch nicht anmelden ! Und ich habe die richtigen login daten angegeben habe es noch 10x abgechekt im config. !

Also diese Fehlermeldungen kommen auch beim Login fürn backend die werden oben angegeben!

Kann mir jemand dabei weiter helfen?


Edit:

Ach ja ich habe auch einen zweiten config . der eibbisschen anders aussieht als der erste:


/**
* @version $Id: configuration.php-dist 314 2008-07-22 16:53:53Z sisko1990 $
* @package Joomla
* @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
* @license GNU/GPL, see LICENSE.php
* Joomla! is free software and parts of it may contain or be derived from the
* GNU General Public License or other free or open source software licenses.
* See COPYRIGHT.php for copyright notices and details.
*
* -------------------------------------------------------------------------
* DIESES SOLLTE NUR ALS LETZTE MÖGLICHKEIT BENUTZT WERDEN, WENN DER INSTALLER FEHLSCHLÄGT
*
* Wenn Sie Joomla! manuell installieren, z.B. nicht über den Web-Installer,
* dannt benennen Sie diese Datei in configuration.php um, z.B.
*
* UNIX -> mv configuration.php-dist configuration.php
* Windows -> rename configuration.php-dist configuration.php
*
* Ab hier können Sie die Datei und die Parameter Ihrer Site und Datenbank
* konfigurieren.
*/
Code:
class JConfig {
/**
* -------------------------------------------------------------------------
* Bereich: Konfiguration der Webseite
* -------------------------------------------------------------------------
*/
/* Seiten-Einstellungen */
var $offline = '0';
var $offline_message = 'Diese Webseite ist wegen technischer Wartung vorübergehend nicht verfügbar.
Bitte versuchen Sie es später wieder.';
var $sitename = 'Joomla!'; // Name der Joomla!-Seite
var $editor = 'tinymce';
var $list_limit = '20';
var $legacy = '0';

/**
* -------------------------------------------------------------------------
* Bereich: Konfiguration der Datenbank
* -------------------------------------------------------------------------
*/
/* Datenbank-Einstellungen */
var $dbtype = 'mysql'; // Normalerweise: mysql
var $host = 'localhost'; // Normalerweise: localhost
var $user = ''; // MySQL Benutezrname
var $password = ''; // MySQL Passwort
var $db = ''; // MySQL Datenbankname
var $dbprefix = 'jos_'; // Nicht ändern, wenn nicht zwingend nötig!

/* Server-Einstellungen */
var $secret = 'FBVtggIk5lAzEU9H'; // In etwas sicheres ändern
var $gzip = '0';
var $error_reporting = '-1';
var $helpurl = 'http://help.joomla.org';
var $xmlrpc_server = '1';
var $ftp_host = '';
var $ftp_port = '';
var $ftp_user = '';
var $ftp_pass = '';
var $ftp_root = '';
var $ftp_enable = '';
var $tmp_path = '/tmp';
var $log_path = '/var/logs';
var $offset = '0';
var $live_site = ''; // Optional; Vollständige URL zur Joomla!-Installation.

/* Session-Einstellungen */
var $lifetime = '15'; // Session time
var $session_handler = 'database';

/* E-Mail-Einstellungen */
var $mailer = 'mail';
var $mailfrom = '';
var $fromname = '';
var $sendmail = '/usr/sbin/sendmail';
var $smtpauth = '0';
var $smtpuser = '';
var $smtppass = '';
var $smtphost = 'localhost';

/* Cache-Einstellungen */
var $caching = '0';
var $cachetime = '15';
var $cache_handler = 'file';

/* Debug-Einstellungen */
var $debug = '0';
var $debug_db = '0';
var $debug_lang = '0';

/* Meta-Einstellungen */
var $MetaDesc = 'Joomla! - Dynamische Portal-Engine und Content-Management-System';
var $MetaKeys = 'joomla, Joomla';
var $MetaTitle = '1';
var $MetaAuthor = '1';

/* SEO-Einstellungen */
var $sef = '0';
var $sef_rewrite = '0';
var $sef_suffix = '';

/* Feed-Einstellungen */
var $feed_limit = 10;
}
?>

Soll ich damit was zu tun haben bzw. es vielleicht anwenden/verändern?
 
Zuletzt bearbeitet von einem Moderator:
Code:
var $user = ''; // MySQL Benutezrname
var $password = ''; // MySQL Passwort
var $db = '';

da müssen die Logindaten vom bplaced mysql-server hin.

Außerdem solltest du mal Cookies löschen!

Wenn du Joomla bei dir lokal installiert hattest zum testen solltest du nicht die Dateien von dir einfach hochladen, sondern Joomla neu installieren auf dem Webserver!


mfg Undeath

PS: willst du nicht das PW rauslöschen?
 
Zuletzt bearbeitet von einem Moderator:
* Wenn Sie Joomla! manuell installieren, z.B. nicht über den Web-Installer,
* dannt benennen Sie diese Datei in configuration.php um, z.B.

Was ist daran jetzt so schwer zu verstehen? Das nimmst du, wenn du joomla nicht über webinstaller installierst.

Wie gehst du überhaupt vor bei der Installation?
Halte dich genau an die Dokumentation - sieht ja so aus, als ob du einfach drauf los irgendwas machen würdest und das ist immer schlecht.
Joomla! Help Site - Installation Guide

Gruß
Broken Sword
 
Soll ich jetzt wieder joomla ONLINE neu installieren ?

und wie lösche ich die Cookies? meinst du die Internet Cookies oder gibt es andere?


Ich habe joomla ja über denn web.Installer installiert!
 
Zuletzt bearbeitet von einem Moderator:
Status
Für weitere Antworten geschlossen.
Zurück
Oben Unten