Home FTP tut-funzt nicht bei mir

  • Problem

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Home FTP tut-funzt nicht bei mir

    Hallo.
    Also ich wollt mir mal n HomeFTP erstellen fürs uppen und draufziehen lassen.
    So dann hab ich hier im Board die Suche gemacht und das Tut von Taker gefunden und versucht das so zu machen.Aber dann ab dem Punkt 3. mit der einen Website bin ich durcheinander gekommen.Mein Endergebniss sieht so aus:
    ftp://rapmaster:[email protected]:21
    Der User is rapmaster das PW ist rapmaster(aber nich das von der einen HP, dann kommt das HPdingen und dann mein Port.
    PS:Habe einen Router.
    Was muss ich GENAU machen?
    Gruß Blumi!
    [SIZE=1]
    (\_/)
    (o.0)
    (><)
    [/SIZE]
  • blumi91 schrieb:

    Hallo.
    Also ich wollt mir mal n HomeFTP erstellen fürs uppen und draufziehen lassen.
    So dann hab ich hier im Board die Suche gemacht und das Tut von Taker gefunden und versucht das so zu machen.Aber dann ab dem Punkt 3. mit der einen Website bin ich durcheinander gekommen.Mein Endergebniss sieht so aus:
    rapmaster:[email protected]:21
    Der User is rapmaster das PW ist rapmaster(aber nich das von der einen HP, dann kommt das HPdingen und dann mein Port.
    PS:Habe einen Router.
    Was muss ich GENAU machen?
    Gruß Blumi!



    Ich kenn das angesprochene Tutorial nicht aber ich kann soviel sagen:
    Dein user ist: rapmaster
    dein pass ist: uppload
    dein server ist: serveftp.com (ist das sowas wie dyndns??)
    dein port ist: 21

    Diesen Port musst du in deinem Router forwarden. Sonst kann bei dir niemand zugreifen.
  • Jo cool thx für den Tipp.
    Jetzt nur ein Problem was steht da alles und was soll ich da reinschreiben :confused:

    Hier ist mal ein
    Screenshot h**p://www.frag4life.de/walsumer/files/screenshot.bmp
    von der Katastrophe.
    Plz Help.
    THX
    Gruß Blumi!
    [SIZE=1]
    (\_/)
    (o.0)
    (><)
    [/SIZE]
  • Applications Name: My great FTP oder so :D
    Ext. Port: 21
    Protocol: TCP
    Int. Port: 21
    IP Address: da kommt deine Netzinterne IP rein. Also z.B. 192.168.1.50. Eben die IP des PC's auf dem ein FTP-Server laufen soll.
    Enable = Aktivieren.


    Du kannst auch anstatt:
    Ext Port: 21 einen "beliebigen" nehmen. z.b. 53531
    Den musst du dann aber auch in deinem FTP Programm eintragen.
  • Netzinterne IP ist die IP, die einem im Netzwerk vom Router zugeschrieben wird. Es ist die erste IP (IP-Adresse), die man erhält, wenn man in der DOS-Befehlszeile ipconfig eingibt.

    Mal abgesehn davon musst Du folgende Änderungen an Deinem Router machen:
    1. Wenn Du da was findest, was "Virtual Server" heisst, brauchst Du die Firewall nicht zu konfigurieren, weil die dann automatisch konfiguriert wird. Da gibst Du dann folgendes ein:
    Enabled; [Name, damit Dus wiederfindest]; [Private IP:] Deine IP, die Du mit ipconfig rausgesucht hast; [Protocol Type] TCP; [Private Port] 21; [Public Port] 21

    2. In den Firewall Settings folgendes einstellen, wenn Virtual Server Settings nicht vorhanden:
    Enabled; [Name, damit Dus wiederfindest]; Allow; [Source] WAN; [IP Range Start] *; [IP Range End] einfach freilassen;
    [Destination] LAN; [IP Range Start] Deine IP von ipconfig; [IP Range End] Freilassen; [Protocol] TCP; [Port Range] 21-21; [Schedule] Always

    3. Bei Dir im Router unter Advanced -> DDNS Settings folgendes einstellen:
    [Server Address] Adresse des Servers, wo Du Deine Domain hast: In Deinem Fall ist das No-IP.com; [Host name] Der Domainname Deines Servers [Login] Dein Loginname bei no-ip.com [Password] Dein Passwort bei no-ip.com

    ...So und dabei fiel mir dann auf, dass 1. serveftp.com ne Weiterleitung zu no-ip.com ist und 2. dass Du da in Deinem Link oben nicht den Namen Deiner Domain angegeben hast, sondern nur den Servernamen, wo Du Deine Domain hast. Anders ausgedrückt: Eine Domain ist kein Server sondern nur ein Benutzerbereich auf einem Server.
    Du musst in dem Link den vollen Namen angeben - den siehst Du z.B., wenn du dich bei no-ip einloggst und in deinem Account in die Einstellungen gehst; z.b. meinftpserver.serveftp.com wäre ein Domainname - bzw. ein Domainname gliedert sich folgendermaßen als Link auf: [Domain].[server].[Landeskennung/Serverbezeichnung].


    Wenn Du das alles geschafft hast, musst Du nur noch evtl. Deine Software-Firewall so konfigurieren, dass sie ankommende und weggehende Verbindungen auf Deinen Server zugelassen werden.
  • leck mich inne täsch^^
    boa datt funzt imma noch nich oda?
    f*p://rapmaster:[email protected]:21
    probiert mal..müsste n lied druff sein.aber ich glaub ich muss dafür BULLETPROOF FTP SERVER an haben oda?
    mhh thx...
    Gruß Blumi

    *HEUL***
    [SIZE=1]
    (\_/)
    (o.0)
    (><)
    [/SIZE]
  • so viel wie ich weiss, gibg es noch eine NAT/SUA option, zumindestens bei meinem router dem man sagt, das auf deinem rechner ne software läuft, die ne serverfunktion übernimmt, und somit erst bei nat/sua eingetragen sein muss, dass die nach aussen kann.
    bei mir ist das eientlich nur der port, (weils bei mir mit 21 auch net ging hab ich ne portgruppe 19-23 freigegeben) und die ip deines rechners, wo du das programm laufen hast. guck doch ma bitte nach, ob es bei dir sowas auch gibt.

    grüße @dminJ4
  • Auf keinen Fall die Firewall deaktivieren.

    Du solltest die ports 20 und 21 forwarden. Für die Kommunikation braucht bulletproof nämlich beide ports.

    Wenn du den passive mode zulassen willst, dann musst du noch ca. 5 ports freigeben. Also im routermenü forwarden und in bulletproof diese ports unter passive mode eintragen.